Subject: [calsify] VAVAILABILITY, problem with AVAILABLE component

From: Evert Pot <[email-masked]>
Date: Thu, 16 Jul 2015 21:08:49 -0400

Hi guys,

I just ran into the following issue with the VAVAILABILITY spec.
Note the definition of the AVAILABLE component:

          availableprop  = *(
                         ;
                         ; the following are REQUIRED,
                         ; but MUST NOT occur more than once
                         ;
                         dtstamp / dtstart / uid /
                         ;
                         ; either 'dtend' or 'duration' MAY appear
                         ; once, but 'dtend' and 'duration' MUST NOT
                         ; occur in the same 'availableprop'.
                         ; 'duration' MUST NOT be present if 'dtstart'
                         ; is not present
                         ;
                         dtend / duration /
                         ;
                         ; the following are OPTIONAL,
                         ; but MUST NOT occur more than once
                         ;
                         created / description / last-mod /
                         recurid / rrule / summary /
                         ;
                         ; the following are OPTIONAL,
                         ; and MAY occur more than once
                         ;
                         categories / comment / contact / exdate /
                         rdate / x-prop / iana-prop

                         )

It states that DTSTART is REQUIRED, but then it also states:

                         ; 'duration' MUST NOT be present if 'dtstart'
                         ; is not present

which makes no sense. I think it should simply say that either DURATION
or DTEND MUST be specified.

Evert

---

From: Cyrus Daboo <[email-masked]>
Date: Fri, 17 Jul 2015 10:11:08 -0400

Hi Evert,

> or DTEND MUST be specified.

I will copy the text from RFC5545 that is used to define VEVENT:

                  ; Either 'dtend' or 'duration' MAY appear in
                  ; an 'availableprop', but 'dtend' and 'duration'
                  ; MUST NOT occur in the same 'availableprop'.
                  ;
                  dtend / duration /

-- 
Cyrus Daboo

---

From: Evert Pot <[email-masked]>
Date: Fri, 17 Jul 2015 12:29:49 -0400

>                  ; MUST NOT occur in the same 'availableprop'.

I think it should say:

Either 'dtend' or 'duration' MUST appear

An AVAILABILE component without DTEND or DURATION is meaningless as it
would free up no actual time.

Evert