Subject: [calsify] [Technical Errata Reported] RFC5545 (4606)

From: RFC Errata System <[email-masked]>
Date: Tue, 26 Jan 2016 23:44:52 -0800 (PST)

The following errata report has been submitted for RFC5545,
"Internet Calendaring and Scheduling Core Object Specification (iCalendar)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5545&eid=4606

--------------------------------------
Type: Technical
Reported by: Harald Lampke <[email-masked]>

Section: 3.8.8.3

Original Text
-------------
       rstatus    = "REQUEST-STATUS" rstatparam ":"
                    statcode ";" statdesc [";" extdata]

Corrected Text
--------------
       rstatus    = "REQUEST-STATUS" statcode ":"
                    rstatparam ";" statdesc [";" extdata]

Notes
-----
'rstatparam' and 'statcode' are interchanged.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5545 (draft-ietf-calsify-rfc2445bis-10)
--------------------------------------
Title               : Internet Calendaring and Scheduling Core Object Specification (iCalendar)
Publication Date    : September 2009
Author(s)           : B. Desruisseaux, Ed.
Category            : PROPOSED STANDARD
Source              : Calendaring and Scheduling Standards Simplification
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Cyrus Daboo <[email-masked]>
Date: Wed, 27 Jan 2016 09:40:43 -0500

Hi RFC,

> Original Text

This erratum should be rejected.

The original test is correct: "rstatparam" defines the set of allowed 
parameters on the "REQUEST-STATUS" propertY. Parameters always occur 
immediately after the property name and before the ":" that separates the 
property value. The property value is a semi-colon separated structured 
text field with the first component being "statcode".

-- 
Cyrus Daboo