Subject: [calsify] JSCalendar: what to do with JSTask?

From: Robert Stepanek <[email-masked]>
Date: Thu, 30 Aug 2018 11:09:18 +0200

I would like to discuss the status of JSTask and its readiness for acceptance:

The JSCalendar specification defines object types for events, tasks and groups. The event and group objects have underwent years of discussion and there seems to be general consensus of their definition. However, the task object hasn't received that much attention. Much of the definition of JSTtask properties is based on a pending iCalendar VTODO RFC update: https://tools.ietf.org/html/draft-apthorp-ical-tasks-01

With JSTask most likely becoming a standard before its updated iCalendar counterpart, I wonder if the current JSTask specification is all that stable? Is there the risk of  defining a snapshot of an ongoing discussion? If there is, we could split off JSTask from the JSCalendar specification. The current specification should it make easy to define additional object types in separate RFC documents.

Looking forward to your feedback.

Robert

---

From: Michael Douglass <[email-masked]>
Date: Thu, 30 Aug 2018 09:48:18 -0400

In iCalendar and the current JsCalendar much of what makes up a task is 
well defined.

I take the point about some of the newer properties but they're a 
relatively small part of the daft.

However, in other areas we've taken the opportunity to extend the model 
so I don't see these as much different.

I'm currently in the process of developing an app which relies heavily 
on tasks and the ease of translating from tasks to derived events and 
which uses json for messaging. I think this is a vital part of the spec 
and should remain.

On 8/30/18 05:09, Robert Stepanek wrote:
> _______________________________________________
> calsify mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/calsify

---

From: Robert Stepanek <[email-masked]>
Date: Thu, 30 Aug 2018 16:04:36 +0200

> which uses json for messaging. I think this is a vital part of the spec 

I'm happy to hear that the proposed JSTask object is already useful in implementations. My concern is: is it ripe for standardization? It looks to me as if the discussion on a "better VTODO" is split on two draft documents, and it'd be sub-optimal if the two specifications come to different conclusions. I'm not involved in the discussions around VTODO, probably my concerns are unnecessary.

Cheers,
Robert