Subject: [calsify] draft-ietf-calext-eventpub-extensions - styled-description

From: Michael Douglass <[email-masked]>
Date: Fri, 22 Feb 2019 01:46:20 -0500

There has been a sudden upsurge of interest in rich text in calendar 
items and this has resulted in a need to make some changes to the 
styled-description specification.

Given the late stage of the process for this spec I'm not sure how to 
proceed - should I just post a version 11 draft?

To summarize - the changes are:

Add a new parameter: DERIVED=TRUE/FALSE

This will be used on the DESCRIPTION and STYLED-DESCRIPTION properties 
to indicate that the value is derived from a 'master' 
STYLED-DESCRIPTION, i.e one without that parameter or with DERIVED=FALSE

Only one such 'master' will be allowed. This gives us the option of 
providing alternative representations of the rich text in some other 
format. In the case of the DESCRIPTION only plain text is allowed.

Need to remove text suggesting this property be used for language 
variants. Another approach is being considered for that.

I also need to add some text in the security section stating that rich 
text needs to be filtered for malevolent or dubious content.

---

From: Daniel Migault <[email-masked]>
Date: Fri, 22 Feb 2019 13:02:09 +0000

Hi, 

Update the draft. The draft has been sent to the IESG and its current state is AD Evaluation which means that an IETF Last Call has not be sent. Unless Alexey thinks otherwise, I think you can update the draft, changes could have come during the IETF Last Call. 

I understand the changes are refinements, but the question I have for the WG is whether the document needs more discussions in which case we may bring it back to the WG.

Yours, 
Daniel

-----Original Message-----
From: calsify <[email-masked]> On Behalf Of Michael Douglass
Sent: Friday, February 22, 2019 1:46 AM
To: Calsify <[email-masked]>
Subject: [calsify] draft-ietf-calext-eventpub-extensions - styled-description

There has been a sudden upsurge of interest in rich text in calendar items and this has resulted in a need to make some changes to the styled-description specification.

Given the late stage of the process for this spec I'm not sure how to proceed - should I just post a version 11 draft?

This will be used on the DESCRIPTION and STYLED-DESCRIPTION properties to indicate that the value is derived from a 'master' 
STYLED-DESCRIPTION, i.e one without that parameter or with DERIVED=FALSE

Only one such 'master' will be allowed. This gives us the option of providing alternative representations of the rich text in some other format. In the case of the DESCRIPTION only plain text is allowed.

Need to remove text suggesting this property be used for language variants. Another approach is being considered for that.

I also need to add some text in the security section stating that rich text needs to be filtered for malevolent or dubious content.

_______________________________________________
calsify mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/calsify

---

From: Michael Douglass <[email-masked]>
Date: Wed, 27 Feb 2019 23:47:03 -0500

I've submitted draft 11.

In addition to the interest in rich text there was interest in adding a 
parameter to the new structured-location to allow it to be used to 
specify the star and/or end location of the component.

Coincidentally there has been similar interest on the IANA timezone 
list. While that change seems relatively small it may warrant further 
discussion as it has implications on the speicifcation of start and end.

A summary of the changes:

Some minor typos

The DERIVED parameter to indicate a property is derived from some other 
property and should not be modified.

Changes to STYLED-DESCRIPTION to use that property and to clarify and 
state that only one (master) description should exist.

Text on the use of the RELATED parameter for locations.