Subject: Re: [calsify] Shall we meet in Prague? (also: what shall we work on?)

From: "Bron Gondwana" <[email-masked]>
Date: Sun, 03 Feb 2019 10:27:24 -0500

Due to lack of interest... I haven't submitted a request YET! But... it doesn't need to be in until the end of the week, so there's still time. let me know :)

Bron.

On Tue, Jan 29, 2019, at 10:12, Bron Gondwana wrote:
> Hi all,
> 
> It's getting on time to submit meeting requests for the next face-to-face IETF meeting!
> 
> We have two documents that are waiting for revised drafts:
> 
> * eventpub-extensions-10 <https://datatracker.ietf.org/doc/draft-ietf-calext-eventpub-extensions/>
> * caldav-attachments-03 <https://datatracker.ietf.org/doc/draft-ietf-calext-caldav-attachments/>
> 
> As well as the almost ready to go jscalendar:
> 
> * jscalendar-11 <https://datatracker.ietf.org/doc/draft-ietf-calext-jscalendar/>
> 
> I know there's also interest in bringing other items of work to this group. From memory things that I've seen mentioned include:
> 
> * caldav-scheduling-controls (author: me, when I write it up!) - a new header "Scheduling-Enabled: F" to disable all scheduling when storing a resource to a server. Good for restoring from backup as well as a way to avoid sending updates more generally while cleaning up spam, rather than the current "Schedule-Reply: F" which is only for resources where you are not the organizer.
> 
> * caldav-upgrade - a header returned by a server to tell a client that a .ics feed is also available via read-only caldav, allowing clients to use sync-collection for more efficient updates.
> 
> * caldav-push - a method for delivering push updates when a calendar is changed, allowing clients to avoid polling.
> 
> * caldav-server-side-subscriptions - a method for federating caldav calendars (potentially with local cached copy) such that the server acts as a client to another server, aggregating calendars from multiple servers into a single homeset.
> 
> * calendar autodiscovery - I'm not sure if that's coming to this group, or if there's going to be an attempt at renewing the more general service autodiscovery discussion. My notes from last calconnect said it would go to DISPATCH, but I didn't make it to the Monday of Bangkok, so I missed out.
> 
> 
> ....
> 
> Does anybody have any other work that they want to bring to this group, or appetite to work on any of the above? I'd love to get this group flowing smoothly and improving calendaring for everybody! I'll be at CalConnect in Zurich next week, and I'll be asking everyone there to get involved over here as well.
> 
> Submissions for sessions are due Feb 8th at the latest, so do let us know if you'll be present at Prague (or joining remotely) and have something to talk about!
> 
> Cheers,
> 
> Bron (on behalf of the calext chairs)
> 
> 
> --
>  Bron Gondwana, CEO, FastMail Pty Ltd
>  [email-masked]
> 
> 
> _______________________________________________
> calsify mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/calsify
> 

--
 Bron Gondwana, CEO, FastMail Pty Ltd
 [email-masked]

---

From: Michael Douglass <[email-masked]>
Date: Sun, 3 Feb 2019 16:33:46 +0100

I wouldn't call it that: mostly pressing deadlines and an assumption 
we'll talk about it this week - also one of the topics may trigger a 
last minute addition to the eventpub extensions.

When do you arrive?

On 2/3/19 10:27, Bron Gondwana wrote:
> Due to lack of interest... I haven't submitted a request YET!  But... 
> it doesn't need to be in until the end of the week, so there's still 
> time.  let me know :)
>
> Bron.
>
>> * eventpub-extensions-10 
>> <https://datatracker.ietf.org/doc/draft-ietf-calext-eventpub-extensions/>
>> * caldav-attachments-03 
>> <https://datatracker.ietf.org/doc/draft-ietf-calext-caldav-attachments/>
>>
>> * jscalendar-11 
>> <https://datatracker.ietf.org/doc/draft-ietf-calext-jscalendar/>
>>
>> I know there's also interest in bringing other items of work to this 
>> group.  From memory things that I've seen mentioned include:
>>
>> * caldav-scheduling-controls (author: me, when I write it up!) - a 
>> new header "Scheduling-Enabled: F" to disable all scheduling when 
>> storing a resource to a server.  Good for restoring from backup as 
>> well as a way to avoid sending updates more generally while cleaning 
>> up spam, rather than the current "Schedule-Reply: F" which is only 
>> for resources where you are not the organizer.
>>
>> * caldav-upgrade - a header returned by a server to tell a client 
>> that a .ics feed is also available via read-only caldav, allowing 
>> clients to use sync-collection for more efficient updates.
>>
>> * caldav-push - a method for delivering push updates when a calendar 
>> is changed, allowing clients to avoid polling.
>>
>> * caldav-server-side-subscriptions - a method for federating caldav 
>> calendars (potentially with local cached copy) such that the server 
>> acts as a client to another server, aggregating calendars from 
>> multiple servers into a single homeset.
>>
>> * calendar autodiscovery - I'm not sure if that's coming to this 
>> group, or if there's going to be an attempt at renewing the more 
>> general service autodiscovery discussion.  My notes from last 
>> calconnect said it would go to DISPATCH, but I didn't make it to the 
>> Monday of Bangkok, so I missed out.
>>
>>
>> ....
>>
>> Does anybody have any other work that they want to bring to this 
>> group, or appetite to work on any of the above?  I'd love to get this 
>> group flowing smoothly and improving calendaring for everybody!  I'll 
>> be at CalConnect in Zurich next week, and I'll be asking everyone 
>> there to get involved over here as well.
>>
>> Submissions for sessions are due Feb 8th at the latest, so do let us 
>> know if you'll be present at Prague (or joining remotely) and have 
>> something to talk about!
>>
>> Cheers,
>>

---

From: "Bron Gondwana" <[email-masked]>
Date: Sun, 03 Feb 2019 12:47:06 -0500

Late tonight! Assuming my train makes it to the airport on time! I should be at the hotel about 10pm

On Sun, Feb 3, 2019, at 16:34, Michael Douglass wrote:
> I wouldn't call it that: mostly pressing deadlines and an assumption we'll talk about it this week - also one of the topics may trigger a last minute addition to the eventpub extensions.

calsify mailing list

---

From: Daniel Migault <[email-masked]>
Date: Sun, 3 Feb 2019 13:54:44 -0500

If lots of these topics will be discussed at Calconnect, it sounds to me as
an indication that an IETF session would be welcome. Having part of the
discussions at the IETF would help moving proposals forward at the IETF as
it would ease showing these proposals have reached consensus and have
undergone a sufficient number of reviews.

Yours,
Daniel

On Sun, Feb 3, 2019 at 12:47 PM Bron Gondwana <[email-masked]>
wrote:

> I wouldn't call it that: mostly pressing deadlines and an assumption we'll
> talk about it this week - also one of the topics may trigger a last minute
> addition to the eventpub extensions.
>
> When do you arrive?
> Due to lack of interest... I haven't submitted a request YET!  But... it
> doesn't need to be in until the end of the week, so there's still time.
> let me know :)
>
> Bron.
>
> <https://datatracker..ietf.org/doc/draft-ietf-calext-jscalendar/>
>
> * caldav-scheduling-controls (author: me, when I write it up!) - a new
> header "Scheduling-Enabled: F" to disable all scheduling when storing a
> resource to a server.  Good for restoring from backup as well as a way to
> avoid sending updates more generally while cleaning up spam, rather than
> the current "Schedule-Reply: F" which is only for resources where you are
> not the organizer.
>
> * caldav-upgrade - a header returned by a server to tell a client that a
> .ics feed is also available via read-only caldav, allowing clients to use
> sync-collection for more efficient updates.
>
> * caldav-push - a method for delivering push updates when a calendar is
> changed, allowing clients to avoid polling.
>
> calendars (potentially with local cached copy) such that the server acts as
> a client to another server, aggregating calendars from multiple servers
> into a single homeset.
>
> * calendar autodiscovery - I'm not sure if that's coming to this group, or
> if there's going to be an attempt at renewing the more general service
> autodiscovery discussion.  My notes from last calconnect said it would go
> to DISPATCH, but I didn't make it to the Monday of Bangkok, so I missed out.
>
>
> ....
>
> Does anybody have any other work that they want to bring to this group, or
> appetite to work on any of the above?  I'd love to get this group flowing
> smoothly and improving calendaring for everybody!  I'll be at CalConnect in
> Zurich next week, and I'll be asking everyone there to get involved over
> here as well.
>
> Submissions for sessions are due Feb 8th at the latest, so do let us know
> if you'll be present at Prague (or joining remotely) and have something to
> talk about!
>
> Cheers,
>
> calsify mailing [email-masked]://www.ietf.org/mailman/listinfo/calsify
>

---

From: "Bron Gondwana" <[email-masked]>
Date: Sun, 03 Feb 2019 13:56:10 -0500

Ok! I'll chat with Mike tomorrow and also see who can make it to Prague either in person or virtually.

On Sun, Feb 3, 2019, at 19:55, Daniel Migault wrote:
> If lots of these topics will be discussed at Calconnect, it sounds to me as an indication that an IETF session would be welcome. Having part of the discussions at the IETF would help moving proposals forward at the IETF as it would ease showing these proposals have reached consensus and have undergone a sufficient number of reviews. 
> 
> Yours, 
> Daniel
> 
> On Sun, Feb 3, 2019 at 12:47 PM Bron Gondwana <[email-masked]> wrote:
>> __

>>>>> * jscalendar-11 <https://datatracker..ietf.org/doc/draft-ietf-calext-jscalendar/>
>>>>> 
calsify mailing list