Subject: [calsify] JSCalendar: Updated draft-ietf-calext-jscalendar-16

From: "Robert Stepanek" <[email-masked]>
Date: Mon, 24 Jun 2019 15:10:02 +0200

Hi all,

I just updated draft-ietf-calext-jscalendar to version 16: https://tools.ietf.org/html/draft-ietf-calext-jscalendar-16

This update redefines the "isAllDay" property to "showWithoutTime" and allows it for both JSEvent and JSTask, as discussed on this mailing list.

In addition, the draft references RFC 3986 in the security considerations for URIs.

There are no open points remaining and we consider this RFC draft complete, apart from editor review. If you find any point in the document unclear or disputable, please let us know now.

Thanks,
Robert

---

From: Doug Royer <[email-masked]>
Date: Mon, 24 Jun 2019 08:48:42 -0600

> This update redefines the "isAllDay" property to "showWithoutTime" and allows it for both JSEvent and JSTask, as discussed on this mailing list.

I - now understand :-)

> There are no open points remaining and we consider this RFC draft complete, apart from editor review. If you find any point in the document unclear or disputable, please let us know now.

Deep reading starting tomorrow :-)

-- 

Doug Royer - (http://DougRoyer.US)
[email-masked]
714-989-6135

---

From: Marten Gajda <[email-masked]>
Date: Mon, 24 Jun 2019 22:01:57 +0200

Hi Robert,

the location object states:

>    o  name: String (optional, default: empty String).  The human-
>       readable name of the location.
>
>    o  description: String (optional).  Human-readable, plain-text
>       instructions for accessing this location.  This may be an address,
>       set of directions, door access code, etc.
Just out of curiosity, why does "name" default to "empty String", as
opposed to 'no default' like the description?

Is "empty String" the same as "this location has no specific name"?

Cheers,

Marten

Am 24.06.19 um 15:10 schrieb Robert Stepanek:
> Hi all,
>
> I just updated draft-ietf-calext-jscalendar to version 16:
> https://tools.ietf.org/html/draft-ietf-calext-jscalendar-16
>
> This update redefines the "isAllDay" property to "showWithoutTime" and
> allows it for both JSEvent and JSTask, as discussed on this mailing list.
>
> There are no open points remaining and we consider this RFC draft
> complete, apart from editor review. If you find any point in the
> document unclear or disputable, please let us know now.
>
> Thanks,
> Robert
>
> _______________________________________________
> calsify mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/calsify

-- 
Marten Gajda
CEO

dmfs GmbH
Schandauer Straße 34
01309 Dresden
GERMANY

phone: +49 177 4427167
email: [email-masked]

Managing Director: Marten Gajda
Registered address: Dresden
Registered No.: AG Dresden HRB 34881
VAT Reg. No.: DE303248743

---

From: "Robert Stepanek" <[email-masked]>
Date: Tue, 25 Jun 2019 10:05:46 +0200

Hi Marten,

On Mon, Jun 24, 2019, at 10:02 PM, Marten Gajda wrote:
>  Just out of curiosity, why does "name" default to "empty String", as opposed to 'no default' like the description?

> Is "empty String" the same as "this location has no specific name"?

Thanks. I can't think of a good reason, other than an implementation detail of our JSCalendar code.

I'll remove the default empty String from Location.name and keep the property optional.

Cheers,
Robert