Subject: [calsify] question about STYLED-DESCRIPTION in the eventpub extensions document

From: "Tim Hare" <[email-masked]>
Date: Tue, 9 Jul 2019 08:38:33 -0400

Now that I've skimmed through
https://datatracker.ietf.org/doc/draft-ietf-calext-eventpub-extensions/  I
have a question about STYLED-DESCRIPTION, VALUE=TEXT.   Should FMTTYPE be
required in that instance? If it is not required and/or not specified, what
default 'style' SHOULD be applied to the text of the STYLED-DESCRIPTION:  ?
Should it be 'text/plain'  making it essentially DESCRIPTION:  or should
some other format like 'text/markdown' be specified as a default?

Tim Hare
Interested Bystander, Non-Inc.

---

From: Michael Douglass <[email-masked]>
Date: Mon, 15 Jul 2019 15:56:18 -0400

Hi Tim

On 7/9/19 08:38, Tim Hare wrote:
>
> Now that I’ve skimmed through 
> https://datatracker.ietf.org/doc/draft-ietf-calext-eventpub-extensions/ 
> I have a question about STYLED-DESCRIPTION, VALUE=TEXT. Should FMTTYPE 
> be required in that instance? If it is not required and/or not 
> specified, what default ‘style’ SHOULD be applied to the text of the 
> STYLED-DESCRIPTION:  ?  Should it be ‘text/plain’  making it 
> essentially DESCRIPTION:  or should some other format like 
> ‘text/markdown’ be specified as a default?
>
There is this text in the spec:

Applications MAY attempt to guess the media type of the
resource via inspection of its content if and only if the media
type of the resource is not given by the "FMTTYPE" parameter.  If
the media type remains unknown, calendar applications SHOULD treat
it as type "text/html"

> _______________________________________________
> calsify mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/calsify