Subject: Re: [Cellar] [PATCH 1/2] Set VOID Element as multiple in EBML spec

From: Steve Lhomme <[email-masked]>
Date: Sat, 2 Jan 2016 09:53:09 +0100

2015-12-30 14:56 GMT+01:00 Dave Rice <[email-masked]>:
>
>> On Dec 30, 2015, at 8:54 AM, Moritz Bunkus <[email-masked]> wrote:
>>
>> Hey,
>>
>> +1. mkvmerge uses voids a lot, definitely multiple ones per
>> parent. Apart from current, actual use the void's raison d'être is to be
>> able to overwrite existing elements and placing their content somewhere
>> else without invalidating the whole file (and without having to re-write
>> it completely). Therefore voids should be made plural.
>>
>> I wasn't even aware they currently weren't…
>>
>> The patch itself LGTM.

Apart from the patch being in 2 parts, the changes themselves are good.
We should generate new EBML semantic source code after these changes.

> I sent the patch via PR as well. I’m surprised that mkvalidator wasn’t complaining non-stop about this restriction.

That may be because libebml (and libebml2) treat void and nested
elements differently than normal elements. That's something that
should be fixed for nested elements that can only appear once (if that
ever makes sense).

> Dave Rice
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

-- 
Steve Lhomme
Matroska association Chairman

---

From: Dave Rice <[email-masked]>
Date: Sun, 3 Jan 2016 13:11:18 -0500

Hi Steve,

> On Jan 2, 2016, at 3:53 AM, Steve Lhomme <[email-masked]> wrote:
> 

Is it possible/sane to send a single patch that affects two different repositories? Patch 1 is for the EBML draft spec at https://github.com/Matroska-Org/ebml-specification and Patch 2 synchronizes the same change (setting Void to multiple) in https://github.com/Matroska-Org/foundation-source/blob/master/spectool/specdata.xml of the foundation-source repo.

> should be fixed for nested elements that can only appear once (if that

Coincidentally all nested elements in Matroska are also allowed to repeat, so this only affects Void (for now).
Dave

---

From: Steve Lhomme <[email-masked]>
Date: Mon, 4 Jan 2016 08:12:12 +0100

> Is it possible/sane to send a single patch that affects two different repositories? Patch 1 is for the EBML draft spec at https://github.com/Matroska-Org/ebml-specification and Patch 2 synchronizes…

No, you're right.