Subject: [Cellar] EBML Introduction section

From: Dave Rice <[email-masked]>
Date: Sat, 23 Jan 2016 14:36:51 -0500

Each RFC must include an Introduction section to follow the TOC. There is some detail about the requirements here: https://tools.ietf.org/html/rfc7322#section-4.8.1 <https://tools.ietf.org/html/rfc7322#section-4.8.1> and last year there was some initial discussion about this in a github issue: https://github.com/Matroska-Org/ebml-specification/issues/5 <https://github.com/Matroska-Org/ebml-specification/issues/5>.

I used the existing EBML Principle <https://github.com/Matroska-Org/ebml-specification/blob/master/specification.markdown#ebml-principle> section, Moritz's comments <https://github.com/Matroska-Org/ebml-specification/issues/5#issuecomment-99932625>, and my own text to create an introduction section. Comments?

## Introduction

EBML is short for Extensible Binary Meta Language. EBML specifies a binary and octet (byte) aligned format inspired by the principle of XML. EBML itself is a generalized description of the technique of binary markup. Like XML, it is completely agnostic to any data that it might contain. The format is made of 2 parts: the semantic and the structural. The structural part defines how EBML elements may be defined, arranged, and implemented. The semantic part specifies a number of Elements along with their identifier, name, type, and definition. Just like XML, the specific "tags" (IDs in EBML parlance) used in an EBML implementation are arbitrary. However, the semantic of EBML outlines general data types and ID's.

The goal of the EBML Specification is to define a generic, binary, space-efficient format which may be utilized to define more complex formats (such a containers for multimedia content) using an EBML Schema. The definition of the EBML format recognizes the idea behind HTML and XML as a good one: separate structure and semantics allowing the same structural layer to be used with multiple, possibly widely differing semantic layers. Except for the EBML Header and a few global elements this specification does not define particular EBML format semantics; however this specification is intended to define how other EBML-based formats may be defined.

EBML uses a simple approach of building Elements upon three pieces of data (tag, length, and value) as this approach is well-known, easy to parse, and allows selective data parsing. The EBML structure additionally allows for hierarchical arrangement to support complex structural formats in an efficient manner.

Dave Rice

---

From: "Sebastian G. <bastik>" <[email-masked]>
Date: Sat, 23 Jan 2016 21:59:03 +0100

23.01.2016, 20:36 Dave Rice:
> Each RFC must include an Introduction section to follow the TOC.
> There is some detail about the requirements [...]
>
> I used the existing EBML Principle
> <https://github.com/Matroska-Org/ebml-specification/blob/master/specification.markdown#ebml-principle>
> section, Moritz's comments
> <https://github.com/Matroska-Org/ebml-specification/issues/5#issuecomment-99932625>,
> and my own text to create an introduction section. Comments?

Nothing of great importance from my side. Just a few thoughts or
suggestions.

> ## Introduction
> 
> EBML is short for Extensible Binary Meta Language. EBML specifies a
> binary and octet (byte) aligned format inspired by the principle of
> XML. EBML itself is a generalized description of the technique of
> binary markup. Like XML, it is completely agnostic to any data that
> it might contain. The format is made of 2 parts: the semantic and the
> structural. The structural part defines how EBML elements may be
> defined, arranged, and implemented. The semantic part specifies a
> number of Elements along with their identifier, name, type, and
> definition. Just like XML, the specific "tags" (IDs in EBML parlance)
> used in an EBML implementation are arbitrary. However, the semantic
> of EBML outlines general data types and ID's.

The start might be shortened to:

"EBML, short for Extensible Binary Meta Language, specifies a binary and
octet (byte) aligned format inspired by the principle of XML."

> The goal of the EBML Specification is to define a generic, binary,
> space-efficient format which may be utilized to define more complex
> formats (such a containers for multimedia content) using an EBML

'such a' has to be 'such as'. You could also use 'like', although that
gets used often in the section already.

> Schema. The definition of the EBML format recognizes the idea behind
> HTML and XML as a good one: separate structure and semantics allowing
> the same structural layer to be used with multiple, possibly widely
> differing semantic layers. Except for the EBML Header and a few
> global elements this specification does not define particular EBML
> format semantics; however this specification is intended to define
> how other EBML-based formats may be defined.
> 
> EBML uses a simple approach of building Elements upon three pieces of
> data (tag, length, and value) as this approach is well-known, easy to
> parse, and allows selective data parsing. The EBML structure
> additionally allows for hierarchical arrangement to support complex
> structural formats in an efficient manner.
> 
> Dave Rice
> 

--
Sebastian

---

From: Steve Lhomme <[email-masked]>
Date: Tue, 26 Jan 2016 11:29:32 +0100

2016-01-23 20:36 GMT+01:00 Dave Rice <[email-masked]>:
> Each RFC must include an Introduction section to follow the TOC. There is
> some detail about the requirements here:
> https://tools.ietf.org/html/rfc7322#section-4.8.1 and last year there was
> some initial discussion about this in a github issue:
> https://github.com/Matroska-Org/ebml-specification/issues/5.
>
> I used the existing EBML Principle section, Moritz's comments, and my own
> text to create an introduction section. Comments?
>
> ## Introduction
>
> EBML is short for Extensible Binary Meta Language. EBML specifies a binary
> and octet (byte) aligned format inspired by the principle of XML. EBML
> itself is a generalized description of the technique of binary markup. Like
> XML, it is completely agnostic to any data that it might contain.

I would strip that part, or split it.

> The format
> is made of 2 parts: the semantic and the structural. The structural part
> defines how EBML elements may be defined, arranged, and implemented. The
> semantic part specifies a number of Elements along with their identifier,
> name, type, and definition. Just like XML, the specific "tags" (IDs in EBML
> parlance) used in an EBML implementation are arbitrary. However, the
> semantic of EBML outlines general data types and ID's.

Up to here

> space-efficient format which may be utilized to define more complex formats
> (such a containers for multimedia content) using an EBML Schema. The
> definition of the EBML format recognizes the idea behind HTML and XML as a
> good one: separate structure and semantics allowing the same structural
> layer to be used with multiple, possibly widely differing semantic layers.
> Except for the EBML Header and a few global elements this specification does
> not define particular EBML format semantics; however this specification is
> intended to define how other EBML-based formats may be defined.
>
> EBML uses a simple approach of building Elements upon three pieces of data
> (tag, length, and value) as this approach is well-known, easy to parse, and
> allows selective data parsing. The EBML structure additionally allows for
> hierarchical arrangement to support complex structural formats in an
> efficient manner.
>
> Dave Rice
>
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar
>

-- 
Steve Lhomme
Matroska association Chairman