Subject: Re: [Cellar] Menu System in Matroska Files

From: Nithin Mathew Kurien <[email-masked]>
Date: Tue, 9 Feb 2016 13:59:48 +0530

Hello,

Since DVDMenuXtractor is incompatible with the current versions of
MKVToolNix and VLC, and has been out of development for a long time, can we
have a new menu specification for Matroska, designed from scratch if
necessary?

Thanks and regards,
Nithin

On Mon, Jan 25, 2016 at 9:23 PM, Nithin Mathew Kurien <
[email-masked]> wrote:

> Hi,
>
> I downloaded DvdMenuXtractor (rev1295) from
> http://tirnanog.fate.jp/mirror/DvdMenuXtractor/ and tested it on a
> DVD. The program completed execution and output .BAT files along with
> the demuxed tracks. I use the latest versions of MKVToolNix (v.8.8.0)
> and VLC Player (v.2.2.1). When I ran the .BAT files which invoked
> MKVToolNix, most of them aborted execution midway with error. A few of
> them completed, but when I opened the resulting MKV files in VLC, it
> showed the error "VLC can't recognize the input's format:
> The format cannot be detected." It seems that DVDMenuXtractor is not
> working correctly. Is there any way to fix this? Are there some
> example MKV files with menus which I can test in VLC?
>
> Thanks and regards,
> Nithin
>
>
> On Sat, Jan 2, 2016 at 1:49 PM, Steve Lhomme <[email-masked]> wrote:
> > 2015-12-17 11:41 GMT+01:00 Nithin Mathew Kurien <[email-masked]
> >:
> >> Dear all,
> >>
> >> The Matroska specification includes a menu system which is currently
> >> in a draft state (http://matroska.org/technical/menu/index.html).
> >> Currently there are no open-source players supporting this feature.
> >
> > Yes, VLC can handle Matroska files with DVD menus extracted using
> > DVDMenuXtractor:
> > https://github.com/Matroska-Org/dvdmenuxtractor
> >
> > This was a project meant to demonstrate that Matroska menus are
> > possible. It was never finished though as not all DVD commands were
> > translated into Matroska menus. It was also done ~10 years ago and
> > support in VLC might be broken by now.
> >
> > The idea was to be able to keep all the information contained in a DVD
> > ISO, but in a different format.
> >
> >> But there is at least one proprietary format, namely PGMX, a variant
> >> of MKV, that includes a working menu. These files are created by a
> >> proprietary TMPGENC PGMX creator and played by a freeware TMPGENC PGMX
> >> player. A PGMX file also supports including multiple related titles
> >> inside a single file. Opening this file on open-source players will
> >> play it as a normal MKV file without menus. There are some samples
> >> given in their website
> >> (http://tmpgenc.pegasys-inc.com/en/download/tpxp.html).
> >>
> >> I think the menu feature would be a good idea to implement in Matroska
> >> files and humbly request for the same. I think this feature would be
> >> useful for content authors who would like to distribute their works
> >> freely under a Creative Commons license, for example, who would
> >> otherwise have to adopt proprietary formats like DVD and Blu-ray. I
> >> understand that implementing a menu system from scratch might involve
> >> some complexity. In that case, would it be possible to adopt some
> >> features from the open-source libdvdnav and libbluray?
> >>
> >> Thanks and regards,
> >> Nithin
> >>
> >> _______________________________________________
> >> Cellar mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/cellar
> >
> >
> >
> > --
> > Steve Lhomme
> > Matroska association Chairman
>

---

From: Dave Rice <[email-masked]>
Date: Tue, 9 Feb 2016 09:39:02 -0500

> On Feb 9, 2016, at 3:29 AM, Nithin Mathew Kurien via Matroska-devel <[email-masked]> wrote:
> 
> Hello,
> 
> Since DVDMenuXtractor is incompatible with the current versions of MKVToolNix and VLC, and has been out of development for a long time, can we have a new menu specification for Matroska, designed from scratch if necessary?

From scratch is a bit daunting. Would the dvdauthor menu xml format serve as a good starting point?
Dave Rice

> Thanks and regards,
> Nithin
> 
> 
> On Mon, Jan 25, 2016 at 9:23 PM, Nithin Mathew Kurien <[email-masked] <mailto:[email-masked]>> wrote:
> Hi,
> 
> http://tirnanog.fate.jp/mirror/DvdMenuXtractor/ <http://tirnanog.fate.jp/mirror/DvdMenuXtractor/> and tested it on a
> On Sat, Jan 2, 2016 at 1:49 PM, Steve Lhomme <[email-masked] <mailto:[email-masked]>> wrote:
> > 2015-12-17 11:41 GMT+01:00 Nithin Mathew Kurien <[email-masked] <mailto:[email-masked]>>:
> >> Dear all,
> >>
> >> in a draft state (http://matroska.org/technical/menu/index.html <http://matroska.org/technical/menu/index.html>).
> > https://github.com/Matroska-Org/dvdmenuxtractor <https://github.com/Matroska-Org/dvdmenuxtractor>
> >
> >> (http://tmpgenc.pegasys-inc.com/en/download/tpxp.html <http://tmpgenc.pegasys-inc.com/en/download/tpxp.html>).
> >>
> >> [email-masked] <mailto:[email-masked]>
> >> https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>
> >
> >
> >
> > --
> > Steve Lhomme
> Matroska-devel mailing list
> [email-masked]
> http://lists.matroska.org/cgi-bin/mailman/listinfo/matroska-devel
> Read Matroska-Devel on GMane: http://dir.gmane.org/gmane.comp.multimedia.matroska.devel

---

From: Steve Lhomme <[email-masked]>
Date: Sun, 14 Feb 2016 15:39:11 +0100

2016-02-09 15:39 GMT+01:00 Dave Rice <[email-masked]>:
>
> On Feb 9, 2016, at 3:29 AM, Nithin Mathew Kurien via Matroska-devel
> <[email-masked]> wrote:
>
> Hello,
>

DVDMenuXtractor was designed to be a proof of concept of how Matroska
menus could work. I think a good menu system should be able to do what
DVDs and Blu-rays do, so that would be a good starting point.
Given that there might different ways to achieve the same goal. The
DVD format being a bit constraining. I suppose the Blu-ray one is too.

A menu system is a very big project on its own. I think we should keep
that on the side for now. We can surely discuss and start the project.
But right now that should not be the main focus.

One of the implications of this work, though, was to allow
concatenated Matroska files to play. Segments in the one file could
reference each other, since that's the main goal of a menu anyway.
Since they might not be encoded with the same size/speed/etc and
having different tracks. We should keep that in mind when finalizing
Matroska.

> Dave Rice
>
> Thanks and regards,
> Nithin
>
>
> On Mon, Jan 25, 2016 at 9:23 PM, Nithin Mathew Kurien
> <[email-masked]> wrote:
>>
>> Hi,
>>
>> > 2015-12-17 11:41 GMT+01:00 Nithin Mathew Kurien
>> > <[email-masked]>:
>> >> Dear all,
>> >>
> Read Matroska-Devel on GMane:
> http://dir.gmane.org/gmane.comp.multimedia.matroska.devel
>
>
>