Subject: [Cellar] EBML notations

From: Dave Rice <[email-masked]>
Date: Sat, 13 Feb 2016 13:39:56 -0500

Hi all,

I created a pull request here: 

It includes adding the RFC2119 boilerplate: https://github.com/Matroska-Org/ebml-specification/pull/53

> ## Notation and Conventions
> 
> The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in this document are to be interpreted as described in [RFC 2119](https://tools.ietf.org/html/rfc2119).

Any other boilerplate applicable or worthwhile here?

I also included a new definition for VINTMAX in the Element Date Size section:
> The maximum possible value that can be stored as Element Data Size is referred to as `VINTMAX`.

This allows some of the EBML Element Type length definitions to be shortened, such as:
> A binary element may declare any length (including zero) up to the maximum Element Data Size value permitted.
to
> A binary element may declare any length (including zero) to `VINTMAX`.

Any other suggestions for terminology to define in the EBML spec?

And Moritz merged it even before I sent this email :) but comments are still welcome.

Best Regards,
Dave Rice

---

From: Steve Lhomme <[email-masked]>
Date: Sun, 14 Feb 2016 18:03:40 +0100

> Any other suggestions for terminology to define in the EBML spec?

Both are fine. But you should do 2 pull requests for such things so
that one thing doesn't block the other, as they are unrelated.

> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

-- 
Steve Lhomme
Matroska association Chairman