Subject: Re: [Cellar] FFV1 Version 4

From: Dave Rice <[email-masked]>
Date: Wed, 25 May 2016 12:19:19 -0400

> On Jan 7, 2016, at 5:09 PM, Peter B. <[email-masked]> wrote:
> 
> On 01/07/2016 07:34 PM, Jerome Martinez wrote:
>> PS: just to be clear, when you speak about "logarithmic", you speak
>> about DPX transfer characteristic value 3 "Logarithmic [to be defined
>> by SMPTE I23 Technology Committee,
>> sub-group on “Transfer Characteristics”]", right?
>> (note: the "to be defined" is in the spec from 2003 as well from the
>> spec from 2014 :), without further description)

The poster of the DPX file at https://github.com/epiil/dpxdepot/tree/master/test_files/dpx_frame claims that it is log. But the Transfer characteristic value is 0x01 aka "Printing density", rather than value 0x03 as Jerome supposes. Is "Printing density" also considered as log.

Is this data maintainable in Matroska with the new TransferCharacteristics element set to option 9 aka "Log" or should FFV1 contain this type of data.

> Well, personally I'd say I'm speaking about "color values that are
> non-linear".
> In practice, I've only encountered "quasi-log(TM)" (aka "logarithmic) -
> and DPX being the most popular case for these non-linear color values.
> 
> So in order to stick to real-world use-cases I mentioned
> "logarithmic-DPX-to-FFV1-and-back".
> Could also be "Non-linear-Foo-to-FFV1-and-back" ;)
> 
> 
> Maybe it would make sense to collect what kind of non-linear color
> interpretations appear in the real world and derive some way of handling
> them.
> At least the most prominent ones?
> 
> For example, like the ones Reto mentioned:
> // -------------------
> - log RGB (= "quasi-log", sometimes also called "pseudo-log") encodings:
> FilmStream (log60), ARRI log F, Panalog, Sony-log (= S-log), REDLOG, SI
> log90
> - log neg encodings: Cineon printing density (CPD), "DPX", ARRI log C
> // -------------------
> 
> 
> Regards,
> Pb
> 
> 
> PS: Maybe something like a CLUT could be stored as a self-contained way
> of interpreting the non-linearity of the color values?

For reference here is the list for DPX transfer characteristics which is quite different from the Matroska list.

0 User defined
1 Printing density
2 Linear
3 Logarithmic [to be defined by SMPTE I23 Technology Committee, sub-group on “Transfer Characteristics”]
4 Unspecified video
5 SMPTE 274M
6 ITU-R 709-4
7 ITU-R 601-5 system B or G (625)
8 ITU-R 601-5 system M (525)
9 Composite video (NTSC); see SMPTE 170M
10 Composite video (PAL); see ITU-R 624-4
11 Not applicable
12 Not applicable
13 – 254 Reserved for future use

Dave Rice

---

From: Reto Kromer <[email-masked]>
Date: Wed, 25 May 2016 20:27:13 +0200

Dave Rice wrote:

>The poster of the DPX file at 
>https://github.com/epiil/dpxdepot/tree/master/test_files/dpx_frame
>claims that it is log. But the Transfer characteristic
>value is 0x01 aka "Printing density", rather than value
>0x03 as Jerome supposes. Is "Printing density" also
>considered as log.

I am speaking here from memory, as I don't have the time now
to check it (I'm taking off for the US very soon).

If I remember carefully, Kodak's original "printing density"
correlates

  2 ** {0, 1, 2, 3, …}

with

  1.01 ** {0, 1, 2, 3, …}

Yet I had a stroke five years ago and since then my memory
is not as good as before, therefore please enjoy this "cum
grano salis".

Best regards, Reto

AV Preservation by reto.ch
chemin du Suchet 5 | 1024 Ecublens | Switzerland
Web: https://reto.ch | Twitter: @retoch