Subject: [Cellar] deprecated elements?

From: Dave Rice <[email-masked]>
Date: Sun, 26 Jun 2016 18:20:39 -0400

Hi Steve, Moritz, or anyone who may know their Matroska history well,

I'm working on element presentations and noticed some inconsistency in deprecated elements.

TimeSlice is listed as deprecated in its description but doesn't list a maxver. So when was TimeSlice deprecated / what is the maxver of TimeSlice?

Same question for LaceNumber?

OldStereoMode. I think I've asked about this before but it has a maxver of 0. Was there a Matroska version 0? Also the minver is 1, so this doesn't really make sense. Should maxver of OldStereoMode be 1?

Some elements note as deprecated do list a maxver which implies when the deprecation happens. For instance TrackTimecodeScale is deprecated after version 3.

Best Regards,
Dave Rice

---

From: Steve Lhomme <[email-masked]>
Date: Mon, 27 Jun 2016 09:12:14 +0200

> TimeSlice is listed as deprecated in its description but doesn't list a maxver. So when was TimeSlice deprecated / what is the maxver of TimeSlice?

According to archive.org It was there in the early specs and the text
saying it's deprecated is in the v2 version specs. So I'd say
deprecated since v2. We might even go as far as just removing it. I
don't think anyone ever used this.

> Same question for LaceNumber?

Same as above.

> OldStereoMode. I think I've asked about this before but it has a maxver of 0. Was there a Matroska version 0? Also the minver is 1, so this doesn't really make sense. Should maxver of OldStereoMode…

It's an experimental 3D mode that was introduced during v3 and dropped
during v3 in 2011.

-- 
Steve Lhomme
Matroska association Chairman