Subject: Re: [Cellar] [PATCH 1/1] Specify a range of >0 for EBMLVersion/EBMLReadVersion

From: Dave Rice <[email-masked]>
Date: Wed, 8 Jun 2016 11:53:55 -0400

Bumping this.

> On May 24, 2016, at 5:54 PM, Dave Rice <[email-masked]> wrote:
> 
> 
>> On May 24, 2016, at 5:47 PM, Luca Barbato <[email-masked]> wrote:
>> 
>> On 24/05/16 22:52, Michael Bradshaw wrote:
>>> Hi,
>>> 
>>> I propose the following patch for the EBML specification. Currently,
>>> EBMLVersion and EBMLReadVersion do not have a range specified, suggesting
>>> the value 0 should be legal (albeit probably nonsensical).
>>> 
>>> 
>>>> From f0e547502890fa9efa0b966a08544f5b91f8ccd7 Mon Sep 17 00:00:00 2001
>>> From: Michael Bradshaw <[email-masked]>
>>> Date: Tue, 17 May 2016 10:14:42 -0700
>>> Subject: [PATCH 1/1] Specify a range of >0 for EBMLVersion/EBMLReadVersion
>>> 
>>> ---
>>> specification.markdown | 4 ++--
>>> 1 file changed, 2 insertions(+), 2 deletions(-)
>>> 
>>> diff --git a/specification.markdown b/specification.markdown
>>> index 3f262b9..3fb4b01 100644
>>> --- a/specification.markdown
>>> +++ b/specification.markdown
>>> @@ -336,7 +336,7 @@ Element Name:   EBMLVersion
>>>    EBML ID:        [42][86]
>>>    Mandatory:      Yes
>>>    Multiple:       No
>>> -    Range:          -
>>> +    Range:          >0
> 
> AFAIK there have only ever been one version of EBML. With EBMLVersion=1. Perhaps instead of ">0”, we could simply say “1” as no other value is valid. Someday if IETF defines a version 2 of EBML than the Range can be updated to “1-2” and so on.

Any other opinion on this? Should we set EBMLVersion and EBMLReadVersion to ">0" or simply to be only "1" (since the spec defines no other valid EBML version)?

>>>    Default:        1
>>>    Element Type:   Unsigned Integer
>>>    Description:    The version of EBML parser used to create the EBML
>>> Document.
> 
> I never really looked at this description too closely but perhaps this should reference the version of the EBML specification rather than the EBML parser. The version of the parser (i.e. libebml) is not what is intended here.
> 
>>> @@ -347,7 +347,7 @@ Element Name:   EBMLReadVersion
>>>    EBML ID:        [42][F7]
>>>    Mandatory:      Yes
>>>    Multiple:       No
>>> -    Range:          -
>>> +    Range:          >0
> 
> Same comment as above.
> 
>>>    Default:        1
>>>    Element Type:   Unsigned Integer
>>>    Description:    The minimum EBML version a parser has to support to
>>> read this EBML Document.
>>> --
>>> 2.8.0.rc2
>>> 
>> 
>>> =0 then ?
>> 
>> _______________________________________________
>> Cellar mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/cellar
> 
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

---

From: Michael Bradshaw <[email-masked]>
Date: Wed, 8 Jun 2016 09:17:03 -0700

On Wed, Jun 8, 2016 at 8:53 AM, Dave Rice <[email-masked]> wrote:
>
> Any other opinion on this? Should we set EBMLVersion and EBMLReadVersion
> to ">0" or simply to be only "1" (since the spec defines no other valid
> EBML version)?

I'm in favor of requiring it to be only "1" and reserving other values for
future standards.

---

From: Moritz Bunkus <[email-masked]>
Date: Wed, 8 Jun 2016 18:40:40 +0200

Hey,

> I'm in favor of requiring it to be only "1" and reserving other values
> for future standards.

Seconded, though it's not a strong preference.

Kind regards,
mosu

---

From: Dave Rice <[email-masked]>
Date: Wed, 8 Jun 2016 12:46:12 -0400

> On Jun 8, 2016, at 12:40 PM, Moritz Bunkus <[email-masked]> wrote:
> 
> Hey,
> 

Thanks, pr is here: https://github.com/Matroska-Org/ebml-specification/pull/65/files
Dave Rice