Subject: Re: [Cellar] Nesting elements

From: Dave Rice <[email-masked]>
Date: Mon, 1 Aug 2016 20:12:55 -0400

> On Jul 31, 2016, at 11:44 AM, Steve Lhomme <[email-masked]> wrote:
> 
> Although the EBML specs define Void as level 0+ and CRC32 and level 1+
> I could not find anywhere in the document how this + sign should be
> interepreted.

Hmmm, according to https://github.com/Matroska-Org/ebml-specification/blame/master/specification.markdown#L226

"Note that Elements defined as `global` and `recursive` MAY occur at a level greater than or equal to the defined `level`.”

So perhaps the `+` symbols are not needed at all, since both Void and CRC-32 are noted as global.

> I think it should become an element like default, recursive, etc. Also
> like the Range and Default values, when not set (no nesting) it should
> not be written. That won't make the specifications a lot more verbose.
> 
> Related github issue:
> https://github.com/Matroska-Org/ebml-specification/issues/82
> 
> -- 
> Steve Lhomme
> Matroska association Chairman
> 
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

---

From: Steve Lhomme <[email-masked]>
Date: Mon, 8 Aug 2016 21:19:28 +0200

> So perhaps the `+` symbols are not needed at all, since both Void and CRC-32 are noted as global.

For those maybe not but for ChapterAtom of SimpleTag we need a way to
define unambiguously. But that's what `recursive` does.

---

From: Steve Lhomme <[email-masked]>
Date: Mon, 8 Aug 2016 21:23:07 +0200

I created a Pull Request to remove this plus sign from Void and CRC32
https://github.com/Matroska-Org/ebml-specification/pull/84