Subject: [Cellar] Matroska's default codecs

From: Reto Kromer <[email-masked]>
Date: Sun, 21 Aug 2016 17:51:12 +0200

Hello,

at the moment, we have `ffmpeg -h muxer=matroska`:

    Muxer matroska [Matroska]:
        Common extensions: mkv.
        Mime type: video/x-matroska.
        Default video codec: h264.
        Default audio codec: ac3.
        Default subtitle codec: ass.

Will this change, the default video codec becoming FFV1 and
the default audio codec becoming FLAC, or not? Thank you!

Best regards, Reto

---

From: Michael Bradshaw <[email-masked]>
Date: Sun, 21 Aug 2016 12:36:20 -0700

I think that's up to the ffmpeg community to decide what they want their
tool to default to. ffv1 and FLAC are nice but I doubt they'll be commonly
used enough to warrant a default change.

On Sunday, August 21, 2016, Reto Kromer <[email-masked]> wrote:

> _______________________________________________
> Cellar mailing list
> [email-masked] <javascript:;>
> https://www.ietf.org/mailman/listinfo/cellar
>

---

From: Dave Rice <[email-masked]>
Date: Sun, 21 Aug 2016 15:47:41 -0400

I agree with Michael. From the archive.org Matroska survey almost 94% of the video within Matroska is h264. Interestingly ac3 is not the most popular mkv audio encoding, but ac3 is about 15.7% while aac is 64%. Most users of MKV will stick closer to those defaults for the intention of accessibility.

If the CELLAR community wanted to integrate a proposed encoding for a particular purpose (archiving, transmission, etc), I suggest that this would be done by defining a ‘target’ in ffmpeg rather than modifying its default behavior. For instance see how vcd and dvd are defined in the opt_target function at https://github.com/FFmpeg/FFmpeg/blob/61da882cea4579658e8d01e24b8cb71c98df2b94/ffmpeg_opt.c#L2550-L2691. Feasibly we could propose a target that combines suggested options for archiving: -slicecrc 1 -level 3 -c:v ffv1, etc.

Best Regards,
Dave Rice

> On Aug 21, 2016, at 3:36 PM, Michael Bradshaw <[email-masked]> wrote:
> 
> I think that's up to the ffmpeg community to decide what they want their tool to default to. ffv1 and FLAC are nice but I doubt they'll be commonly used enough to warrant a default change.
> 
> On Sunday, August 21, 2016, Reto Kromer <[email-masked] <mailto:[email-masked]>> wrote:
> Hello,
> 
> https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>
> [email-masked]

---

From: Kieran O Leary <[email-masked]>
Date: Sun, 21 Aug 2016 21:36:07 +0100

Hi

On 21 Aug 2016 8:47 p.m., "Dave Rice"
>
> If the CELLAR community wanted to integrate a proposed encoding for a
particular purpose (archiving, transmission, etc), I suggest that this
would be done by defining a ‘target’ in ffmpeg rather than modifying its
default behavior. For instance see how vcd and dvd are defined in the
opt_target function at
https://github.com/FFmpeg/FFmpeg/blob/61da882cea4579658e8d01e24b8cb71c98df2b94/ffmpeg_opt.c#L2550-L2691.
Feasibly we could propose a target that combines suggested options for
archiving: -slicecrc 1 -level 3 -c:v ffv1, etc.

+1
I think this is a great idea. Perhaps another way of doing it could  be a
profile for ffv1, kind of like `-profile:v archive`, or something like that.

-kieran.

---

From: Reto Kromer <[email-masked]>
Date: Sun, 21 Aug 2016 22:39:54 +0200

Thank you very much, Michael and Dave, for the answer and
the statistical information of today's reality. I can
understand that the Matroska users are mainly interested in
accessibility. Seen from the point of view of preservation,
a solution like the mentioned could be of interest:

>If the CELLAR community wanted to integrate a proposed
>encoding for a particular purpose (archiving, transmission,
>etc), I suggest that this would be done by defining a
>‘target’ in ffmpeg rather than modifying its default
>behavior. For instance see how vcd and dvd are defined in
>the opt_target function at 
>Feasibly we could propose a target that combines suggested
>options for archiving: -slicecrc 1 -level 3 -c:v ffv1, etc.

I have no clear preference for now; I need to delve deeper
into this, in order to gather a better overview.

On my side, the question raised up, because I am preparing
some quick demo interfaces for tomorrow. Of course, I can
"put into" a button any code, more or less complex...

Thanks again and best regards, Reto

---

From: Tobias Rapp <[email-masked]>
Date: Mon, 29 Aug 2016 09:08:12 +0200

On 21.08.2016 22:36, Kieran O Leary wrote:
> opt_target function
> at https://github.com/FFmpeg/FFmpeg/blob/61da882cea4579658e8d01e24b8cb71c98df2b94/ffmpeg_opt.c#L2550-L2691.
> I think this is a great idea. Perhaps another way of doing it could  be
> a profile for ffv1, kind of like `-profile:v archive`, or something like
> that.

There is a similar feature already existing in FFmpeg:
http://ffmpeg.org/ffmpeg-all.html#Preset-files

For example by putting the following lines into a file named 
"ffv1l3.ffpreset":

vcodec=ffv1
g=1
level=3
slices=16
slicecrc=1

one can use it by adding "-pre ffv1l3" to the command line.

Regards,
Tobias