Subject: Re: [Cellar] EBML Element Parenting

From: hubblec4 <[email-masked]>
Date: Mon, 1 Aug 2016 09:50:15 +0200

Am 31.07.2016 um 18:45 schrieb Reto Kromer:
> Steve Lhomme wrote:
>
>> As we're moving towards splitting the Matroska specs in
>> many smaller documents,
> I personally would prefer to have one document containing
> the full specification of Matroska.
>
> Best regards, Reto
>

I would prefer to have one document too.
The old-style looks for me very well, more then better as many other 
spec-documents.
And the new style by Dave is much more comfortable to navigate.

Kind Regards
Martin

---

From: Dave Rice <[email-masked]>
Date: Mon, 1 Aug 2016 20:18:25 -0400

> On Aug 1, 2016, at 3:50 AM, hubblec4 <[email-masked]> wrote:
> 
> 
> 
> The old-style looks for me very well, more then better as many other spec-documents.

I could support splitting the specification into separate documents in a few instances. For instance I think the Matroska tags and their definitions could be moved into a separate document. So the main document would cover the structure of the tagging elements, but a separate document could cover the metadata values that could be used within it. I think this would be helpful as the metadata values and definitions could be versioned separately without needing the version the underlying Matroska specification.

In cases like codec mappings and dvd menus and features, I think I prefer this all in one Matroska specification. I’d like to prevent what’s occurred with MXF where dozens of documents are needed to understand the entirely of the file format and it’s challenging to even comprehend if you have all those necessary documents or not.

Dave

---

From: Jerome Martinez <[email-masked]>
Date: Tue, 2 Aug 2016 09:58:47 +0900

On 02/08/2016 09:18, Dave Rice wrote:
> I could support splitting the specification into separate documents in 
> a few instances. For instance I think the Matroska tags and their 
> definitions could be moved into a separate document. So the main 
> document would cover the structure of the tagging elements, but a 
> separate document could cover the metadata values that could be used 
> within it. I think this would be helpful as the metadata values and 
> definitions could be versioned separately without needing the version 
> the underlying Matroska specification. 

+1

> In cases like codec mappings and dvd menus and features, I think I prefer this all in one Matroska specification. I’d like to prevent what’s occurred with MXF where dozens of documents are needed t…

your argument for split of tags definition ("without needing the version 
the underlying Matroska specification") also applies here.
IETF uses to do the same kind of split as SMTE for MXF (Check Opus: one 
RFC for Opus in RTP, so RTP has 1 RFC per new codec, one RFC for Opus in 
OGG...), actually because missing such changes in a unique spec create 
too many revisions for something not core.

it is not easy to decide where to put codec specs (e.g. Opus has a 
separate RFC, FFV1 includes it in its specs...) but  I don't think that 
having it in an unique spec is good we don't see the important changes 
in core spec with it.
I propose that we have split specs, but not one per format, one RFC for 
all codecs in Matroska may be enough (+1 for DVD menu, very specific and 
potentially complex/unstable item)