Subject: [Cellar] Matroska EncryptedBlock Structure and Virtual Block

From: Dave Rice <[email-masked]>
Date: Thu, 6 Oct 2016 00:19:36 -0400

Hi all,

What is the status of the Matroska documentation on "EncryptedBlock Structure” and “Virtual Block”?  The section in the repo has malformed tables [1]. But the corresponding section in the matroska.org site is greyed out with the “version2” class in the HTML. Should these sections be removed or should they be noted as deprecated to a particular version of Matroska?

Dave Rice

[1]: https://github.com/Matroska-Org/matroska-specification/blob/8630510d5977d1d7d94bc67c32906de6aae5921c/index.md#encryptedblock-structure
[2]: https://www.matroska.org/technical/specs/index.html#encryptedblock_structure

---

From: Jerome Martinez <[email-masked]>
Date: Thu, 6 Oct 2016 11:15:07 +0200

Le 06/10/2016 à 06:19, Dave Rice a écrit :
> What is the status of the Matroska documentation on "EncryptedBlock Structure” and “Virtual Block”?

I understood that it is outdated, not really used, and should be removed 
from the standard

>    The section in the repo has malformed tables [1]. But the corresponding section in the matroska.org site is greyed out with the “version2” class in the HTML. Should these sections be removed or should they be noted as deprecated to a particular version of Matroska?

As this is the first version of the standard, I would say that we don't 
use yet "deprecated" stuff, we reserve it for elements in the first 
version of the standard and removed in a later version of the standard.

Jérôme

---

From: Steve Lhomme <[email-masked]>
Date: Sun, 16 Oct 2016 15:53:49 +0200

> I understood that it is outdated, not really used, and should be removed

Yes they should be removed.

>>    The section in the repo has malformed tables [1]. But the corresponding
>> section in the matroska.org site is greyed out with the “version2” class in
>> the HTML. Should these sections be removed or should they be noted as
>> deprecated to a particular version of Matroska?
>
>
> As this is the first version of the standard, I would say that we don't use
> yet "deprecated" stuff, we reserve it for elements in the first version of
> the standard and removed in a later version of the standard.
>
> Jérôme
>
>
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

-- 
Steve Lhomme
Matroska association Chairman