Subject: [Cellar] EditionUID length

From: Dave Rice <[email-masked]>
Date: Thu, 20 Oct 2016 15:35:38 -0400

Hi all,

I noticed that writing EditionUID fails for many values in Matroska writers such as MKVToolnix but this works if the EditionUID is a small enough value. For instance a 128 bit EditionUID fails, but a <=32 bit one works.

Is there an unwritten understanding that EditionUID (and many of the non-Segment-UID Elements) has size constraints or is it a bug in the Matroska writer for not handling any valid unsigned integer as an EditionUID? Presuming a size-constrained UID is preferred but it should be noted as to what the constraint is.

Dave Rice

---

From: Michael Bradshaw <[email-masked]>
Date: Thu, 20 Oct 2016 13:22:56 -0700

On Thu, Oct 20, 2016 at 12:35 PM, Dave Rice <[email-masked]> wrote:

> Hi all,
>
> I noticed that writing EditionUID fails for many values in Matroska
> writers such as MKVToolnix but this works if the EditionUID is a small
> enough value. For instance a 128 bit EditionUID fails, but a <=32 bit one
> works.

EditionUID is defined as an unsigned integer element, and as such cannot be
more than 64 bits. I would expect a 128-bit EditionUID to fail, but a
64-bit one should work (if not, I'd say that's a bug in the tool).

---

From: Dave Rice <[email-masked]>
Date: Thu, 20 Oct 2016 16:29:57 -0400

> On Oct 20, 2016, at 4:22 PM, Michael Bradshaw <[email-masked]> wrote:
> 
> On Thu, Oct 20, 2016 at 12:35 PM, Dave Rice <[email-masked] <mailto:[email-masked]>> wrote:
> Hi all,
> 
> EditionUID is defined as an unsigned integer element, and as such cannot be more than 64 bits. I would expect a 128-bit EditionUID to fail, but a 64-bit one should work (if not, I'd say that's a bug in the tool).

Ah, sorry to miss that. I see that SegmentUID (defined as 128 bits) is 'binary' while EditionUID is 'uinteger' (which has an Element Type definition which restricts to 8 bytes). 64 bit EditionUID's do work in mkvtoolnix, even though it assigns 32 bit versions by default.
Dave