Subject: [Cellar] Matroska: limit to 2 SeekHead Elements

From: Dave Rice <[email-masked]>
Date: Sat, 15 Oct 2016 11:51:37 -0400

HI all,

I submitted a small pull request to limit SeekHead to two occurrences [1] (in practice an option first SeekHead for the beginning of the file and an optional second SeekHead for the end of the file). The documentation on the SeekHead element https://github.com/Matroska-Org/matroska-specification/blob/gh-pages/order_guidelines.md#seekhead doesn’t explicitly say that SeekHead elements are limited to two, but the documentation doesn’t seem to leave any purpose remaining for a third SeekHead. Additionally the past XML structure for defining Matroska structure had no mechanism to express an Element usage limit beyond 0, 1 or infinite, so such a constraint is only recently feasible.

From a survey of 75,732 Matroska files:

-	11,897 has 0 SeekHead Elements
-	53,859 has 1 SeekHead Element
-	9,976 has 2 SeekHead Elements
-	0 has >2 SeekHead Elements

Is there any scenario where >2 SeekHead Elements makes sense? Any likelihood that >2 SeekHead Elements was ever used?

Dave Rice

[1]: https://github.com/Matroska-Org/matroska-specification/pull/54

---

From: Moritz Bunkus <[email-masked]>
Date: Sun, 16 Oct 2016 10:22:42 +0200

Hey,

I'd be fine with this. mkvmerge, mkvpropedit and my GUI's header editor
all need at most two. I'm not aware of any tool that can actually create
more than two (though my tools can safely handle an arbitrary number
when reading the file, but that's just safe coding in play, not an
endorsement of allowing an unlimited amount).

Kind regards,
mosu

---

From: Steve Lhomme <[email-masked]>
Date: Sun, 16 Oct 2016 17:00:36 +0200

> Is there any scenario where >2 SeekHead Elements makes sense? Any likelihood that >2 SeekHead Elements was ever used?

For the current usage of SeekHead, no. And I can't think of other cases.

> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

-- 
Steve Lhomme
Matroska association Chairman