Subject: Re: [Cellar] NYC cellar meetup?

From: Genevieve HK <[email-masked]>
Date: Sat, 8 Oct 2016 19:01:17 -0400

1. Yes!
2. weekends are doable
3. +1 metadata (but I generally would just be attending to listen & learn
more about *everything*)

Thanks for planning this!

On Sat, Oct 8, 2016 at 3:00 PM, <[email-masked]> wrote:

> Send Cellar mailing list submissions to
>         [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://www.ietf.org/mailman/listinfo/cellar
> or, via email, send a message with subject or body 'help' to
>         [email-masked]
>
> You can reach the person managing the list at
>         [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Cellar digest..."
>
> Today's Topics:
>
>    1. Re: NYC cellar meetup? ([email-masked])
>    2. Re: NYC cellar meetup? (Murray, Kate)
>    3. Re: NYC cellar meetup? (Doug Ewell)
>    4. Re: NYC cellar meetup? (Reto Kromer)
>    5. Re: NYC cellar meetup? (Brendan Allen)
>
>
> ---------- Forwarded message ----------
> From: [email-masked]
> To: Dave Rice <[email-masked]>
> Cc: [email-masked]
> Date: Fri, 7 Oct 2016 21:13:10 +0200
> Subject: Re: [Cellar] NYC cellar meetup?
>
>
> > On Oct 7, 2016, at 8:52 PM, Dave Rice <[email-masked]> wrote:
> >
> > Hi all,
> >
> > There's been some offlist discussion about having a meetup in New York
> City on cellar issues (quite a few New Yorkers on the list). In general I
> think the agenda could be informal but address things like: discussion of
> open issues, how to contribute, planning upcoming work, collaboration.
> >
> > Nick Krabbenhoeft has offered to arrange for a meeting space at New York
> Public Library.
> >
> > So some questions for the group:
> >
> > 1. Is such a meeting of interest?
> >
> Yes!
>
> > 2. Should it occur during an evening or the weekend? An evening may be
> easier to local folks to coordinate but would be too late for most remote
> participation from Europe.
> >
> Also prefer evenings but more so prefer potential Euro participation!
>
> > 3. Recommendations for agenda items, things you'd like to learn, things
> you'd like to see done?
>
> FLAC attack.
>
>
> > Dave Rice
> > _______________________________________________
> > Cellar mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/cellar
>
>
>
>
> ---------- Forwarded message ----------
> From: "Murray, Kate" <[email-masked]>
> To: "[email-masked]'" <[email-masked]>
> Cc:
> Date: Fri, 7 Oct 2016 15:16:30 -0400
> Subject: Re: [Cellar] NYC cellar meetup?
> Thanks for this Dave. I'm game to (virtually) meet up with other
> interested folks if scheduling permits.
>
> Best from Kate
> **********
> Kate Murray
> Technology Policy Directorate
> Library of Congress
> 202-707-4894
> [email-masked]
>
>
>
> -----Original Message-----
> From: Dave Rice [mailto:[email-masked]]
> Sent: Friday, October 07, 2016 2:53 PM
> To: [email-masked]
> Subject: [Cellar] NYC cellar meetup?
>
> Hi all,
>
> There's been some offlist discussion about having a meetup in New York
> City on cellar issues (quite a few New Yorkers on the list). In general I
> think the agenda could be informal but address things like: discussion of
> open issues, how to contribute, planning upcoming work, collaboration.
>
> Nick Krabbenhoeft has offered to arrange for a meeting space at New York
> Public Library.
>
> So some questions for the group:
>
> 1. Is such a meeting of interest?
>
> 2. Should it occur during an evening or the weekend? An evening may be
> easier to local folks to coordinate but would be too late for most remote
> participation from Europe.
>
> 3. Recommendations for agenda items, things you'd like to learn, things
> you'd like to see done?
>
> Dave Rice
>
>
>
>
> ---------- Forwarded message ----------
> From: Doug Ewell <[email-masked]>
> To: [email-masked]
> Cc:
> Date: Fri, 07 Oct 2016 15:45:05 -0700
> Subject: Re: [Cellar] NYC cellar meetup?
> Dave Rice wrote:
>
> > Nick Krabbenhoeft has offered to arrange for a meeting space at New
> > York Public Library.
>
> That's rather a distance from Colorado, so rather than making the trek,
> I'll just repeat my request that BCP 47 be adopted as the
> language-tagging standard instead of (or at least in strong preference
> to) the existing approach which combines ISO 639-2/B with ccTLDs.
>
> --
> Doug Ewell | Thornton, CO, US | ewellic.org
>
>
>
> ---------- Forwarded message ----------
> From: Reto Kromer <[email-masked]>
> To: [email-masked]
> Cc:
> Date: Sat, 8 Oct 2016 07:05:28 +0200
> Subject: Re: [Cellar] NYC cellar meetup?
> Dave Rice wrote:
>
> >1. Is such a meeting of interest?
>
> Indeed.
>
> >2. Should it occur during an evening or the weekend? An
> >evening may be easier to local folks to coordinate but
> >would be too late for most remote participation from
> >Europe.
>
> A schedule permitting remote participation from Europe would
> be ideal.
>
> >3. Recommendations for agenda items, things you'd like to
> >learn, things you'd like to see done?
>
> Clear metadata embedding in Matroska, in order to maintain
> the relevant information about the RGB flavour encoded by
> FFV1. This would facilitate the native implementations into
> the current cutting, grading, restoration, etc. softwares.
> And, therefore, advocating for adoption.
>
> +1 FLAC
>
> Best regards, Reto
>
>
>
>
> ---------- Forwarded message ----------
> From: Brendan Allen <[email-masked]>
> To: Reto Kromer <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Date: Sat, 8 Oct 2016 12:06:24 -0400
> Subject: Re: [Cellar] NYC cellar meetup?
> Hi everyone,
> I've been lurking on this thread for awhile trying to follow. I'd like to
> say thanks to all of you for the work you're doing to standardize these
> formats. Also, its pretty cool how open, inclusive and transparent this
> process is.
> I live in nyc and could meet-up at the library. My interests are in
> embedded metadata and FLAC
>
> kind regards,
> Brendan Allen
>
> Sent from my iPhone
>
> > On Oct 8, 2016, at 1:05 AM, Reto Kromer <[email-masked]> wrote:
> >
> > Dave Rice wrote:
> >
> >> 1. Is such a meeting of interest?
> >
> > Indeed.
> >
> >> 2. Should it occur during an evening or the weekend? An
> >> evening may be easier to local folks to coordinate but
> >> would be too late for most remote participation from
> >> Europe.
> >
> > A schedule permitting remote participation from Europe would
> > be ideal.
> >
> >> 3. Recommendations for agenda items, things you'd like to
> >> learn, things you'd like to see done?
> >
> > Clear metadata embedding in Matroska, in order to maintain
> > the relevant information about the RGB flavour encoded by
> > FFV1. This would facilitate the native implementations into
> > the current cutting, grading, restoration, etc. softwares.
> > And, therefore, advocating for adoption.
> >
> > +1 FLAC
> >
> > Best regards, Reto
> >
> > _______________________________________________
> > Cellar mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/cellar
>
>
>
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar
>
>

---

From: Ethan T Gates <[email-masked]>
Date: Sun, 9 Oct 2016 09:48:48 -0400

Hi all,

Another novice lurker here - I second Brendan's thanks to you all for both
the content and admirable form of this process and Genevieve's desire to
observe and soak up as much as I can, as I've been doing by poring over
these threads. I would love to attend a NYC meeting, could make weekends
work, and might humbly suggest a quick word about how exactly newbies or
those without much or any experience with programming or metadata
standardization can contribute! (provision of sample files? copy editing
documentation?) You all have been doing a stellar job of getting CELLAR's
mission out into the wider archival community lately and I think interest
in participation is only going to keep growing.

Best,
Ethan Gates

-- 
Ethan Gates
Moving Image Archiving and Preservation Technician
Department of Cinema Studies, MIAP
New York University
665 Broadway, Room 613
New York, NY 10012
212-998-1732

---

From: Dave Rice <[email-masked]>
Date: Tue, 18 Oct 2016 12:57:09 -0400

Hi Ethan and others,

Thanks for this message. In regards to how people can contribute, we've been trying to file tickets in the associated repositories and these vary from very easy to complex. I'd suggest that if you'd like contribute but feel the need for support, please feel welcome to ask for a mentor.

Here's a highlight of some of the more approachable issues:

https://github.com/Matroska-Org/ebml-specification/issues/117 <https://github.com/Matroska-Org/ebml-specification/issues/117>
This is basically just a find/replace to correct a misspelling of "Occurence" with "Occurrence", mostly in this section: https://github.com/Matroska-Org/ebml-specification/blob/master/specification.markdown#path <https://github.com/Matroska-Org/ebml-specification/blob/master/specification.markdown#path>.

https://github.com/Matroska-Org/matroska-specification/issues/48 <https://github.com/Matroska-Org/matroska-specification/issues/48>
This issue is resolved basically by removing https://github.com/Matroska-Org/matroska-specification/blob/gh-pages/overhead.md <https://github.com/Matroska-Org/matroska-specification/blob/gh-pages/overhead.md> from the matroska-specification repo as the discussion suggests that it should not be part of the specification.

https://github.com/Matroska-Org/matroska-specification/issues/50 <https://github.com/Matroska-Org/matroska-specification/issues/50>
This calls for some sections to be reviewed against the EBML specification to ensure that they are redundant and then remove the identified redundant sections from the Matroska specification.

https://github.com/Matroska-Org/ebml-specification/issues/114 <https://github.com/Matroska-Org/ebml-specification/issues/114>
This requires some XML knowledge, but this is a recommendation that enumeration lists be moved from an informal "(1: option A, 2: option B)"-style structure. A example of the current enumeration list is here: https://github.com/Matroska-Org/matroska-specification/blob/2c0a14d3e0117175c1bf224c7be6496eedb28541/ebml_matroska.xml#L195 <https://github.com/Matroska-Org/matroska-specification/blob/2c0a14d3e0117175c1bf224c7be6496eedb28541/ebml_matroska.xml#L195>. So this issue is two part, first propose a new structure, then once accepted adjust ebml_matroska.xml to use it.

https://github.com/Matroska-Org/matroska-specification/issues/49 <https://github.com/Matroska-Org/matroska-specification/issues/49>
This relates to the metadata documenation at https://github.com/Matroska-Org/matroska-specification/blob/gh-pages/tagging.md <https://github.com/Matroska-Org/matroska-specification/blob/gh-pages/tagging.md>. Moritz has noted the meaning of tag names prefixed by underscores at https://github.com/Matroska-Org/matroska-specification/issues/49#issuecomment-254039146 <https://github.com/Matroska-Org/matroska-specification/issues/49#issuecomment-254039146>, so a section should be added to tagging.md to explain the meaning of tag names prefixed by underscores and what they imply and what a Reader should do with them.

https://github.com/Matroska-Org/matroska-specification/issues/46 <https://github.com/Matroska-Org/matroska-specification/issues/46>
This involves cleaning up Matroska's method for defining how to define codecs in Matroska. There's a markdown table that needs to be cleaned up and the structure of codec definitions themselves needs to be documented (such as the name style of Codec IDs, what information is needed in a description).

If you'd like to take a particular issue please note so in the Github issue tracker and feel welcome to ask any clarifying questions or request a mentor there so that we can assign both to the issue. Thanks much,

Dave Rice

> On Oct 9, 2016, at 9:48 AM, Ethan T Gates <[email-masked]> wrote:
> 
> Hi all,
> 
> Another novice lurker here - I second Brendan's thanks to you all for both the content and admirable form of this process and Genevieve's desire to observe and soak up as much as I can, as I've been doing by poring over these threads. I would love to attend a NYC meeting, could make weekends work, and might humbly suggest a quick word about how exactly newbies or those without much or any experience with programming or metadata standardization can contribute! (provision of sample files? copy editing documentation?) You all have been doing a stellar job of getting CELLAR's mission out into the wider archival community lately and I think interest in participation is only going to keep growing.
> 
> Best,
> Ethan Gates
> 
> On Sat, Oct 8, 2016 at 7:01 PM, Genevieve HK <[email-masked] <mailto:[email-masked]>> wrote:
> 1. Yes! 
> 2. weekends are doable
> 3. +1 metadata (but I generally would just be attending to listen & learn more about *everything*)
> 
> On Sat, Oct 8, 2016 at 3:00 PM, <[email-masked] <mailto:[email-masked]>> wrote:
>         [email-masked] <mailto:[email-masked]>
> 
>         https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>
>         [email-masked] <mailto:[email-masked]>
> 
>         [email-masked] <mailto:[email-masked]>
> 
>    1. Re: NYC cellar meetup? ([email-masked] <mailto:[email-masked]>)
> From: [email-masked] <mailto:[email-masked]>
> To: Dave Rice <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
> > On Oct 7, 2016, at 8:52 PM, Dave Rice <[email-masked] <mailto:[email-masked]>> wrote:
> >
> > Hi all,
> >
> > There's been some offlist discussion about having a meetup in New York City on cellar issues (quite a few New Yorkers on the list). In general I think the agenda could be informal but address things like: discussion of open issues, how to contribute, planning upcoming work, collaboration.
> >
> > Nick Krabbenhoeft has offered to arrange for a meeting space at New York Public Library.
> >
> > 2. Should it occur during an evening or the weekend? An evening may be easier to local folks to coordinate but would be too late for most remote participation from Europe.
> >
> > 3. Recommendations for agenda items, things you'd like to learn, things you'd like to see done?
> 
> FLAC attack.
> 
> 
> > Dave Rice
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>
> 
> 
> 
> 
> From: "Murray, Kate" <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>'" <[email-masked] <mailto:[email-masked]>>
> Cc: 
> Thanks for this Dave. I'm game to (virtually) meet up with other interested folks if scheduling permits.
> 
> Best from Kate
> **********
> Kate Murray
> 202-707-4894 <tel:202-707-4894>
> [email-masked] <mailto:[email-masked]>
> 
> 
> 
> From: Dave Rice [mailto:[email-masked] <mailto:[email-masked]>]
> To: [email-masked] <mailto:[email-masked]>
> There's been some offlist discussion about having a meetup in New York City on cellar issues (quite a few New Yorkers on the list). In general I think the agenda could be informal but address things like: discussion of open issues, how to contribute, planning upcoming work, collaboration.
> 
> Nick Krabbenhoeft has offered to arrange for a meeting space at New York Public Library.
> 
> 2. Should it occur during an evening or the weekend? An evening may be easier to local folks to coordinate but would be too late for most remote participation from Europe.
> 
> 3. Recommendations for agenda items, things you'd like to learn, things you'd like to see done?
> 
> Dave Rice
> 
> 
> 
> 
> From: Doug Ewell <[email-masked] <mailto:[email-masked]>>
> To: [email-masked] <mailto:[email-masked]>
> Cc: 
> Doug Ewell | Thornton, CO, US | ewellic.org <http://ewellic.org/>
> 
> 
> 
> From: Reto Kromer <[email-masked] <mailto:[email-masked]>>
> To: [email-masked] <mailto:[email-masked]>
> Cc: 
> From: Brendan Allen <[email-masked] <mailto:[email-masked]>>
> To: Reto Kromer <[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> I've been lurking on this thread for awhile trying to follow. I'd like to say thanks to all of you for the work you're doing to standardize these formats. Also, its pretty cool how open, inclusive and transparent this process is.
> I live in nyc and could meet-up at the library. My interests are in embedded metadata and FLAC
> 
> kind regards,
> Brendan Allen
> 
> Sent from my iPhone
> 
> > On Oct 8, 2016, at 1:05 AM, Reto Kromer <[email-masked] <mailto:[email-masked]>> wrote:
> >
> > Dave Rice wrote:
> >
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>
> 
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>
> 
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>
> 
> 
> 
> 
> -- 
> Ethan Gates