Subject: Re: [Cellar] status of FFV1 and EBML drafts

From: Dave Rice <[email-masked]>
Date: Tue, 2 Jan 2018 09:03:58 -0500

Hi,

In regards to FFV1, I just pushed a pull request at https://github.com/FFmpeg/FFV1/pull/82 <https://github.com/FFmpeg/FFV1/pull/82>, mostly grammar and formatting. Derek’s review at https://mailarchive.ietf.org/arch/msg/cellar/qItSPq06vc9MaxsZFPJ3GmREsr4 <https://mailarchive.ietf.org/arch/msg/cellar/qItSPq06vc9MaxsZFPJ3GmREsr4> has some issues still remaining: consideration of renaming the JPEG2000-RCT colorspace and some work to be more clear about the terminology of Frame and Pixel and defining their corresponding bitstream functions. FFV1 also needs an IANA Considerations section (some comments from Jerome at that at https://www.ietf.org/mail-archive/web/cellar/current/msg01168.html <https://www.ietf.org/mail-archive/web/cellar/current/msg01168.html>).

I suggest after resolving the current open pull requests than we could ping for some additional review. At some point we’ll also need to start the work to separate the Version 0,1,3 informational specification from the specification drafting of Version 4.

In regards, to EBML and Matroska, both have had a lot of active work over the past few months. I’ll update the document tracker with new drafts of both specifications within the next day or so and summarize changes to the list.

To the chairs, thus far the Matroska draft is listed as a “Related Internet-Draft”. At this point should the new draft be submitted as an “Active Internet Draft”? It seems to meet the criteria.

In regards to FLAC, I see that we don’t have a draft in the document tracker. Andrew, any status?

Best Regards,
Dave Rice

> On Dec 28, 2017, at 12:28 PM, Ashley Blewer <[email-masked]> wrote:
> 
> [thread bump] 
> 
> Can we figure out how to come to a consensus on these couple of issues?
> 
> Ashley
> 
> On Sun, Nov 26, 2017 at 4:07 AM, Steve Lhomme <[email-masked] <mailto:[email-masked]>> wrote:
> Hi,
> 
> I won't comment on FFV1, although I should probably read it to see if
> there's anything I don't understand.
> 
> For EBML I think there are still things to be done:
> - clarify how to handle bogus data
> https://github.com/Matroska-Org/ebml-specification/issues/48 <https://github.com/Matroska-Org/ebml-specification/issues/48>
> - kind of relates to junk in Master Elements
> https://github.com/Matroska-Org/ebml-specification/issues/92 <https://github.com/Matroska-Org/ebml-specification/issues/92>
> In the context of long term storage it's probably very important to
> solve these issues.
> 
> - DocType 0 as experimental/internal. We need to agree on this and then word it
> https://github.com/Matroska-Org/ebml-specification/issues/157 <https://github.com/Matroska-Org/ebml-specification/issues/157>
> 
> After that I think we're good to got for EBML. There's currently no
> pending pull request.
> 
> 2017-11-19 16:47 GMT+01:00 Dave Rice <[email-masked] <mailto:[email-masked]>>:
> > Hi cellar,
> >
> > At the IETF99 meeting in the minutes at https://datatracker.ietf.org/doc/minutes-99-cellar/ <https://datatracker.ietf.org/doc/minutes-99-cellar/> it discusses having a WG last call for FFV1 and EBML but also the need for more reviews of these documents. Is one issue blocking another? Meaning: should the group announce a last call in order to encourage more reviews or are more reviews needed in order to have a last call?
> >
> > Best Regards,
> > Dave Rice
> >
> > _______________________________________________
> > Cellar mailing list
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>
> 
> 
> 
> --
> Steve Lhomme
> Matroska association Chairman
> 
> _______________________________________________
> Cellar mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>
> 
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

---

From: Jerome Martinez <[email-masked]>
Date: Tue, 2 Jan 2018 15:07:32 +0100

On 02/01/2018 15:03, Dave Rice wrote:
> Derek’s review at 
> https://mailarchive.ietf.org/arch/msg/cellar/qItSPq06vc9MaxsZFPJ3GmREsr4 has 
> some issues still remaining

Sorry for the delay, I hope to have some time for handling the issues 
pointed by the review this week.

Jérôme