Subject: [Cellar] Fwd: Understanding VP8 data in a MKV file

From: Austin Einter <[email-masked]>
Date: Tue, 2 Jan 2018 08:19:48 +0530

I have a mkv file, that contains VP8 encoded data.
I need to stream this data to chrome (through RTP), and need to play it in
chrome.

I have parsed the mkv file, and I have VP8 data.
I will be sending this VP8 data in RTP packetc.
Looks I need to follow RFC 7741 to put VP8 descriptor / header in RTP
packet followed by VP8 data.

Now I have several doubts, kindly try to help me to understand.

1) What is a partition in VP8 and from MKV file how do I get partition
information.
2) I need to put partition size in VP8 header. From where I get the
partition size.
3) How do I know partition index, this I need to put in VP8 descriptor.

Does VP8 data I read from mkv file contains this.

Regards
Austin

---

From: Austin Einter <[email-masked]>
Date: Thu, 4 Jan 2018 13:43:54 +0530

---------- Forwarded message ----------
From: Austin Einter <[email-masked]>
Date: Sun, Dec 31, 2017 at 10:32 PM
Subject: Understanding VP8 data in a MKV file
To: [email-masked]

Regards
Austin

---

From: Steve Lhomme <[email-masked]>
Date: Sun, 21 Jan 2018 17:51:41 +0100

2018-01-04 9:13 GMT+01:00 Austin Einter <[email-masked]>:
> Looks I need to follow RFC 7741 to put VP8 descriptor / header in RTP packet
> followed by VP8 data.
>

Sorry, that sounds like a term internal to the VP8 documentation.
Maybe Moritz know about such things but that's out of the scope of
CELLAR.

> Regards
> Austin
>
>
>
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar
>

-- 
Steve Lhomme
Matroska association Chairman