Subject: [Cellar] [Matroska Tags] restructure tags lists into xml

From: Dave Rice <[email-masked]>
Date: Sat, 13 Jan 2018 10:25:49 -0500

Hi all,

The name, types, class, and descriptions of Matroska’s official tags are currently in formatted text within a Markdown document, such as in https://github.com/Matroska-Org/matroska-specification/blob/c1f7802bd258e0847b4892f8a9499c2ea786d3de/tagging.md#nesting-information <https://github.com/Matroska-Org/matroska-specification/blob/c1f7802bd258e0847b4892f8a9499c2ea786d3de/tagging.md#nesting-information>. I propose to move these tags into a structured xml document. The contents of the xml can then be formatted into a RFC friendly form during the make process. I think the advantages of this could be that the tags are easier to maintain in xml and it may make it easier for developers to integrate these vocabularies. Currently I have a draft of that xml at https://github.com/Matroska-Org/matroska-specification/pull/220/files <https://github.com/Matroska-Org/matroska-specification/pull/220/files> for comment (either on the xml itself or the general idea). I’ll later add in the make process to add the same data into the Matroska Tags RFC draft from the xml source rather than the current markdown source.

Kind Regards,
Dave Rice

---

From: Dave Rice <[email-masked]>
Date: Sun, 14 Jan 2018 10:33:03 -0500

> On Jan 13, 2018, at 10:25 AM, Dave Rice <[email-masked]> wrote:
> 
> Hi all,
> 

https://github.com/Matroska-Org/matroska-specification/pull/220 <https://github.com/Matroska-Org/matroska-specification/pull/220> is updated with a revised XML representing the Matroska tagging vocabulary and definitions. Also the Makefile process is updated so that the tagging registry is removed from tagging.md but will not be built into RFC outputs using a mix of the tagging.md files and the new xml. The RFC txt output is identical before and after this pull request, but I think these changes will help make the tagging registry more useful, allow easier internationalization, and better allow us to extend the definition of Matroska tags.

Best Regards,
Dave Rice

---

From: Steve Lhomme <[email-masked]>
Date: Sun, 21 Jan 2018 17:49:00 +0100

That sounds like a good move. Thanks.

2018-01-14 16:33 GMT+01:00 Dave Rice <[email-masked]>:
> The name, types, class, and descriptions of Matroska’s official tags are
> currently in formatted text within a Markdown document, such as in
> https://github.com/Matroska-Org/matroska-specification/blob/c1f7802bd258e0847b4892f8a9499c2ea786d3de/tagging.md#nesting-information.
> I propose to move these tags into a structured xml document. The contents of
> the xml can then be formatted into a RFC friendly form during the make
> process. I think the advantages of this could be that the tags are easier to
> maintain in xml and it may make it easier for developers to integrate these
> vocabularies. Currently I have a draft of that xml at
> https://github.com/Matroska-Org/matroska-specification/pull/220/files for
> comment (either on the xml itself or the general idea). I’ll later add in
> the make process to add the same data into the Matroska Tags RFC draft from
> the xml source rather than the current markdown source.
>
>
> https://github.com/Matroska-Org/matroska-specification/pull/220 is updated
> with a revised XML representing the Matroska tagging vocabulary and
> definitions. Also the Makefile process is updated so that the tagging
> registry is removed from tagging.md but will not be built into RFC outputs
> using a mix of the tagging.md files and the new xml. The RFC txt output is
> identical before and after this pull request, but I think these changes will
> help make the tagging registry more useful, allow easier
> internationalization, and better allow us to extend the definition of
> Matroska tags.
>
> Best Regards,
> Dave Rice
>
>
>
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar
>

-- 
Steve Lhomme
Matroska association Chairman