Subject: [cin] Aviation Network Communications Requirements for Global Air Traffic Management -- Maybe a starting point RE: Gentle Reminder

From: Terry Davis <[email-masked]>
Date: Thu, 3 Jan 2013 00:27:41 +0000

All

Hugh, maybe to get some discussions going here, you could forward this to the JCG mailing list?

And to restate from my original post in CIN:

ICAO plans to utilize  wants Internet protocols to build new global air traffic management networks to augment the current limited spectrum capacity OSI based networks with a broadband Internet based capable of being utilized across any available and authorized spectrums.  They have designated Internet Protocol Version 6 (IPv6) as the foundation for this new generation  of air traffic management networks.  However (at least in my opinion) the Internet standards we have are still some key missing foundational pieces to allow aviation to readily build the global network infrastructure to support these new (critical) air traffic management systems.

As examples:
-	Aviation is prohibited from using any routing architecture that will result in aircraft network addresses from transitioning between Internet service entry points.  This is due to the churn in the global Border Gateway Protocol tables induced when aircraft network that was previously attached to one continent transitions to an entry point on another continent.  The basic Internet protocols were not designed to handle globally mobile platforms; this transition causes millions of updates to router tables around the world and IETF believes it could result in major disruptions in Internet traffic were it to be used on aircraft without isolation.

-	There is not a way to readily create a "closed/isolated" network using Internet protocols.   And we probably truly do not want any routing re-distribution for the Internet's own good.  Personally I think, something like a rooted address space, that only routed within itself might work well.  But that also couldn't be "private" like the 1918 space; one of the problems with the using 1918 space that we discovered in aviation is that "everyone uses it" so it exists everywhere; airport, airlines, air navigation service providers, and even the airplanes internally themselves which renders it unusable for global aviation.

-	Information on how best to create a "private DNS" with its own roots that will not interfere is global DNS. 

-	Plus as anyone running "high security" networks also knows, having a reliable "trace back" mechanism is high on our desires to manage network security.  This is especially desirable since this network will span numerous different communications spectrums.

-	And in many cases aircraft will be simultaneously connected on this network to services on different spectrums, from different nations/states, and even different continents.  

The problem here is that commercial aviation (and commercial UAV) networks need to be able to readily create a limited-access/closed/isolated network that almost literally protects the Internet itself from our globally mobile assets.  As anyone who has ran or designed large networks with hundreds or thousands of sites around the globe knows, you must anticipate that they are always cross-connected somewhere.  

So ICAO (with a 140 individual "self-governing" member nations) has to begin with the assumption that their new IP based air traffic management networks will always be cross-linked to the main Internet somewhere and thus create designs such that aviation will cannot be a threat to disrupt Internet routing and services anyway on the globe. 

Take care

Terry Davis, P.E.   |   Chief Scientist 
[email-masked]
o. 206. 805. 6263 c. 425. 503. 5511
iJet Onboard   |  www.ijetonboard.com

PS: Here's the original informational RFC that Will, Wes, and I did several years ago.
http://www.rfc-editor.org/rfc/rfc5522.txt 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Terry Davis
Sent: Tuesday, November 06, 2012 8:02 AM
To: [email-masked]
Subject: Re: [cin] Gentle Reminder

All

Apologies that we didn't get this setup for this meeting here in Atlanta; we plan to be ready for the spring meeting in Orlando.  A couple of us have begun to draft the problem statement and charter which we hope to post in the near future.

For the aviation members of the group, we do have a working paper on aviation cyber security going to the ICAO Air Navigation Commission for presentation at their session later this month.  We seem to have broad support for it from the aviation community:  regulatory bodies, standards bodies, and the major commercial entities.  It is available on their website at:
http://www.icao.int/Meetings/anconf12/WorkingPapers/Forms/AllItems.aspx    (Search the page for "cyber" to find our paper.)

For those of you that didn't hear or see Panetta's warning on cyber war last month, I encourage you to read it:
http://www.nytimes.com/2012/10/12/world/panetta-warns-of-dire-threat-of-cyberattack.html?pagewanted=all&_r=0

If anything he may have understated the threats to critical infrastructure around the globe; every nation faces this problem in today's world.

We designed the Internet to be open and usable by everyone.  It has worked so well that our governments and commercial entities have also used it to support the critical infrastructure systems that control besides on communications; our power, our water, our food and medical distribution, hospitals, vehicles, etc.  And now within a few years, the communications to the aircraft that you will be on flying to attend future IETF meetings.

The problem is that we have not created the standards needed for these types of critical services to be placed on the Internet with truly enough security to allow them to be adequately defended from cyber-attacks.

Or even to protect the Internet itself from some of the ways these groups may use it.  During the short life of Connexion by Boeing, we developed routing techniques that allowed passengers to maintain their VPN's without dropping on trans-continental flights handing off between both different satellites and ground stations on different continents.  This worked great for the passengers but with just a 150 aircraft in service; it created routing storms that were responsible for 20% of the churn in the global BGP tables.

There are agreements in place to work on solutions to this problem between the Internet community and the aviation community.  Routing remains a core concern.  Aviation could use different routing protocols but all these come with BGP re-distributors.  Aviation could use only private networks or special routing techniques.  The problem is that this is global service.  Anyone that has ever been involved with large global networks knows that "they are always cross-linked somewhere", someone always violates the approved designs, re-distributed the wrong routing tree, etc.  ICAO has 140+ independent nation/states as members; 140+ independent operators of aviation communications within their borders!   With the current set of standards, can we safely integrated aviation's use of the Internet without risking disruption to the Internet itself?

I remain unconvinced.  And for aviation and these critical infrastructure networks that our lives and our families truly depend on, do we really intend to give them standards to operate with that are "naturally open" to anyone on the globe to try to communicate with?

Look for more soon on the problem statement and charter.

Take care

Terry Davis, P.E.   |   Chief Scientist
[email-masked]
o. 206. 805. 6263 c. 425. 503. 5511
iJet Onboard   |  www.ijetonboard.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ronald Bonica
Sent: Monday, September 10, 2012 8:07 AM
To: [email-masked]
Subject: [cin] Gentle Reminder

Folks,

Does this group still intend to hold a BoF at IETF 85? If so, the cut-off date for a BoF request is September 24.

Generally, a BoF request includes:

- a proposed charter
- a problem statement (which should be posted as an Internet Draft)

The deadline for posting version-00 IDs is October 15. However, it would be great if the problem statement were posted by September 24.

--------------------------
Ron Bonica
vcard:       www.bonica.org/ron/ronbonica.vcf

_______________________________________________
cin mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cin

This message and its attachments are the property of iJet Technologies, Inc. and are intended solely for the use of the designated recipient(s) and their appointed delegates. This email may contain information that is confidential. If you are not the intended recipient, you are prohibited from printing, copying, forwarding or saving any portion of the message or attachments. Please delete the message and attachments and notify the sender immediately. Thank you for your cooperation.

_______________________________________________
cin mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cin

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 3 Jan 2013 09:06:33 -0800

Hi Terry,

I agree on all counts, and this is why we developed the IRON family
of technologies:

https://datatracker.ietf.org/doc/draft-templin-ironbis/
https://datatracker.ietf.org/doc/draft-templin-intarea-vet/
https://datatracker.ietf.org/doc/draft-templin-intarea-seal/

In response to the route optimization requirement, we have also
developed Asymmetric Extended Route Optimization (AERO) and saw
it through to publication as RFC6706.

IRON, VET, SEAL and AERO fit very well into the Critical
Infrastructure Networks (CIN) requirements, and especially
address the mobility and route optimization needs without
impacting the public Internet.

What are the next steps in terms of wg formation?

Thanks - Fred
[email-masked] 

> Sent: Wednesday, January 02, 2013 4:28 PM
> To: [email-masked]; Hugh Mote ([email-masked]); Julien
> Holstein
> Cc: Wesley Eddy ([email-masked]); William Ivancic
> Subject: [cin] Aviation Network Communications Requirements for Global Air
> Traffic Management -- Maybe a starting point RE: Gentle Reminder
> 
> All
> 
> ICAO plans to utilize  wants Internet protocols to build new global air
> traffic management networks to augment the current limited spectrum
> capacity OSI based networks with a broadband Internet based capable of
> being utilized across any available and authorized spectrums.  They have
> designated Internet Protocol Version 6 (IPv6) as the foundation for this
> new generation  of air traffic management networks.  However (at least in
> my opinion) the Internet standards we have are still some key missing
> foundational pieces to allow aviation to readily build the global network
> infrastructure to support these new (critical) air traffic management
> systems.
> 
> As examples:
> -	Aviation is prohibited from using any routing architecture that will
> result in aircraft network addresses from transitioning between Internet
> service entry points.  This is due to the churn in the global Border
> Gateway Protocol tables induced when aircraft network that was previously
> attached to one continent transitions to an entry point on another
> continent.  The basic Internet protocols were not designed to handle
> globally mobile platforms; this transition causes millions of updates to
> router tables around the world and IETF believes it could result in major
> disruptions in Internet traffic were it to be used on aircraft without
> isolation.
> 
> -	There is not a way to readily create a "closed/isolated" network
> using Internet protocols.   And we probably truly do not want any routing
> re-distribution for the Internet's own good.  Personally I think,
> something like a rooted address space, that only routed within itself
> might work well.  But that also couldn't be "private" like the 1918 space;
> one of the problems with the using 1918 space that we discovered in
> aviation is that "everyone uses it" so it exists everywhere; airport,
> airlines, air navigation service providers, and even the airplanes
> internally themselves which renders it unusable for global aviation.
> 
> -	Plus as anyone running "high security" networks also knows, having a
> reliable "trace back" mechanism is high on our desires to manage network
> security.  This is especially desirable since this network will span
> numerous different communications spectrums.
> 
> -	And in many cases aircraft will be simultaneously connected on this
> network to services on different spectrums, from different nations/states,
> and even different continents.
> 
> The problem here is that commercial aviation (and commercial UAV) networks
> need to be able to readily create a limited-access/closed/isolated network
> that almost literally protects the Internet itself from our globally
> mobile assets.  As anyone who has ran or designed large networks with
> hundreds or thousands of sites around the globe knows, you must anticipate
> that they are always cross-connected somewhere.
> 
> So ICAO (with a 140 individual "self-governing" member nations) has to
> begin with the assumption that their new IP based air traffic management
> networks will always be cross-linked to the main Internet somewhere and
> thus create designs such that aviation will cannot be a threat to disrupt
> Internet routing and services anyway on the globe.
> 
> Take care
> 
> 
> Apologies that we didn't get this setup for this meeting here in Atlanta;
> we plan to be ready for the spring meeting in Orlando.  A couple of us
> have begun to draft the problem statement and charter which we hope to
> post in the near future.
> 
> For the aviation members of the group, we do have a working paper on
> aviation cyber security going to the ICAO Air Navigation Commission for
> presentation at their session later this month.  We seem to have broad
> support for it from the aviation community:  regulatory bodies, standards
> bodies, and the major commercial entities.  It is available on their
> website at:
> http://www.icao.int/Meetings/anconf12/WorkingPapers/Forms/AllItems.aspx
> (Search the page for "cyber" to find our paper.)
> 
> If anything he may have understated the threats to critical infrastructure
> around the globe; every nation faces this problem in today's world.
> 
> We designed the Internet to be open and usable by everyone.  It has worked
> so well that our governments and commercial entities have also used it to
> support the critical infrastructure systems that control besides on
> communications; our power, our water, our food and medical distribution,
> hospitals, vehicles, etc.  And now within a few years, the communications
> to the aircraft that you will be on flying to attend future IETF meetings.
> 
> The problem is that we have not created the standards needed for these
> types of critical services to be placed on the Internet with truly enough
> security to allow them to be adequately defended from cyber-attacks.
> 
> Or even to protect the Internet itself from some of the ways these groups
> may use it.  During the short life of Connexion by Boeing, we developed
> routing techniques that allowed passengers to maintain their VPN's without
> dropping on trans-continental flights handing off between both different
> satellites and ground stations on different continents.  This worked great
> for the passengers but with just a 150 aircraft in service; it created
> routing storms that were responsible for 20% of the churn in the global
> BGP tables.
> 
> There are agreements in place to work on solutions to this problem between
> the Internet community and the aviation community.  Routing remains a core
> concern.  Aviation could use different routing protocols but all these
> come with BGP re-distributors.  Aviation could use only private networks
> or special routing techniques.  The problem is that this is global
> service.  Anyone that has ever been involved with large global networks
> knows that "they are always cross-linked somewhere", someone always
> violates the approved designs, re-distributed the wrong routing tree, etc.
> ICAO has 140+ independent nation/states as members; 140+ independent
> operators of aviation communications within their borders!   With the
> current set of standards, can we safely integrated aviation's use of the
> Internet without risking disruption to the Internet itself?
> 
> I remain unconvinced.  And for aviation and these critical infrastructure
> networks that our lives and our families truly depend on, do we really
> intend to give them standards to operate with that are "naturally open" to
> anyone on the globe to try to communicate with?
> 
> The deadline for posting version-00 IDs is October 15. However, it would
> be great if the problem statement were posted by September 24.
> 
> This message and its attachments are the property of iJet Technologies,
> Inc. and are intended solely for the use of the designated recipient(s)
> and their appointed delegates. This email may contain information that is
> confidential. If you are not the intended recipient, you are prohibited
> from printing, copying, forwarding or saving any portion of the message or
> attachments. Please delete the message and attachments and notify the
> sender immediately. Thank you for your cooperation.
>

---

From: Ronald Bonica <[email-masked]>
Date: Thu, 3 Jan 2013 17:36:54 +0000

> What are the next steps in terms of wg formation?

- Produce a problem statement
- Produce a propose WG charter
- Propose a BoF

              Ron