Subject: [codesprints] Fwd: Beijing IETF Codesprint

From: Robert Sparks <[email-masked]>
Date: Wed, 15 Sep 2010 10:51:07 -0500

If you're planning to join the Beijing codesprint, please let us know at
<http://trac.tools.ietf.org/tools/ietfdb/wiki/IETF79SprintSignUp>.

If you're a regular attendee but know for sure you won't be there, please
drop me a note.

Thanks!

RjS

Begin forwarded message:

> From: IETF Chair <[email-masked]>
> Date: September 9, 2010 2:28:53 PM CDT
> To: IETF Announcement list <[email-masked]>
> Cc: [email-masked], [email-masked]
> Subject: Beijing IETF Codesprint
> Reply-To: [email-masked]
> 
> Beijing IETF Codesprint
> 
> When:  6 November 2010, starting at 9:30 AM
> 
> Where: IETF Hotel
> 
> What:  A bunch of hackers get together to work on code for the IETF.
>       All code will become part of the open source IETF tools.
> 
> Who:   Hopefully you can help
> 
> Many of the results of previous codesprint activities are being
> used every day by the IETF community.  A new Internet-Draft submission
> tool and a new liaison statement tool will be available before November
> 6th.  Work to polish or improve those tools will be most welcome.
> 
> Steve Conte will be helping with advance planning.  Henrik Levkowetz
> will be coordinating the event in Bejing.  More information is available at:
> 
> http://trac.tools.ietf.org/tools/ietfdb/wiki/IETF79Sprint
> 
> If you are able to participate, please sign up on the wiki at:
> 
> http://trac.tools.ietf.org/tools/ietfdb/wiki/IETF79SprintSignUp
> 
> Please support the tools development effort,
>  Russ
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: Russ Housley <[email-masked]>
Date: Wed, 15 Sep 2010 14:56:53 -0400

I'd like to evaluate the last Codesprint.  What went right?  What went
(other than the Bat Cave of a room) wrong?

Russ

---

From: Tony Hansen <[email-masked]>
Date: Sat, 18 Sep 2010 00:43:07 -0400

I personally spent more time diagnosing wireless connectivity issues 
than being productive. A few hardwired connections would have been useful.

     Tony

---

From: Russ Housley <[email-masked]>
Date: Sat, 18 Sep 2010 10:44:39 -0400

I have passed this on to the NOC team.

Russ

---

From: Robert Sparks <[email-masked]>
Date: Fri, 24 Sep 2010 16:13:38 -0500

One thought - 

I think we could get a quicker start if we made the branches for the people
we knew about before Saturday - a week earlier would be great - it would
make it easier for people to get their development environment going before
they got there.

RjS

On Sep 15, 2010, at 1:56 PM, Russ Housley wrote:

> codesprints mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codesprints

---

From: Warren Kumari <[email-masked]>
Date: Fri, 24 Sep 2010 17:35:08 -0400

Sorry, I didn't respond earlier because I didn't have complaints :-)

Eveything IMO went off well, other than my lack of Django skills ...

Warren Kumari
------
Please excuse typing, etc -- This was sent from a device with a tiny keyboard.

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 25 Sep 2010 01:07:27 +0200

Hi Robert,

> make it easier for people to get their development environment going before

Can do (assuming I remember or am reminded).

Best,

	Henrik

---

From: Peter Musgrave <[email-masked]>
Date: Fri, 24 Sep 2010 20:22:26 -0400

Sure.

I thought overall it was a good session. I was able to get going and
change some code which I found useful (and I now use a lot). I was a
bit surprised I got that far - although I had done my homework prior
to arriving. (I suspect it has all leaked out my ears over the last
three months - but we'll see.)

I think the session might benefit from an interruption at some point
(maybe a brief stop at coffee once people have settled in - or lunch)
and a chance for people to exchange some info on what they are trying
to do or ask a question about how a particular section of the tools
works. Nothing long - just 30-60 sec. to see if the person
wants/needs/can provide advice.

I enjoyed the session - and I'll be back in Beijing.

Is there any info on how many people try it out and never return? Are
there things we could do to help those people stay? (Part of me thinks
that it is somewhat self-selecting at present and that may not be a
bad thing).

Cheers,

Peter Musgrave

On Fri, Sep 24, 2010 at 4:41 PM, Robert Sparks <[email-masked]> wrote:
> It would be good to respond to this if you can. (Please let me know if you
> didn't get it originally)
> An "it's all good" message if you don't want something to change would help.
> Suggestions for improvement would be better.
> RjS
>
> Begin forwarded message:
>
> From: Russ Housley <[email-masked]>
> Date: September 15, 2010 1:56:53 PM CDT
> To: [email-masked]
> Subject: [codesprints] Maastricht Codesprint Evaluation
>

---

From: Russ Housley <[email-masked]>
Date: Sun, 26 Sep 2010 16:07:56 -0400

This sounds like a good idea, and easy too.