Subject: [conex] Reserved header bits in IPv6

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 21 Oct 2010 12:21:11 +0200

Hi

This document has some relevance to the ConEx work
http://tools.ietf.org/id/draft-krishnan-6man-header-reserved-bits-00.txt

===============
Abstract

   The IPv6 header does not contain any reserved bits for future
   expansion.  This document sets aside 4 bits from the flow label field
   for future expansion.

===============

/Ingemar
=================================
INGEMAR JOHANSSON  M.Sc. 
Senior Research Engineer 

Ericsson AB
Multimedia Technologies
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]
www.ericsson.com 
Visit http://labs.ericsson.com !
=================================

---

From: Fred Baker <[email-masked]>
Date: Thu, 21 Oct 2010 08:47:01 -0400

Two comments:

1) as far as I'm concerned, the entire 20 bit flow label field is "reserved bits". While there have been periodic discussions of how it might be used, I don't see a lot of use of it.
2) unless 6man agrees, it's probably not a good idea to build on this beyond making a good case for reserved bits.

On Oct 21, 2010, at 6:21 AM, Ingemar Johansson S wrote:

> _______________________________________________
> conex mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/conex

---

From: Ingemar Johansson S <[email-masked]>
Date: Fri, 22 Oct 2010 09:31:33 +0200

Ok

understand, perhaps it is then best to wait for the discussion in 6man first.

Regards
Ingemar 

> -----Original Message-----
> From: Fred Baker [mailto:[email-masked]] 
> Sent: den 21 oktober 2010 14:47
> To: Ingemar Johansson S
> Cc: [email-masked]
> Subject: Re: [conex] Reserved header bits in IPv6
> 
> Two comments:
> 
> 1) as far as I'm concerned, the entire 20 bit flow label 
> field is "reserved bits". While there have been periodic 
> discussions of how it might be used, I don't see a lot of use of it.
> 2) unless 6man agrees, it's probably not a good idea to build 
> on this beyond making a good case for reserved bits.
>