Subject: [core] CORE WG Update

From: Cullen Jennings <[email-masked]>
Date: Fri, 4 Jun 2010 10:41:31 -0600

Carsten and I with our WG chair hats on have been talking about how to keep the WG moving forward. We requested input on selecting draft-shelby-core-coap as a WG document. We received very few objections to this thought there is clearly significant open issues around the Subscribe/Notify topic and several other smaller open issues. We do no see any reasons that these issues can not be resolved as part of the working group process - in fact we believe it is better to do this using the WG consensus process. We are not seeing any other significantly different proposal. Some of the issues raised fall well outside the scope that the charter restricts us to. So at this point, we are going to adopting the draft-shelby-core-coap draft as a WG document. It will get resubmitted under the name draft-ietf-core-coap. 

This does not mean we are going to using the SUB/NOT mechanisms as they are currently described in the draft - the working group still needs to discuss what they want and come to consensus around that then the editors of the draft will update it to reflect that consensus. Continued discussion is needed on many topics in this draft before it is done but at this point, the draft is suitable as a  "straw man" that the WG can start working from. So far the draft has been an individual draft in that the authors can put whatever they want in it - as it changes to being a WG document, the editors need to put into the draft not what they want but what the WG wants. We as the working group need to use the current draft as a starting point and figure out what changes are need such that it reflects something we can all live with. 

Carsten and I would like to keep this moving along as quickly as possible. The editor team plans to have a new version out before the end of June that reflects the latest email list discussion. Some topics that we hope folks can make good progress on via email are:

1) The plan for how to do security. I've talked to a few people about this and will try and put out some combined ideas and to get the conversation started. 

2) Come to some conclusions on the overall design of SUB/NOT. 

3) How can we simplify COAP? Lots of things got put in because seemed like a good idea at the time but all these little things accumulate to add complexity. What things can we toss out, make optional, or just plain simplify?

I have heard about multiple working COAP implementations and think it would be fun (and useful) to see how they work together.  I would like to propose that the Sunday before the next IETF, we have a bit of a hack fest and see how we can do on the "running code" part of protocol design. We will need to get AD approval for this but I that should not be a problem. 

Thanks to everyone for the ongoing discussions. 

Cullen & Carsten
Core WG Co-Chairs

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 04 Jun 2010 15:49:35 -0600

On 6/4/10 10:41 AM, Cullen Jennings wrote:

> I have heard about multiple working COAP implementations and think it
> would be fun (and useful) to see how they work together.  I would
> like to propose that the Sunday before the next IETF, we have a bit
> of a hack fest and see how we can do on the "running code" part of
> protocol design. We will need to get AD approval for this but I that
> should not be a problem.

Your sponsoring AD approves.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/