Subject: [core] Fwd: New Version Notification for draft-bormann-coap-misc-02

From: Carsten Bormann <[email-masked]>
Date: Wed, 30 Jun 2010 17:01:07 +0200

We said we were going to respin this frequently.
The most important addition is the proposal for a simplified/fixed option encoding (section 6).
This is an element that would go into coap-01, so feedback would be very welcome.

Gruesse, Carsten

Begin forwarded message:

> From: IETF I-D Submission Tool <[email-masked]>
> Date: June 30, 2010 16:57:40 +0200
> To: [email-masked]
> Cc: [email-masked]
> Subject: New Version Notification for draft-bormann-coap-misc-02 
> 
> 
> A new version of I-D, draft-bormann-coap-misc-02.txt has been successfully submitted by Carsten Bormann and posted to the IETF repository.
> 
> Filename:	 draft-bormann-coap-misc
> Revision:	 02
> Title:		 Miscellaneous additions to CoAP
> Creation_date:	 2010-06-30
> WG ID:		 Independent Submission
> Number_of_pages: 24
> 
> Abstract:
> This short I-D makes a number of partially interrelated proposals how
> to solve certain problems in the CoRE WG's main protocol, CoAP.
> 
> 
> 
> The IETF Secretariat.
>

---

From: "Pete St. Pierre" <[email-masked]>
Date: Wed, 30 Jun 2010 10:32:21 -0700

Is there a target publication date for coap-01?  If this is going to be the foundation for the plugfest, sooner would be preferable to later :-)

Cheers, 
...Pete
On Jun 30, 2010, at 8:01 AM, Carsten Bormann wrote:

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

--
Pete St. Pierre
[email-masked]
Sun Labs
Oracle 
16 Network Circle
Menlo Park, CA 94025

---

From: Zach Shelby <[email-masked]>
Date: Wed, 30 Jun 2010 22:44:04 +0300

My goal is to get it out by mid next week, I have already closed quite a few tickets and am probably about 50% done with the changes.  So far looking good.

We still have some work to do on finishing the proxy, HTTP mapping and discovery sections. The subscription proposal will be put into coap-observe for now as to keep coap-01 very stable. Quick comments/help/opinions as questions come up on the list will help us get tickets closed faster, thanks! 

Zach 

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 30 Jun 2010 21:58:22 +0200

On Jun 30, 2010, at 19:32, Pete St. Pierre wrote:

> target publication date for coap-01?

The absolute deadline is July 12, because that is the I-D cutoff.
But I think Zach and friends will be way faster than that.

So how do you like Klaus' and my proposal for the option encoding?

Gruesse, Carsten