Subject: [core] Comments on draft-hartke-coap-observe-00

From: Robert Cragie <[email-masked]>
Date: Sun, 04 Jul 2010 18:20:11 +0100

Sorry these are a little late.

 To summarize:

	* The document moves around layers of abstraction somewhat. Some of
the concepts are quite abstract (observer, subject etc.), then it
talks about messages, then it refers to reliable UDP. I think it
should keep to the abstract level and defer discussion on the more
specific layers to other documents
	* I know I have said this before but I believe it is important to
abstract the transaction model from the methods themselves. This means
we can put a clean break between the RESTful part (plus pub/sub) and
the transactions (HTTP-like or more asynchronous for M2M). What may be
missing is to specify abstract properties of the delivery, which is
sort of addressed by message types in this document.

 I tried to attach as modified original but I think it was too large
for mail server. In the attachment my comments are in as .  indicates
where I have put out text not directly relevant to the comment.

 Robert
-- 

	Robert Cragie (Pacific Gas & Electric) 

	Gridmerge Ltd.
 89 Greenfield Crescent,
 Wakefield, WF4 4WA, UK
 +44 1924 910888
 +1 415 513 0064
http://www.gridmerge.com [1]

Links:
------
[1] http://www.gridmerge.com/

---

From: Zach Shelby <[email-masked]>
Date: Mon, 5 Jul 2010 09:48:08 +0300

On Jul 4, 2010, at 8:20 PM, Robert Cragie wrote:

> 	• The document moves around layers of abstraction somewhat. Some of the concepts are quite abstract (observer, subject etc.), then it talks about messages, then it refers to reliable UDP. I think it should keep to the abstract level and defer discussion on the more specific layers to other documents

Definitely. In the next version I would like to see two parts to the document actually. 1. The requirements and purely abstract model (using sane terminology).  2. The solution for doing subscription using coap-01 (so it still makes it before the -01 cutoff). We decided to move the solution to the next version of coap-observe to avoid contaminating the base coap document while it is perfected. The goal is to move the feature to coap-02 after Maastricht. 

> 	• I know I have said this before but I believe it is important to abstract the transaction model from the methods themselves. This means we can put a clean break between the RESTful part (plus pub/sub) and the transactions (HTTP-like or more asynchronous for M2M). What may be missing is to specify abstract properties of the delivery, which is sort of addressed by message types in this document.

Bingo! This is exactly what we have done in coap-01, so far it seems to work nicely, and it even further simplified the header.

Zach

> I tried to attach as modified original but I think it was too large for mail server. In the attachment my comments are in as <RCC></RCC>. <snip> indicates where I have put out text not directly relevant to the comment.
> 
> Robert
> -- 
> http://www.gridmerge.com
> <draft-hartke-coap-observe-00-rcc-comments.txt>_______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297