Subject: [core] Fwd: New Version Notification for draft-ietf-core-coap-01

From: Zach Shelby <[email-masked]>
Date: Thu, 8 Jul 2010 11:34:12 +0300

CoAP-01 is now available:

http://www.ietf.org/id/draft-ietf-core-coap-01.txt

Thanks to everyone on the list, and especially Carsten and Klaus for a huge amount of help in getting this done and in such good shape. Since -00 we have closed 14 tickets and gone through 10 editorial versions. This version of the draft will now be used as the basis for the Maastricht plugfest. CoAP-02 is planned for just after Maastricht to take into account interop feedback and integrate subscription.  More coming about plugfest organization soon.

   Changes from ietf-00 to ietf-01:

      o New cleaner transaction message model and header (#5)
      o Removed subscription while being designed (#1)
      o Section 2 re-written (#3)
      o Text added about use of short URIs (#4)
      o Improved header option scheme (#5, #14)
      o Date option removed whiled being designed (#6)
      o New text for CoAP default port (#7)
      o Completed proxying section (#8)
      o Completed resource discovery section (#9)
      o Completed HTTP mapping section (#10)
      o Several new examples added (#11)
      o URI split into 3 options (#12)
      o MIME type defined for link-format (#13, #16)
      o New text on maximum message size (#15)
      o Location Option added

Zach

Begin forwarded message:

> From: IETF I-D Submission Tool <[email-masked]>
> Date: July 8, 2010 11:24:54 AM GMT+03:00
> To: [email-masked]
> Cc: [email-masked],[email-masked]
> Subject: New Version Notification for draft-ietf-core-coap-01 
> 
> 
> A new version of I-D, draft-ietf-core-coap-01.txt has been successfully submitted by Zach Shelby and posted to the IETF repository.
> 
> Filename:	 draft-ietf-core-coap
> Revision:	 01
> Title:		 Constrained Application Protocol (CoAP)
> Creation_date:	 2010-07-08
> WG ID:		 core
> Number_of_pages: 36
> 
> Abstract:
> This document specifies the Constrained Application Protocol (CoAP),
> a specialized RESTful transfer protocol for use with constrained
> networks and nodes for machine-to-machine applications such as smart
> energy and building automation.  These constrained nodes often have
> 8-bit microcontrollers with small amounts of ROM and RAM, while
> networks such as 6LoWPAN often have high packet error rates and a
> typical throughput of 10s of kbit/s.  CoAP provides the REST Method/
> Response interaction model between application end-points, supports
> built-in resource discovery, and includes key web concepts such as
> URIs and content-types.  CoAP easily translates to HTTP for
> integration with the web while meeting specialized requirements such
> as multicast support, very low overhead and simplicity for
> constrained environments.
> 
> 
> 
> The IETF Secretariat.
> 
> 

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 8 Jul 2010 11:48:31 +0200

On Jul 8, 2010, at 10:34, Zach Shelby wrote:

> This version of the draft will now be used as the basis for the Maastricht plugfest.

In preparation for that, the test server at

	coap://ns.tzi.org:61616/

now runs CoAP-01.
(The updated code is very preliminary and doesn't do anything but GET, but the basics should work.)

Gruesse, Carsten