Subject: [core] option header in COAP

From: Hari Hara Sudhan R <[email-masked]>
Date: Wed, 21 Jul 2010 14:23:31 +0530

Hi all,

COAP specifications mention some default values for options.
If the application doesnt provide some of these options then COAP
implementation will add the default values to the message and send it.
Is that right?

Thanks and Regards,
Hari

---

From: Peter Bigot <[email-masked]>
Date: Wed, 21 Jul 2010 13:59:02 -0500

My interpretation is that (a) the implementation need not encode the default
value if the user did not provide one, and furthermore (b) the
implementation is free to not transmit the user-provided value if it is
equal to the default.

(Another reason why I want absence of Uri-Authority to be different from
presence with an empty value.)

Peter

On Wed, Jul 21, 2010 at 3:53 AM, Hari Hara Sudhan R <
[email-masked]> wrote:

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: "Pete St. Pierre" <[email-masked]>
Date: Wed, 21 Jul 2010 12:26:28 -0700

> My interpretation is that (a) the implementation need not encode the default value if the user did not provide one, and furthermore (b) the implementation is free to not transmit the user-provided value if it is equal to the default.

I'm only just beginning a CoAP implementation, but to this point I've interpreted coap-01 this way as well.

...Pete

> (Another reason why I want absence of Uri-Authority to be different from presence with an empty value.)
> 
> Peter
> 
> On Wed, Jul 21, 2010 at 3:53 AM, Hari Hara Sudhan R <[email-masked]> wrote:
> Hi all,
> 

--
Pete St. Pierre
[email-masked]
Sun Labs
Oracle 
16 Network Circle
Menlo Park, CA 94025