Subject: [core] missed (?) open issue

From: Peter Bigot <[email-masked]>
Date: Thu, 29 Jul 2010 07:09:04 -0500

Since header options provide information relevant to the REST transaction,
there should be a mechanism for user-defined (vice protocol-defined) header
options.  Like HTTP's extension-headers.

I thought I once saw a comment from somebody else supporting this, but can't
find it now, so if this is just me still hung up on options, ignore it.

Peter

---

From: Zach Shelby <[email-masked]>
Date: Thu, 29 Jul 2010 14:34:08 +0200

Hi Peter,

We didn't miss this - it is on my list of issues to open a ticket on. 

For the current delta header option design it makes most sense to create a priori an elective "User Defined Option" in which one or more custom fields can be placed in the value.  I propose that we first explore this approach (add it to -misc, try it out). 

If a 2-byte header would be used then it would make more sense to reserve a chunk of the type space for custom use. But we didn't hear interest in changing the current design in the WG meeting. 

Zach 

On Jul 29, 2010, at 2:09 PM, Peter Bigot wrote:

> Since header options provide information relevant to the REST transaction, there should be a mechanism for user-defined (vice protocol-defined) header options.  Like HTTP's extension-headers.
> 
> I thought I once saw a comment from somebody else supporting this, but can't find it now, so if this is just me still hung up on options, ignore it.
> 
> Peter
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 29 Jul 2010 14:40:32 +0200

On Jul 29, 2010, at 14:34, Zach Shelby wrote:

> add it to -misc

Good point.  Will do for -06.

Gruesse, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 29 Jul 2010 14:38:44 +0200

On Jul 29, 2010, at 14:09, Peter Bigot wrote:

> I thought I once saw a comment from somebody else supporting this,

Yes, me:

http://www.ietf.org/mail-archive/web/core/current/msg00592.html

Out of the choices I proposed there, I'd prefer the repeatable option 14.
The initial bytes of the option value would distinguish different kinds of private options.
(If it *has* to be globally unique, get an enterprise number and send the SDNV of that as a start:

   (14)
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| delta | length|1 0 0 0 0 0 0 1|0 1 1 1 0 0 1 1| private opt-id|   value...    |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
                     SDNV of enterprise number

But, of course, that doesn't have to be.)

Of course, you can stuff a lot of what you would consider "options" into that value, so you don't have to make use of a repeatable option if all user-defined options are from one org.

Gruesse, Carsten