Subject: [core] Response Code in ACK in case of asynchronous response

From: Hari Hara Sudhan R <[email-masked]>
Date: Wed, 18 Aug 2010 12:39:15 +0530

Hi all,

In case of asynchronous response when the server sends a response what
is the response code it should use?

Thanks and Regards,
Hari Hara Sudhan R

---

From: Yusuke DOI <[email-masked]>
Date: Wed, 18 Aug 2010 16:27:17 +0900

Hi all,

Let me ask a related question.

- How long should a client wait for asynchronous response, after 
receiving acknowledge?

Personally I think there should be some refresh mechanism (for example, 
periodic ack with same tid) to let client know the server is working on 
the request. Otherwise, the server may lost the state and the client 
have to keeps waiting.

Regards,

// Yusuke DOI <[email-masked]>, TOSHIBA Corp., R&D Center

(2010/08/18 16:09), Hari Hara Sudhan R wrote:
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: Hari Hara Sudhan R <[email-masked]>
Date: Wed, 18 Aug 2010 14:01:52 +0530

Hi all,

Let me be more clear.

In case of asynchronous response when the server sends a acknowledgement what
is the response code it should use?

Thanks and Regards,
Hari Hara Sudhan R

---

From: Olaf Bergmann <[email-masked]>
Date: Wed, 18 Aug 2010 12:11:22 +0200

> is the response code it should use?

Does anything except 200 (in HTTP-speak) make sense?

Gruesse,
Olaf

---

From: Hari Hara Sudhan R <[email-masked]>
Date: Wed, 18 Aug 2010 15:53:41 +0530

> Does anything except 200 (in HTTP-speak) make sense?

200 makes sense.But then how does the client know whether that is just
an acknowledgement or a synchronous response.

May be Im missing something.

Thanks and Regards,
Hari hara Sudhan R

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 18 Aug 2010 12:31:49 +0200

>> is the response code it should use?

I'm not sure I understand the question.  You mean the second message in the four-message exchange?

> Does anything except 200 (in HTTP-speak) make sense?

Well, 200 would mean "here is the (OK) answer now".

Figure 3 from 2.1.2 may be a bit brief:

   Client             Server
      |                 |
      |   CON tid=48    |
      |  GET http://n.. |
      +---------------->|
      |                 |
      |   ACK tid=48    |
      |<----------------+
      |                 |
      ... Time Passes ...
      |                 |
      |   CON tid=783   |
      |  200 http://n.. |
      |     "<html..    |
      |<----------------+
      |                 |
      |   ACK tid=783   |
      +---------------->|
      |                 |

The two messages marked ACK do not carry a code at all, i.e. use code 0.

Gruesse, Carsten

---

From: Hari Hara Sudhan R <[email-masked]>
Date: Wed, 18 Aug 2010 16:49:17 +0530

Thanks a lot. That was my question.
Now it is clear.

Thanks and Regards,
Hari Hara Sudhan R