Subject: [core] COAP dissector for wireshark

From: Shoichi Sakane <[email-masked]>
Date: Thu, 21 Oct 2010 19:43:25 +0900

Hi, just for your interest.

The wireshark from svn 34601 or later has a dissector of COAP.
It supports
 * draft-ietf-core-coap-02.txt
 * draft-ietf-core-block-00.txt
 * draft-ietf-core-observe-00.txt

Any feedback would be appreciated.
I will join the interop at the meeting if I can.

Best,

Shoichi Sakane

---

From: Michael John <[email-masked]>
Date: Thu, 21 Oct 2010 16:13:58 +0200

Hi,

Great! Could you also provide pcap files to play with?
Many thanks.

Best regards
Michael

2010/10/21 Shoichi Sakane <[email-masked]>

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 21 Oct 2010 17:19:06 +0200

> Great! Could you also provide pcap files to play with?

I have started to informally collect pcap files for 6lowpan and RPL in the 6lowpan repository, i.e.:

http://svn.tools.ietf.org/svn/wg/6lowpan/packets

This still needs work as these files have not been vetted -- we need to find out whether they actually are correct (and what version of the spec they are corresponding to).  For now, I'll just add as much information to the README file as I can get.

If you have pcap files plus some metadata, send them to me (or just add them to the svn and update the README).

Gruesse, Carsten

---

From: Shoichi Sakane <[email-masked]>
Date: Fri, 22 Oct 2010 08:56:08 +0900

Hi,

You can find it at the bugzilla database of the wireshark.
   https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5270

These files seem to have some incorrect stub.
Please take it at own your risk, don't trust them as you know.

If you want to have further correct data,
maybe you will find it at the Carsten's repository,
or you will get it at the interop.

Shoichi  Sakane

On 10/21/10 11:13 PM, Michael John wrote:
> 2010/10/21 Shoichi Sakane <[email-masked] <mailto:[email-masked]>>
>
>     [email-masked] <mailto:[email-masked]>