Subject: [core] Establishment of Observation must include a Observe Option ?

From: 王靖 <[email-masked]>
Date: Thu, 22 Sep 2011 16:22:30 +0800

Hi everyone!

Is the establishment of observation must include a observe option and
the type of message must be CON?

---

From: Likepeng <[email-masked]>
Date: Thu, 22 Sep 2011 08:38:10 +0000

For the Observe option, I think Yes, it must be included. 

For the message type, I think Yes too (at least SHOULD), because client expects server to return the Observe option to indicate the observation relationship has been established.

Kind Regards
Kepeng
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of 王靖
Sent: Thursday, September 22, 2011 4:23 PM
To: [email-masked]
Subject: [core] Establishment of Observation must include a Observe Option ?

Hi everyone!

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: Klaus Hartke <[email-masked]>
Date: Thu, 22 Sep 2011 16:55:55 +0200

> Is the establishment of observation must include a observe option and

Yes, a GET request that requests the establishment of an observation
relationship must include an Observe Option.

> the type of message must be CON?

No, the message type can also be NON. I'd assume that most client
implementations will always use CON though. A server must be prepared
to receive both.

Klaus