Subject: Re: [core] Fw: New Version Notification for draft-becker-core-coap-sms-gprs-05.txt

From: Abhijan Bhattacharyya <[email-masked]>
Date: Mon, 1 Sep 2014 15:58:07 +0530

Hi Kepeng,
CoAP over SMS is no doubt an interesting proposition. I just had a quick 
look into the draft and I have a concern on the security consideration 
part. (Sorry if I am going to unknowingly repeat something that has 
already been discussed. )
The security scenario described in your draft is that of undesired message 
explosion and you want to protect through some table look-up to identify 
MSISDN of legitimate end-points. But we may have more problems during 
transfer over the actual GSM carrier. To best of my knowledge GSM has many 
security holes. For example:

1) It is quite possible to launch a man-in-the-middle attack in GSM since 
the MS and BTS do not mutually authenticate. Only the BTS authenticates 
the MS but not the otherway. With the help of some not-so-costly h/w, it 
is quite possible to spoof a BTS to the mobiles under a particular service 
provider (carrier). Then all the data will be routed through the spoofed 
BTS and the MS will not be even aware of that. 
2) The encryption of GSM is also not very great. There are several 
variations and some has known problems. Infact, so far as I know, Govt. of 
some countries (e.g. India) mandate the use of A5/0 encryption - this 
means NO ENCRYPTION. (Possibly France also follows this. Not sure though).
3) 3G has a better security with MS and BTS authenticating each other. 
But, if someone has a phone with multiple RAT (Radio Access Technology) 
then a hacker can, in theory, use something like a high power sinewave 
generator/ radiator to jam the 3G band and force the mobile to fall back 
to the GSM band. The hacker then can use the holes of GSM to do whatever 
possible.

Regards
Abhijan Bhattacharyya
Associate Consultant
Scientist, Innovation Lab, Kolkata, India
Tata Consultancy Services Limited
Mailto: [email-masked]
Website: http://www.tcs.com
____________________________________________
Experience certainty.   IT Services
                        Business Solutions
                        Consulting
____________________________________________

From:   Likepeng <[email-masked]>
To:     "core ([email-masked])" <[email-masked]>
Date:   08/08/2014 01:27 PM
Subject:        [core] Fw: New Version Notification for 
draft-becker-core-coap-sms-gprs-05.txt
Sent by:        "core" <[email-masked]>

Hello all,

In Toronto F2F meeting, we had some discussions about alternative 
transports topic and several people showed interests and supports for the 
SMS transport draft.

We updated the draft recently and here are the changes:
   o  Removed reference to USSD.
   o  Updated reference to RFC7252 and 3GPP specs.
   o  Updated Options.
   o  Adapted URI scheme.

We would appreciate your review and feedback.

Thanks,

Kind Regards
Kepeng (On behalf of co-authors of this draft)

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2014年8月8日 15:51
收件人: Likepeng; Markus Becker; Koojana Kuladinithi; Thomas Poetsch; 
Thomas Poetsch; Markus Becker; Koojana Kuladinithi; Likepeng
主题: New Version Notification for draft-becker-core-coap-sms-gprs-05.txt

A new version of I-D, draft-becker-core-coap-sms-gprs-05.txt
has been successfully submitted by Kepeng Li and posted to the IETF 
repository.

Name:                            draft-becker-core-coap-sms-gprs
Revision:                05
Title:                           Transport of CoAP over SMS
Document date:           2014-08-08
Group:                           Individual Submission
Pages:                           14
URL:            
http://www.ietf.org/internet-drafts/draft-becker-core-coap-sms-gprs-05.txt
Status:         
https://datatracker.ietf.org/doc/draft-becker-core-coap-sms-gprs/
Htmlized:       
http://tools.ietf.org/html/draft-becker-core-coap-sms-gprs-05
Diff:           
http://www.ietf.org/rfcdiff?url2=draft-becker-core-coap-sms-gprs-05

Abstract:
   Short Message Service (SMS) of mobile cellular networks is frequently
   used in Machine-To-Machine (M2M) communications, such as for
   telematic devices.  The service offers small packet sizes and high
   delays just as other typical low-power and lossy networks (LLNs),
   i.e. 6LoWPANs.  The design of the Constrained Application Protocol
   (CoAP) [RFC7252], that took the limitations of LLNs into account, is
   thus also applicable to other transports.  The adaptation of CoAP to
   SMS transport mechanisms is described in this document.
  
Please note that it may take a couple of minutes from the time of 
submission until the htmlized version and diff are available at 
tools.ietf.org.

The IETF Secretariat

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you

---

From: Likepeng <[email-masked]>
Date: Tue, 2 Sep 2014 01:32:32 +0000

Hi Abhijan,

Thanks for raising this issue.

Currently in OMA LightweightM2M, there are also some discussions about security issues for SMS transport.

Once they have conclusions, we will update the security considerations section accordingly.

Kind Regards
Kepeng

发件人: Abhijan Bhattacharyya [mailto:[email-masked]]
发送时间: 2014年9月1日 18:28
收件人: Likepeng
抄送: core ([email-masked])
主题: Re: [core] Fw: New Version Notification for draft-becker-core-coap-sms-gprs-05.txt

Hi Kepeng,
CoAP over SMS is no doubt an interesting proposition. I just had a quick look into the draft and I have a concern on the security consideration part. (Sorry if I am going to unknowingly repeat something that has already been discussed. )
The security scenario described in your draft is that of undesired message explosion and you want to protect through some table look-up to identify MSISDN of legitimate end-points. But we may have more problems during transfer over the actual GSM carrier. To best of my knowledge GSM has many security holes. For example:

1) It is quite possible to launch a man-in-the-middle attack in GSM since the MS and BTS do not mutually authenticate. Only the BTS authenticates the MS but not the otherway. With the help of some not-so-costly h/w, it is quite possible to spoof a BTS to the mobiles under a particular service provider (carrier). Then all the data will be routed through the spoofed BTS and the MS will not be even aware of that.
2) The encryption of GSM is also not very great. There are several variations and some has known problems. Infact, so far as I know, Govt. of some countries (e.g. India) mandate the use of A5/0 encryption - this means NO ENCRYPTION. (Possibly France also follows this. Not sure though).
3) 3G has a better security with MS and BTS authenticating each other. But, if someone has a phone with multiple RAT (Radio Access Technology) then a hacker can, in theory, use something like a high power sinewave generator/ radiator to jam the 3G band and force the mobile to fall back to the GSM band. The hacker then can use the holes of GSM to do whatever possible.

Regards
Abhijan Bhattacharyya
Associate Consultant
Scientist, Innovation Lab, Kolkata, India
Tata Consultancy Services Limited
Mailto: [email-masked]<mailto:[email-masked]>
Website: http://www.tcs.com<http://www.tcs.com/>
____________________________________________
Experience certainty.        IT Services
                       Business Solutions
                       Consulting
____________________________________________

From:        Likepeng <[email-masked]<mailto:[email-masked]>>
To:        "core ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>
Date:        08/08/2014 01:27 PM
Subject:        [core] Fw: New Version Notification for draft-becker-core-coap-sms-gprs-05.txt
Sent by:        "core" <[email-masked]<mailto:[email-masked]>>
________________________________

Hello all,

In Toronto F2F meeting, we had some discussions about alternative transports topic and several people showed interests and supports for the SMS transport draft.

Thanks,

Kind Regards

-----邮件原件-----
发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
发送时间: 2014年8月8日 15:51
收件人: Likepeng; Markus Becker; Koojana Kuladinithi; Thomas Poetsch; Thomas Poetsch; Markus Becker; Koojana Kuladinithi; Likepeng
主题: New Version Notification for draft-becker-core-coap-sms-gprs-05.txt

A new version of I-D, draft-becker-core-coap-sms-gprs-05.txt
has been successfully submitted by Kepeng Li and posted to the IETF repository.

Name:                                  draft-becker-core-coap-sms-gprs
Revision:                 05
Title:                                  Transport of CoAP over SMS
Document date:                 2014-08-08
Group:                                  Individual Submission
Pages:                                  14
URL:            http://www.ietf.org/internet-drafts/draft-becker-core-coap-sms-gprs-05.txt
Status:         https://datatracker.ietf.org/doc/draft-becker-core-coap-sms-gprs/
Htmlized:       http://tools.ietf.org/html/draft-becker-core-coap-sms-gprs-05
Diff:           http://www.ietf.org/rfcdiff?url2=draft-becker-core-coap-sms-gprs-05

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
core mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/core

---

From: Abhijan Bhattacharyya <[email-masked]>
Date: Tue, 2 Sep 2014 11:18:22 +0530

Hi Kepeng,
Thanks for the information.

Regards
Abhijan Bhattacharyya
Associate Consultant
Tata Consultancy Services

From:   Likepeng <[email-masked]>
To:     Abhijan Bhattacharyya <[email-masked]>
Cc:     "core ([email-masked])" <[email-masked]>
Date:   09/02/2014 07:03 AM
Subject:        Re: [core] Fw: New Version Notification for 
draft-becker-core-coap-sms-gprs-05.txt

Hi Abhijan,

Currently in OMA LightweightM2M, there are also some discussions about 
security issues for SMS transport.
 
Once they have conclusions, we will update the security considerations 
section accordingly.
 
Kind Regards
Kepeng
 
发件人: Abhijan Bhattacharyya [mailto:[email-masked]] 
发送时间: 2014年9月1日 18:28
收件人: Likepeng
抄送: core ([email-masked])
主题: Re: [core] Fw: New Version Notification for 
draft-becker-core-coap-sms-gprs-05.txt
 
Hi Kepeng, 

Regards
Abhijan Bhattacharyya
Associate Consultant

Hello all,

Thanks,

Kind Regards

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2014年8月8日 15:51
收件人: Likepeng; Markus Becker; Koojana Kuladinithi; Thomas Poetsch; 

Abstract:

The IETF Secretariat

---

From: Likepeng <[email-masked]>
Date: Thu, 11 Sep 2014 00:25:37 +0000

Hi Abhijan,

In DTLS WG, there is one draft related to DTLS over SMS:
http://tools.ietf.org/html/draft-fossati-dtls-over-gsm-sms-00

This can solve some of the security concerns.

Kind Regards
Kepeng

Hi Kepeng,

Regards
Abhijan Bhattacharyya
Associate Consultant

Hello all,

Thanks,

Kind Regards

-----邮件原件-----
发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
发送时间: 2014年8月8日 15:51
收件人: Likepeng; Markus Becker; Koojana Kuladinithi; Thomas Poetsch; Thomas Poetsch; Markus Becker; Koojana Kuladinithi; Likepeng
主题: New Version Notification for draft-becker-core-coap-sms-gprs-05.txt

Abstract:

The IETF Secretariat

---

From: "weigengyu" <[email-masked]>
Date: Mon, 15 Sep 2014 10:25:10 +0800

Hi Kepeng, 

About your draft I have a problem:
    In the draft “draft-becker-core-coap-sms-gprs-05.txt” Section 4 Scenarios,
MO-MT, MT and MO scenarios are given. 

    Probably the scenario using SMS systems as intermediary needs considering. 
Such a scenario is much like summrizing above scenarios, and all mobile systems are as intermediaries. 
The message exchange is described as following:
    A CoAP client,  maybe on a mobile terminal with WiFi, sends a CoAP message to a SMS Gateway of mobile opterator, 
then the CoAP message is conveyed by SMS system to a destionation mobile terminal. 
The destination mobile terminal delivers the CoAP  message to a CoAP server over LLN.

Is this scenario required?

Regards, 

Gengyu WEI
Network Technology Center
School of Computer 
Beijing University of Posts and Telecommunications

From: Likepeng 
Sent: Thursday, September 11, 2014 8:25 AM
To: Abhijan Bhattacharyya 
Cc: mailto:[email-masked] 
Subject: Re: [core] Fw: New Version Notification for draft-becker-core-coap-sms-gprs-05.txt

Hi Abhijan,

Kind Regards

Kepeng

Hi Kepeng, 

1) It is quite possible to launch a man-in-the-middle attack in GSM since the MS and BTS do not mutually authenticate Only the BTS authenticates the MS but not the otherway. With the help of some not-so-costly h/w, it is quite possible to spoof a BTS to the mobiles under a particular service provider (carrier). Then all the data will be routed through the spoofed BTS and the MS will not be even aware of that. 
2) The encryption of GSM is also not very great. There are several variations and some has known problems. Infact, so far as I know, Govt. of some countries (e.g. India) mandate the use of A5/0 encryption - this means NO ENCRYPTION. (Possibly France also follows this. Not sure though). 
3) 3G has a better security with MS and BTS authenticating each other. But, if someone has a phone with multiple RAT (Radio Access Technology) then a hacker can, in theory, use something like a high power sinewave generator/ radiator to jam the 3G band and force the mobile to fall back to the GSM band. The hacker then can use the holes of GSM to do whatever possible. 

Regards
Abhijan Bhattacharyya
Associate Consultant

To:        "core ([email-masked])" <mailto:[email-masked]> 

--------------------------------------------------------------------------------

Hello all,

Thanks,

Kind Regards

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2014年8月8日 15:51
收件人: Likepeng; Markus Becker; Koojana Kuladinithi; Thomas Poetsch; Thomas Poetsch; Markus Becker; Koojana Kuladinithi; Likepeng
主题: New Version Notification for draft-becker-core-coap-sms-gprs-05.txt

Abstract:

The IETF Secretariat

--------------------------------------------------------------------------------
_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core