Subject: [core] draft-jennings-senml status and future

From: Alexandr Krylovskiy <[email-masked]>
Date: Fri, 12 Sep 2014 08:52:08 +0200

Hello,

I am not very well familiar with the whole ietf standardisation process, 
but the latest SenML draft [1] has expired on 2013-04-25. 

I’ve found it being mentioned multiple times on the CoRE mailing list (e.g., [2]) 
and seen it been used in several recent industry and research projects.

What are the latest news/plans regarding the SenML? 
Are there any plans to re-submit a new draft?

[1] http://tools.ietf.org/html/draft-jennings-senml-10
[2] https://www.ietf.org/mail-archive/web/core/current/msg04045.html

Kind regards,
Alexandr

---

From: Wojciech Bober <[email-masked]>
Date: Fri, 12 Sep 2014 10:06:27 +0200

Hi,

I'm also interested in the status of this draft.

Kind regards,
Wojciech Bober

2014-09-12 8:52 GMT+02:00 Alexandr Krylovskiy <[email-masked]
>:

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: Jari Arkko <[email-masked]>
Date: Fri, 12 Sep 2014 13:25:03 +0300

Zach, Cullen: I’d be ready to move forward, don’t think we need more data. Do you have something to wrap up and should we just publish the draft?

JAri

On 12 Sep 2014, at 11:06, Wojciech Bober <[email-masked]> wrote:

> 2014-09-12 8:52 GMT+02:00 Alexandr Krylovskiy <[email-masked]>:
> Hello,
>

---

From: Alexandr Krylovskiy <[email-masked]>
Date: Wed, 17 Sep 2014 12:56:06 +0200

For what it’s worth, I’ve found a typo in the spec: 
‘bu’ should be defined as a string as described further in the text (see diff).

It would be great to see the draft re-published and live on.

--- draft-jennings-senml-10.txt	2012-10-23 00:49:37.000000000 +0200
+++ draft-jennings-senml-10-updated.txt	2014-09-17 12:49:14.000000000 +0200
@@ -398,7 +398,7 @@
                +---------------------------+------+--------+
                |                 Base Name | bn   | String |
                |                 Base Time | bt   | Number |
-               |                Base Units | bu   | Number |
+               |                Base Units | bu   | String |
                |                   Version | ver  | Number |
                | Measurement or Parameters | e    | Array  |
                +---------------------------+------+--------+

---

From: Wojciech Bober <[email-masked]>
Date: Wed, 17 Sep 2014 13:10:44 +0200

I think what's missing from the draft is a section that defines an
efficient binary representation.

The last time I've checked there were some efforts to standarize msgpack
(as binpack). However I've found today that in the end CBOR standard has
been proposed and standarized [2], so probably that could be referenced.

[1] http://tools.ietf.org/html/rfc7049
[2] http://tools.ietf.org/html/rfc7049

-- 
Wojtek

2014-09-17 12:56 GMT+02:00 Alexandr Krylovskiy <
[email-masked]>:

> > Zach, Cullen: I’d be ready to move forward, don’t think we need more
> data. Do you have something to wrap up and should we just publish the draft?
> >
> > JAri
> >