Subject: Re: [core] Seeking input on Implementations of RFC 7250 "Using Raw Public Keys in TLS and DTLS"

From: "Kovatsch Matthias" <[email-masked]>
Date: Thu, 10 Sep 2015 12:04:22 +0000

Hi

What is the status of this? I would be in favor of fixing this according to the specification now, in particular, because we want to release Californium 1.0.0 soon.

Olaf, would you be willing to fix this in TinyDTLS as well?
Hannes, how is it currently implemented in mbed TLS? Do you know about other commercial implementations such as WolfSSL or CyaSSL?

Ciao
Matthias

---

From: Olaf Bergmann <[email-masked]>
Date: Thu, 10 Sep 2015 14:20:43 +0200

"Kovatsch  Matthias" <[email-masked]> writes:

> Hi
>
> What is the status of this? I would be in favor of fixing this
> according to the specification now, in particular, because we want to
> release Californium 1.0.0 soon.

+1

> Olaf, would you be willing to fix this in TinyDTLS as well?

Done on 2015-08-26.  Wireshark has a bugfix since 2015-09-07.

Grüße
Olaf

---

From: "Kovatsch Matthias" <[email-masked]>
Date: Thu, 10 Sep 2015 12:21:39 +0000

> Done on 2015-08-26.  Wireshark has a bugfix since 2015-09-07.

Okay, so the status is that keeping it for interoperability in the flied is off the table :)
Good, let's get the fix into Scandium.

Ciao
Matthias

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 10 Sep 2015 15:43:12 +0200

Hi Matthias,

On 09/10/2015 02:04 PM, Kovatsch  Matthias wrote:
> Hi
> 
> What is the status of this?

I have not received further info from other implementers.

Olaf has already prepared a patch for TinyDTLS and someone has to check
what the status in Californium is.

> I would be in favor of fixing this

Makes sense.

> 
> Olaf, would you be willing to fix this in TinyDTLS as well? Hannes,
> how is it currently implemented in mbed TLS?

I let my co-worker Manuel talk about the mbed TLS implementation since
he is doing the coding.

> Do you know about other
> commercial implementations such as WolfSSL or CyaSSL?

I can check with them. From their webpage it seems that they do not
support raw public key.

Ciao
Hannes

> Ciao Matthias

---

From: "Hudalla Kai (INST/ESY)" <[email-masked]>
Date: Thu, 10 Sep 2015 14:02:23 +0000

Matthias,

I agree with you that we should fix this in Scandium before releasing 1.0.0. I just want to point out that this may result in Californium not being interoperable with existing devices/clients that are already out there (based on already released versions of TinyDTLS, mbed etc.) from the very beginning. I have no clue whether the number of such devices/clients is of any relevance or not, though ...

Regards,
Kai

> -----Original Message-----
> From: core [mailto:[email-masked]] On Behalf Of Kovatsch
> Matthias
> Sent: Thursday, September 10, 2015 2:22 PM
> To: Olaf Bergmann
> Cc: [email-masked] WG
> Subject: Re: [core] Seeking input on Implementations of RFC 7250 "Using
> Raw Public Keys in TLS and DTLS"
> 
> Okay, so the status is that keeping it for interoperability in the
> flied is off the table :) Good, let's get the fix into Scandium.
> 
> Ciao
> Matthias
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: "Kovatsch Matthias" <[email-masked]>
Date: Thu, 10 Sep 2015 14:20:41 +0000

> I agree with you that we should fix this in Scandium before releasing 1.0.0. I
> just want to point out that this may result in Californium not being
> interoperable with existing devices/clients that are already out there (based
> on already released versions of TinyDTLS, mbed etc.) from the very
> beginning. I have no clue whether the number of such devices/clients is of
> any relevance or not, though ...

Yes, I am aware of this possibility. Since there are no real numbers available, we can only speculate. From my experience and talking to many people, I have the feeling that there are actually no DTLS-based devices out there that are intended for actual interoperability across vendors or products. The applications often even use their own optimizations within their deployment...

Thus, I do not see it as a risk, but as a chance to get this right.

Ciao
Matthias

---

From: "Hudalla Kai (INST/ESY)" <[email-masked]>
Date: Thu, 10 Sep 2015 14:30:53 +0000

Ok, just wanted to make sure we are all on the same page.
I have created Bug 477074 [1] in eclipse Bugzilla for Scandium which I will start working on ...

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=477074

Regards,
Kai

> From: Kovatsch Matthias [mailto:[email-masked]]
> Sent: Thursday, September 10, 2015 4:21 PM
> To: Hudalla Kai (INST/ESY); Olaf Bergmann
> Cc: [email-masked] WG
> Subject: RE: [core] Seeking input on Implementations of RFC 7250 "Using
> > I agree with you that we should fix this in Scandium before releasing
> > 1.0.0. I just want to point out that this may result in Californium
> > not being interoperable with existing devices/clients that are
> already
> > out there (based on already released versions of TinyDTLS, mbed etc.)
> > from the very beginning. I have no clue whether the number of such
> > devices/clients is of any relevance or not, though ...
> 
> Yes, I am aware of this possibility. Since there are no real numbers
> available, we can only speculate. From my experience and talking to
> many people, I have the feeling that there are actually no DTLS-based
> devices out there that are intended for actual interoperability across
> vendors or products. The applications often even use their own
> optimizations within their deployment...
>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 10 Sep 2015 16:44:13 +0200

Kovatsch Matthias wrote:
> I have the feeling that there are actually no DTLS-based devices out there that are intended for actual interoperability across vendors or products.

I don't have a basis to feel the same wy in general, but I'm pretty sure
about this with respect to RPK.  Fixing this bug before it gets more
widespread is the right thing to do.

Grüße, Carsten

---

From: Manuel Pegourie-Gonnard <[email-masked]>
Date: Thu, 10 Sep 2015 15:43:44 +0100

> I let my co-worker Manuel talk about the mbed TLS implementation since
It’s not implemented yet in mbed TLS, should happen in a month or two.

Manuel.

-- IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium.  Thank you.

ARM Limited, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No:  2557590
ARM Holdings plc, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No:  2548782

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 11 Sep 2015 10:20:27 +0200

Hi Matthias,

On 09/10/2015 04:20 PM, Kovatsch  Matthias wrote:
> I have the feeling that there are actually no DTLS-based devices out
> there that are intended for actual interoperability across vendors or
> products. The applications often even use their own optimizations
> within their deployment...

I agree that it is a bit hard to measure.

As it can be read in RFC and in
http://www.tschofenig.priv.at/Design-Patterns_HannesTschofenig.pptx,
there are different types of deployments for IoT. Some of the most
widely used models don't require TLS/DTLS. For those deployment models
where DTLS/TLS is applicable two issues can be observed: (a) companies
use no communication security (as discussed in the March IETF plenary)
or (b) they are focusing on higher-performance IoT devices that use
certificate-based authentication (often using A-class processors).

So, we are still at an early stage with the deployment of many of the
security mechanisms but I am convinced that we get there soon. We are
also doing our best to lower the bar for implementers to integrate
DTLS/TLS into their IoT applications (which I think is extremely
important to actually make a difference for the ordinary implementer).

Ciao
Hannes