Subject: [core] Is hashing mandatory in CoMI?

From: Somaraju Abhinav <[email-masked]>
Date: Wed, 2 Sep 2015 18:49:03 +0000

Hi,
I have recently started working with the CoMI draft and one thing that was not clear to me was if it is mandatory to use the Yang hash of the object identifier? I am thinking of using Yang modules we might design for some constrained applications that already have short identifiers.
Thanks,
Abhinav
________________________________________________________ The contents of this e-mail and any attachments are confidential to the intended recipient. They may not be disclosed to or used by or copied in any way by anyone other than the intended recipient. If this e-mail is received in error, please immediately notify the sender and delete the e-mail and attached documents. Please note that neither the sender nor the sender's company accept any responsibility for viruses and it is your responsibility to scan or otherwise check this e-mail and any attachments.

---

From: Michel Veillette <[email-masked]>
Date: Wed, 2 Sep 2015 20:18:59 +0000

For CoMI, YANG hash are mandatory.
We are working of a new draft (CoOL) which will introduce structured (registered) identifier.

Michel Veillette
System Architecture Director
Trilliant Inc.
Tel: 450-375-0556 ext. 237
[email-masked]<mailto:[email-masked]>
www.trilliantinc.com<http://www.trilliantinc.com/>

From: core [mailto:[email-masked]] On Behalf Of Somaraju Abhinav
Sent: 2 septembre 2015 14:49
To: Core ‎[[email-masked]]‎ <[email-masked]>
Subject: [core] Is hashing mandatory in CoMI?

Hi,

---

From: Andy Bierman <[email-masked]>
Date: Wed, 2 Sep 2015 16:15:16 -0700

Hi,

CoMI does not have an option for using plain URIs and identifier strings
instead of object numbers.

Andy

On Wed, Sep 2, 2015 at 11:49 AM, Somaraju Abhinav <
[email-masked]> wrote:

> Hi,
> I have recently started working with the CoMI draft and one thing that was
> not clear to me was if it is mandatory to use the Yang hash of the object
> identifier? I am thinking of using Yang modules we might design for some
> constrained applications that already have short identifiers.
> Thanks,
> Abhinav
> ________________________________________________________ The contents of
> this e-mail and any attachments are confidential to the intended recipient.
> They may not be disclosed to or used by or copied in any way by anyone
> other than the intended recipient. If this e-mail is received in error,
> please immediately notify the sender and delete the e-mail and attached
> documents. Please note that neither the sender nor the sender's company
> accept any responsibility for viruses and it is your responsibility to scan
> or otherwise check this e-mail and any attachments.
>
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>
>

---

From: Somaraju Abhinav <[email-masked]>
Date: Thu, 3 Sep 2015 05:22:29 +0000

Thanks for the info. It might help to put that statement in the draft.

Sent from my Windows Phone
________________________________
From: Andy Bierman<mailto:[email-masked]>
Sent: ‎03/‎09/‎2015 01:15
To: Somaraju Abhinav<mailto:[email-masked]>
Cc: Core ‎[[email-masked]]‎<mailto:[email-masked]>
Subject: Re: [core] Is hashing mandatory in CoMI?

Hi,

Andy

On Wed, Sep 2, 2015 at 11:49 AM, Somaraju Abhinav <[email-masked]<mailto:[email-masked]>> wrote:
Hi,
I have recently started working with the CoMI draft and one thing that was not clear to me was if it is mandatory to use the Yang hash of the object identifier? I am thinking of using Yang modules we might design for some constrained applications that already have short identifiers.
Thanks,
Abhinav
________________________________________________________ The contents of this e-mail and any attachments are confidential to the intended recipient. They may not be disclosed to or used by or copied in any way by anyone other than the intended recipient. If this e-mail is received in error, please immediately notify the sender and delete the e-mail and attached documents. Please note that neither the sender nor the sender's company accept any responsibility for viruses and it is your responsibility to scan or otherwise check this e-mail and any attachments.

_______________________________________________
core mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/core