Subject: [core] Call for adoption of draft-tschofenig-core-coap-tcp-tls

From: Andrew Mcgregor <[email-masked]>
Date: Tue, 3 Nov 2015 15:38:28 +1100

The sense of the room at IETF 94 was that we should adopt this as a working
group document.

This is the corresponding mailing list call, open until November 16.

        Title           : A TCP and TLS Transport for the Constrained
Application Protocol (CoAP)
        Authors         : Carsten Bormann
                          Simon Lemay
                          Valik Solorzano Barboza
                          Hannes Tschofenig
        Filename        : draft-tschofenig-core-coap-tcp-tls-05.txt
        Pages           : 12
        Date            : 2015-11-02

Abstract:
   The Hypertext Transfer Protocol (HTTP) was designed with TCP as the
   underlying transport protocol.  The Constrained Application Protocol
   (CoAP), while inspired by HTTP, has been defined to make use of UDP
   instead of TCP.  Therefore, reliable delivery and a simple congestion
   control and flow control mechanism are provided by the message layer
   of the CoAP protocol.

   A number of environments benefit from the use of CoAP directly over a
   reliable byte stream such as TCP, which already provides these
   services.  This document defines the use of CoAP over TCP as well as
   CoAP over TLS.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-tschofenig-core-coap-tcp-tls/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-tschofenig-core-coap-tcp-tls-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-tschofenig-core-coap-tcp-tls-05

-- 
Andrew McGregor | SRE | [email-masked] | +61 4 1071 2221

---

From: Juan Perez <[email-masked]>
Date: Sat, 7 Nov 2015 21:16:56 +0000

+1

It is important for us (at Microsoft Azure IoT) that this document gets adopted.  Additionally, as part of the OMA LWM2M group, it’s important that CoAP supports TCP/TLS as a standard to enable internet/cloud scenarios.

We’ve run tests between worldwide Azure and non-Azure data centers and have found that a UDP keep-alive is required no more than every 30 seconds in order to maintain reachability between clients and servers.

Thanks,
Juan

From: Andrew Mcgregor [mailto:[email-masked]]
Sent: Monday, November 2, 2015 8:38 PM
To: Core <[email-masked]>
Subject: [core] Call for adoption of draft-tschofenig-core-coap-tcp-tls

The sense of the room at IETF 94 was that we should adopt this as a working group document.

        Title           : A TCP and TLS Transport for the Constrained Application Protocol (CoAP)
        Authors         : Carsten Bormann
                          Simon Lemay
                          Valik Solorzano Barboza
                          Hannes Tschofenig
        Filename        : draft-tschofenig-core-coap-tcp-tls-05.txt
        Pages           : 12
        Date            : 2015-11-02

Abstract:

--
Andrew McGregor | SRE | [email-masked]<mailto:[email-masked]> | +61 4 1071 2221

---

From: Zach Shelby <[email-masked]>
Date: Sun, 8 Nov 2015 00:16:05 +0000

I believe this is important for the industry as a whole, and that we already have seen considerable deployment experience. Agreed this should be adopted.

Sent from Outlook<http://aka.ms/Ox5hz3>

On Sat, Nov 7, 2015 at 1:17 PM -0800, "Juan Perez" <[email-masked]<mailto:[email-masked]>> wrote:

+1

It is important for us (at Microsoft Azure IoT) that this document gets adopted.  Additionally, as part of the OMA LWM2M group, it's important that CoAP supports TCP/TLS as a standard to enable internet/cloud scenarios.

We've run tests between worldwide Azure and non-Azure data centers and have found that a UDP keep-alive is required no more than every 30 seconds in order to maintain reachability between clients and servers.

Thanks,
Juan

Abstract:

________________________________

-- IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Mohit Sethi <[email-masked]>
Date: Sun, 8 Nov 2015 10:06:28 +0900

+1. I agree that this is important and should be adopted.

/--Mohit

On 11/08/2015 09:16 AM, Zach Shelby wrote:
> I believe this is important for the industry as a whole, and that we 
> already have seen considerable deployment experience. Agreed this 
> should be adopted.
>
> Sent from Outlook <http://aka.ms/Ox5hz3>
>
>
>
>
> On Sat, Nov 7, 2015 at 1:17 PM -0800, "Juan Perez" 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
> +1
>
> It is important for us (at Microsoft Azure IoT) that this document 
> gets adopted.  Additionally, as part of the OMA LWM2M group, it’s 
> important that CoAP supports TCP/TLS as a standard to enable 
> internet/cloud scenarios.
>
> We’ve run tests between worldwide Azure and non-Azure data centers and 
> have found that a UDP keep-alive is required no more than every 30 
> seconds in order to maintain reachability between clients and servers.
>
> Thanks,
>
> Juan
>
> *From:*Andrew Mcgregor [mailto:[email-masked]]
> *Sent:* Monday, November 2, 2015 8:38 PM
> *To:* Core <[email-masked]>
> *Subject:* [core] Call for adoption of draft-tschofenig-core-coap-tcp-tls
>
> Andrew McGregor | SRE [email-masked] 
> <mailto:[email-masked]> | +61 4 1071 2221
>
>
> ------------------------------------------------------------------------
>
> -- IMPORTANT NOTICE: The contents of this email and any attachments 
> are confidential and may also be privileged. If you are not the 
> intended recipient, please notify the sender immediately and do not 
> disclose the contents to any other person, use it for any purpose, or 
> store or copy the information in any medium. Thank you.
>
>
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Gilbert Clark <[email-masked]>
Date: Sat, 7 Nov 2015 20:40:22 -0500

+1 vote for adoption

-Gilbert Clark

On 11/7/2015 8:06 PM, Mohit Sethi wrote:
>> We’ve run tests between worldwide Azure and non-Azure data centers 
>> and have found that a UDP keep-alive is required no more than every 
>> 30 seconds in order to maintain reachability between clients and 
>> servers.
>>
>> Thanks,
>>
>> Juan
>>

---

From: "Kepeng Li" <[email-masked]>
Date: Sun, 08 Nov 2015 10:38:51 +0800

+1 for adoption.

Kind Regards
Kepeng

发件人:  Andrew Mcgregor <[email-masked]>
日期:  Tuesday, 3 November, 2015 1:38 pm
至:  Core <[email-masked]>
主题:  [core] Call for adoption of draft-tschofenig-core-coap-tcp-tls

Abstract:

-- 
Andrew McGregor | SRE | [email-masked] | +61 4 1071 2221
_______________________________________________ core mailing list
[email-masked] https://www.ietf.org/mailman/listinfo/core

---

From: Julien Vermillard <[email-masked]>
Date: Sun, 08 Nov 2015 07:14:33 +0000

+1

We suffer the same issues between our servers and our cellular modems.
On some network we need to go down to 20 seconds.

Julien

Le sam. 7 nov. 2015 22:17, Juan Perez <[email-masked]> a écrit :

> +1
>
>
>
> It is important for us (at Microsoft Azure IoT) that this document gets
> adopted.  Additionally, as part of the OMA LWM2M group, it’s important that
> CoAP supports TCP/TLS as a standard to enable internet/cloud scenarios.
>
>
>
> have found that a UDP keep-alive is required no more than every 30 seconds
> in order to maintain reachability between clients and servers.
>
>
>
> Thanks,
>
> Juan
>
>
>
> *From:* Andrew Mcgregor [mailto:[email-masked]]

---

From: Wojciech Bober <[email-masked]>
Date: Sun, 08 Nov 2015 07:24:40 +0000

+1

Same experience as Julien's with even lower (10s) periods on some networks
in Poland.

---

From: Robert Cragie <[email-masked]>
Date: Sun, 8 Nov 2015 23:07:43 +0000

+1 - I fully support adoption of this document.

Robert

---

From: Matthieu Vial <[email-masked]>
Date: Mon, 9 Nov 2015 10:43:19 +0100

+1 for adoption.

---

From: "weigengyu" <[email-masked]>
Date: Mon, 9 Nov 2015 21:34:16 +0800

Hi all,

+1.  It is important. 

And one question. 
Does it need to give more specifications about the UDP-to-TCP and TCP-to-UDP gateways? 

Regards,

Gengyu WEI
Network Technology Center
School of Computer 
Beijing University of Posts and Telecommunications

From: Julien Vermillard 
Sent: Sunday, November 08, 2015 3:14 PM
To: Core 
Subject: Re: [core] Call for adoption of draft-tschofenig-core-coap-tcp-tls

+1  

Julien

  +1

  Thanks,

  Juan

  Abstract:

  -- 

--------------------------------------------------------------------------------
_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: Simon Lemay <[email-masked]>
Date: Tue, 10 Nov 2015 16:59:12 +0000

+1 for adoption
On Mon, Nov 9, 2015 at 05:34 weigengyu <[email-masked]> wrote:

> *From:* Julien Vermillard <[email-masked]>
> *Sent:* Sunday, November 08, 2015 3:14 PM
> *Subject:* Re: [core] Call for adoption of
> draft-tschofenig-core-coap-tcp-tls
>
>
> +1
>
> ------------------------------

---

From: "Parthasarathi R" <[email-masked]>
Date: Mon, 16 Nov 2015 06:41:18 +0530

+1

From: core [mailto:[email-masked]] On Behalf Of Simon Lemay
Sent: Tuesday, November 10, 2015 10:29 PM
To: weigengyu; Core
Subject: Re: [core] Call for adoption of draft-tschofenig-core-coap-tcp-tls

+1 for adoption 

Hi all,

+1.  It is important. 

And one question. 

Regards,

Gengyu WEI

From: Julien Vermillard <mailto:[email-masked]>  

To: Core <mailto:[email-masked]>  

+1  

Julien

+1

Thanks,

Juan

Abstract:

The IETF datatracker status page for this draft is:
 <https://datatracker.ietf.org/doc/draft-tschofenig-core-coap-tcp-tls/> https://datatracker.ietf.org/doc/draft-tschofenig-core-coap-tcp-tls/

There's also a htmlized version available at:
 <https://tools.ietf.org/html/draft-tschofenig-core-coap-tcp-tls-05> https://tools.ietf.org/html/draft-tschofenig-core-coap-tcp-tls-05

A diff from the previous version is available at:
 <https://www.ietf.org/rfcdiff?url2=draft-tschofenig-core-coap-tcp-tls-05> https://www.ietf.org/rfcdiff?url2=draft-tschofenig-core-coap-tcp-tls-05

-- 

  _____

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 16 Nov 2015 04:44:04 +0100

I'm a co-author and I was in the room, but for the record I should
probably also add that I'm in favor of adoption as a WG draft.

Grüße, Carsten

Andrew Mcgregor wrote:
> Andrew McGregor | SRE | [email-masked]

---

From: "Kovatsch Matthias" <[email-masked]>
Date: Mon, 16 Nov 2015 10:11:52 +0000

Despite being a bit late, I also support the adoption of this document.

+1

Matthias

From: core [mailto:[email-masked]] On Behalf Of Andrew Mcgregor
Sent: Dienstag, 3. November 2015 05:38
To: Core <[email-masked]>
Subject: [core] Call for adoption of draft-tschofenig-core-coap-tcp-tls

Abstract:

---

From: Klaus Hartke <[email-masked]>
Date: Mon, 16 Nov 2015 11:49:25 +0100

+1

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 16 Nov 2015 12:00:04 +0100

+1
(Because we already implemented a variant of it.)

---

From: Andrew Mcgregor <[email-masked]>
Date: Wed, 18 Nov 2015 15:14:54 +1100

And it looks like we have pretty good consensus from the list as well.

Authors, please submit your next version as a WG draft under the
name draft-ietf-core-coap-tcp-tls.

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 18 Nov 2015 19:14:57 +0100

Done (with minimal editorial changes only).

Reminder: The two editorial notes still remaining are:
-- what are our recommendations about when the capability to send larger
messages (than reasonable over UDP/DTLS) should actually be used, and
-- should we always set ALPN or only on port 443?

We would appreciate input on how to resolve these; this should then make
the document ready for WGLC.

Grüße, Carsten

Andrew Mcgregor wrote:
> On 3 November 2015 at 15:38, Andrew Mcgregor <[email-masked]
> <mailto:[email-masked]>> wrote:
>