Subject: [core] Open Issues for CoAP over TCP draft

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 30 Nov 2015 17:48:08 +0100

Hi all,

recently the CoAP over TCP draft was submitted as a WG item. To progress
the work I started to add the first open issue t the issue tracker.

Feel free to add further issues that require discussion.

Here is a link to the issue tracker:
http://trac.tools.ietf.org/wg/core/trac/query?component=coap-tcp-tls

Ciao
Hannes

---

From: "weigengyu" <[email-masked]>
Date: Tue, 1 Dec 2015 12:33:22 +0800

Hi,

I would like to put some questions:

1. Whether to consider the inter-operations between CoAP over TCP and CoAP 
over UPD in this draft.
    Or this draft just concerns the CoAP over TCP only.

    My suggestion is to consider the inter-operations.

2. Is a CoAP semantics End-to-end or hop-by-hop.
    The CoAP semantics means both CoAP request/response layer and CoAP 
message layer.

     My suggestion is to handle in End-to-end.

3. Is it a right approach to handle the CoAP semantics, that is CoAP 
request/response semantics is handled in End-to-end
    and the CoAP is handled in hop-by-hop.

    My suggestion is both CoAP request/response and message layer are 
handled in End-to-end.

Regards,

> Hannes

Gengyu WEI
Network Technology Center
School of Computer
Beijing University of Posts and Telecommunications
-----原始邮件----- 
From: Hannes Tschofenig
Sent: Tuesday, December 01, 2015 12:48 AM
To: [email-masked] WG
Subject: [core] Open Issues for CoAP over TCP draft

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core