Subject: [core] #393 (coap-tcp-tls): Observing resource over reliable transports

From: "core issue tracker" <[email-masked]>
Date: Tue, 08 Dec 2015 13:20:17 -0000

#393: Observing resource over reliable transports

 There needs to be a section on how resources can be observed over TCP/TLS.
 Questions include:

 * Do servers need to include a sequence number in notifications, given
 that TCP/TLS provides reliable, in-order delivery?
 * How do servers throttle the stream of notifications when the resource
 changes its state more frequently than the server can send notifications?
 * Does a client have to re-register its interest in a resource if it
 hasn't received a notification for a while but the connection is still up?

-- 
-------------------------+-------------------------------------------------
 Reporter:               |      Owner:  draft-ietf-core-coap-tcp-
  [email-masked]         |  [email-masked]
     Type:  other        |     Status:  new
  technical              |  Milestone:
 Priority:  minor        |    Version:
Component:  coap-tcp-    |   Keywords:
  tls                    |
 Severity:  Active WG    |
  Document               |
-------------------------+-------------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/393>
core <https://tools.ietf.org/core/>

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Tue, 8 Dec 2015 15:13:07 +0000

Did we also need to include the following since TLS requires NON and elides Message-ID.

Observe
Use of Confirmable messages in the Observe draft (section 1.2, 3.5, 3.6, 4.5, 4.5.1)
Use of Message Id in Non-confirmable messages in the Observe draft (section 4.5)
Adaptation of congestion control (section 4.5.1)

Use of Message Id
Use of Message Id to ensure no duplication can occur through the Request/Response layer.
TCP will only ensure no duplication at the TCP layer. It doesn’t prevent an invoking Request/Response layer from sending the message more than once for any reason (good or bad).

-----Original Message-----
From: core issue tracker [mailto:[email-masked]] 
Sent: Tuesday, December 08, 2015 7:20 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: [core] #393 (coap-tcp-tls): Observing resource over reliable transports

 * Do servers need to include a sequence number in notifications, given  that TCP/TLS provides reliable, in-order delivery?
 * How do servers throttle the stream of notifications when the resource  changes its state more frequently than the server can send notifications?
 * Does a client have to re-register its interest in a resource if it  hasn't received a notification for a while but the connection is still up?

-- 
-------------------------+----------------------------------------------
-------------------------+---
 Reporter:               |      Owner:  draft-ietf-core-coap-tcp-
  [email-masked]         |  [email-masked]
     Type:  other        |     Status:  new
  technical              |  Milestone:
 Priority:  minor        |    Version:
Component:  coap-tcp-    |   Keywords:
  tls                    |
 Severity:  Active WG    |
  Document               |
-------------------------+----------------------------------------------
-------------------------+---