Subject: Re: [core] 🔔 Working Group Adoption call for draft-groves-core-dynlink

From: Jaime Jiménez <[email-masked]>
Date: Mon, 5 Sep 2016 08:42:51 +0000

Hi all,

there has been no feedback apart from that of the authors of this draft. Therefore we will be extending the deadline for this draft and we will try to reach a conclusion by the end of this week.

Ciao,
- - Jaime Jiménez

> On 31 Aug 2016, at 03:15, Christian Groves <[email-masked]> wrote:
> 
> No surprise as author I support the draft..
> 
> Regards, Christian
> 
> 
> On 26/08/2016 10:01 PM, Jaime Jiménez wrote:
>> Hi all,
>> 
>> As people are on vacation, let’s extend the deadline few days more to allow people to comment.
>> 
>> Ciao!
>> - - Jaime Jimenez
>> 
>>> On 15 Aug 2016, at 18:05, Jaime Jiménez <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Dear CoRE-WG,
>>> 
>>> As we discussed at last IETF96, working group adoption has been requested for draft-groves-core-dynlink. This draft is the result of a document split and thus the initial status is that of adoption, nevertheless that has to be confirmed on the list. Please reply with your comments, including although not limited to whether or not you support adoption. Non-authors are especially encouraged to comment.
>>> 
>>> Since there are several concurrent WGA calls, we will end the call on *August 26, 2016*.
>>> 
>>> Thanks,
>>> Jaime and Carsten
>> 
>

---

From: Christian Groves <[email-masked]>
Date: Wed, 14 Sep 2016 10:26:25 +1000

Hello Jaime,

One thing to note is that the LwM2M specification (see table 4/section 
5.1.2) makes use of the observe attributes defined in this draft. With 
the core interfaces document split, the LWM2M draft would need to be 
updated to reference the dynlink draft.

Regards, Christian

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 29 Sep 2016 09:04:05 +0200

Hi Jaime,

I missed this call for adoption. I am in favor of having the document
adopted for 2 reasons:

1) First, the content of this draft was contained in the
draft-ietf-core-interfaces-05. For this reason I am actually wondering
why we do a call for adoption in the first place since we are only doing
a document management action here (separating the content into two
documents).

2) Second, as Christian already mentioned the functionality is part of
the LWM2M version 1.0 specification and we would prefer to have a
corresponding IETF document.

Ciao
Hannes

On 08/15/2016 05:05 PM, Jaime Jiménez wrote:
> Dear CoRE-WG,
> 
> As we discussed at last IETF96, working group adoption has been
> requested for draft-groves-core-dynlink. This draft is the result of a
> document split and thus the initial status is that of adoption,
> nevertheless that has to be confirmed on the list. Please reply with
> your comments, including although not limited to whether or not you
> support adoption. Non-authors are especially encouraged to comment.
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 29 Sep 2016 09:10:18 +0200

One other note about the usefulness of the functionality of this document.

draft-groves-core-dynlink defines attributes for use with observe, namely
- Minimum Period
- Maximum Period
- Change Step
- Greater Than
- Less Than

These are obviously important for making CoAP observe usable in IoT
scenarios since otherwise you will unnecessarily generate a lot of traffic.

Since I find this functionality essential for CoAP observe I prefer to
have these attributes documented in an RFC.

Ciao
Hannes