Subject: Re: [core] I-D Action: draft-ietf-core-coap-tcp-tls-04.txt

From: Brian Raymor <[email-masked]>
Date: Tue, 6 Sep 2016 18:30:13 +0000

Refreshing this request for people returning from summer vacations ... I'd appreciate feedback on whether a CoAP+TCP client may immediately send messages after sending its CSM without waiting for the server CSM ...- https://github.com/core-wg/coap-tcp-tls/issues/58.

I plan to publish -05 during the week of 9/12 which will address this set of issues - https://github.com/core-wg/coap-tcp-tls/milestone/3

Thanks,
...Brian

-----Original Message-----
From: core [mailto:[email-masked]] On Behalf Of Brian Raymor
Sent: Wednesday, August 24, 2016 2:22 PM
To: [email-masked]
Subject: Re: [core] I-D Action: draft-ietf-core-coap-tcp-tls-04.txt

-04 addresses all the issues discussed at IETF 96 - with the exception of https://github.com/core-wg/coap-tcp-tls/issues/5. The authors are discussing the scope for a section related to RFC7641 (Observing resources ...).

In addition, I opened a new issue related to mandatory exchange of CSM - https://github.com/core-wg/coap-tcp-tls/issues/58 - where feedback would be helpful.

Both of these issues are targeted for -05.

...Brian

-----Original Message-----
From: core [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, August 24, 2016 2:09 PM
To: [email-masked]
Cc: [email-masked]
Subject: [core] I-D Action: draft-ietf-core-coap-tcp-tls-04.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Constrained RESTful Environments of the IETF.

        Title           : CoAP (Constrained Application Protocol) over TCP, TLS, and WebSockets
        Authors         : Carsten Bormann
                          Simon Lemay
                          Hannes Tschofenig
                          Klaus Hartke
                          Bilhanan Silverajan
                          Brian Raymor
	Filename        : draft-ietf-core-coap-tcp-tls-04.txt
	Pages           : 42
	Date            : 2016-08-24

Abstract:
   The Constrained Application Protocol (CoAP), although inspired by
   HTTP, was designed to use UDP instead of TCP.  The message layer of
   the CoAP over UDP protocol includes support for reliable delivery,
   simple congestion control, and flow control.

   Some environments benefit from the availability of CoAP carried over
   reliable transports such as TCP or TLS.  This document outlines the
   changes required to use CoAP over TCP, TLS, and WebSockets
   transports.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-core-coap-tcp-tls/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-core-coap-tcp-tls-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-core-coap-tcp-tls-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: "weigengyu" <[email-masked]>
Date: Tue, 13 Sep 2016 12:47:38 +0800

Hi Brian,

It needs futher explanations.

Although HTTP/2 optimized some performance of HTTP1.1, it seems not concern 
the Constrained feature of CoAP Node.
The CoAP server may be effected if client immediately sends messages after 
sending its CSM without waiting for the server CSM.
Is the probability of battery loss caused by inconsistency of CSM big or 
small?
Is it a potential means for a client to attack the CoAP server by consuming 
its power?

Reguards,

Gengyu WEI
Network Technology Center
School of Computer
Beijing University of Posts and Telecommunications

-----原始邮件----- 
From: Brian Raymor
Sent: Wednesday, September 07, 2016 2:30 AM
To: [email-masked]
Subject: Re: [core] I-D Action: draft-ietf-core-coap-tcp-tls-04.txt

Refreshing this request for people returning from summer vacations ... I'd 
appreciate feedback on whether a CoAP+TCP client may immediately send 
messages after sending its CSM without waiting for the server CSM ...- 
https://github.com/core-wg/coap-tcp-tls/issues/58.

I plan to publish -05 during the week of 9/12 which will address this set of 
issues - https://github.com/core-wg/coap-tcp-tls/milestone/3

Thanks,
...Brian

-----Original Message-----
From: core [mailto:[email-masked]] On Behalf Of Brian Raymor
Sent: Wednesday, August 24, 2016 2:22 PM
To: [email-masked]
Subject: Re: [core] I-D Action: draft-ietf-core-coap-tcp-tls-04.txt

-04 addresses all the issues discussed at IETF 96 - with the exception of 
https://github.com/core-wg/coap-tcp-tls/issues/5. The authors are discussing 
the scope for a section related to RFC7641 (Observing resources ...).

In addition, I opened a new issue related to mandatory exchange of CSM - 
https://github.com/core-wg/coap-tcp-tls/issues/58 - where feedback would be 
helpful.

...Brian

-----Original Message-----
From: core [mailto:[email-masked]] On Behalf Of 
[email-masked]
Sent: Wednesday, August 24, 2016 2:09 PM
To: [email-masked]
Cc: [email-masked]
Subject: [core] I-D Action: draft-ietf-core-coap-tcp-tls-04.txt

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.
This draft is a work item of the Constrained RESTful Environments of the 
IETF.

        Title           : CoAP (Constrained Application Protocol) over TCP, 
TLS, and WebSockets
        Authors         : Carsten Bormann
                          Simon Lemay
                          Hannes Tschofenig
                          Klaus Hartke
                          Bilhanan Silverajan
                          Brian Raymor
Filename        : draft-ietf-core-coap-tcp-tls-04.txt
Pages           : 42
Date            : 2016-08-24

Abstract: