Subject: [core] COSE Implementations

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 21 Mar 2018 09:23:45 +0000

Hi all,

At the end of the SUIT WG meeting the chairs asked whether those working (or interested in contributing) a COSE implementation in C with an embedded crypto library could step forward.

Nobody showed up. This may probably be due to the overlap of the SUIT and the CORE meeting slots.

I am wondering whether some folks here are working on an embedded COSE implementation in C they are willing to share. Given that COSE is being promoted in many drafts in CORE and in ACE I would be surprised if there is no implementation work going on.

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Ludwig Seitz <[email-masked]>
Date: Wed, 21 Mar 2018 09:37:38 +0000

On 2018-03-21 09:23, Hannes Tschofenig wrote:
> Hi all,
> 
> At the end of the SUIT WG meeting the chairs asked whether those working 
> (or interested in contributing) a COSE implementation in C with an 
> embedded crypto library could step forward.
> 
> I am wondering whether some folks here are working on an embedded COSE 
> implementation in C they are willing to share. Given that COSE is being 
> promoted in many drafts in CORE and in ACE I would be surprised if there 
> is no implementation work going on.
> 
> Ciao
> 
> Hannes

Hannes,

I think part of the problem is that in the embedded space people tend to 
implement only the parts they need and hardcode most of the moving parts 
to the tiny subset of options they support.

You can find some code here:
https://github.com/Gunzter/contiki-ng/blob/oscore_dev/os/net/app-layer/oscore/cose.c

that does a limited subset of Encrypt0

/Ludwig

-- 
Ludwig Seitz, PhD
Security Lab, RISE SICS
Phone +46(0)70-349 92 51

---

From: Olaf Bergmann <[email-masked]>
Date: Wed, 21 Mar 2018 12:42:13 +0100

Hannes,

Hannes Tschofenig <[email-masked]> writes:

> implementation in C they are willing to share. Given that COSE is
> being promoted in many drafts in CORE and in ACE I would be surprised
> if there is no implementation work going on.

I started an implementation for the ACE DTLS profile work but plan to
extend that. Will be open-source soon (i.e., days, not months).

Grüße
Olaf