Subject: [core] http://www.ietf.org/id/draft-urien-core-blockchain-transaction-protocol-00.txt

From: Pascal Urien <[email-masked]>
Date: Fri, 2 Mar 2018 23:11:07 +0100

Dear All

The draft

http://www.ietf.org/id/draft-urien-core-blockchain-transaction-protocol-00.txt

introduces the idea of Blockchain Transaction Protocol for Constraint Nodes

Anybody interested by this new paradigm ?

The goal of the blockchain transaction protocol for constraint nodes  is to
enable the generation of blockchain transactions by constraint  nodes,
according to the following principles :
- transactions are triggered by Provisioning-Messages that include  the
needed blockchain parameters.
- binary encoded transactions are returned in Transaction-Messages,
which include sensors/actuators data. Constraint nodes, associated with
blockchain addresses, compute the transaction signature.

Best Regards

Pascal Urien

---

From: Pascal Urien <[email-masked]>
Date: Sun, 4 Mar 2018 20:20:43 +0100

Hi All

The draft  http://www.ietf.org/id/draft-urien-core-blockchain-
transaction-protocol-00.txt

proposes to forward sensors/actuators data in blockchain transactions for
authentication, publication and dating purposes

Two messages are nedeed, to be inserted in CoAP payload

1) Provisionning Message, such as
==========================

 {
     "type": 1,
     "nonce": 12,
     "gasPrice": 30,
     "gasLimit": 80000,
     "address": "6BAC1B75185D9051AF740AB909F81C71BBB221A6",
     "value": 0
  }

2) Transaction Message, such as
=========================

 {
   "type": 1,
   "transaction":
   "F8 74 // RLP List, length= 116 bytes
    0C // nonce 1 byte =12 decimal
    85 06FC23AC00 // gasPrice = 30 GWei
    83 013880     // gasLimit = 80000 gas
    // recipient address 20 bytes
    94 6BAC1B75185D9051AF740AB909F81C71BBB221A6
    80 // Null Ether Value
    // Data 15 bytes "Temperature=25C"
    8F 54656D70657261747572653D323543
    1B // recovery parameter, 1 byte
    A0 // r, 32 bytes, ECDSA r paramter
    A9B58980F76EE6284800B82A2B5DF13E456887EC0CF426A5E5D6A738EB1784ED
    A0 // s, 32 bytes, ECDSA s parameter
    629633C6A3ED5FEE0FB40E2D1CF251345B885D372857B1A6C4762C9BE914281F
   "

 }

Any comment ?

Pascal