Subject: [core] draft-ietf-core-hop-limit-00

From: Klaus Hartke <[email-masked]>
Date: Sun, 4 Nov 2018 16:34:58 +0100

Hi authors of draft-ietf-core-hop-limit,

the draft was discussed a couple of times in the recent virtual
interims of CoRE, but I'm not sure if the conclusions ever made it the
mailing list.

We discussed the open questions from the August 29 virtual interim
[1], with the following conclusions:

> * Would it be useful to have a general-purpose content format for
> providing details of an alternate server, or is the information too
> DOTS-specific?

In general, a general-purpose content format would be nice, but for
now a DOTS-specific content format is fine.

> * Should a more specific media type than "application/cbor" be used?

Yes. (draft-ietf-dots-signal-channel now uses "application/dots+cbor".)

> * Is {elective, safe to forward, not part of the cache key} the right choice?
> * Is {elective, safe to forward, part of the cache key} the better choice?

The option should be elective, safe-to-forward, and part of the cache
key. If a cache understands the option, it should perform a
greater-than-or-equals comparison instead of just checking for
equality of the option value.

> * Is there a better number than 5.06? (HTTP 506 is: Variant Also
> Negotiates [RFC2295])

Allocating response code 5.06 for "Hop Limit Reached" is fine, since
"Variant Also Negotiates" is unlikely to make it into CoAP.

Best regards,
Klaus

[1] https://www.ietf.org/mail-archive/web/core/current/msg09830.html

---

From: <[email-masked]>
Date: Mon, 5 Nov 2018 08:03:38 +0000

Hi Klaus, 

Thank you. FYI, we considered those comments when editing draft-ietf-core-hop-limit-00.

Early answers to these issues were made by Tiru at: https://mailarchive.ietf.org/arch/msg/core/giPOExiFuWDJdNtRY52g3dMkXAM. 

I do agree that (Allocating response code 5.06 for "Hop Limit Reached" is fine). We can suggest 5.06 when it comes to assigning TBA2 (during the IANA review process). 

Cheers,
Med

> -----Message d'origine-----
> De : core [mailto:[email-masked]] De la part de Klaus Hartke
> Envoyé : dimanche 4 novembre 2018 16:35
> À : [email-masked] WG; [email-masked]
> Objet : [core] draft-ietf-core-hop-limit-00
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core