Subject: [core] Groupcomm for CoAP (RFC 7390) implementations

From: Göran Selander <[email-masked]>
Date: Fri, 14 Dec 2018 10:59:38 +0000

All,

Does anyone know if there is a list of CoAP implementations supporting RFC 7390 (Group Communication for CoAP)? 

http://coap.technology/ mentions RFC 7390 under "specifications" but I didn't find anything under "implementations".

Thanks
Göran

---

From: "Kraus Achim (INST/ECS4)" <[email-masked]>
Date: Wed, 19 Dec 2018 15:25:15 +0000

Hi,

Californium offers a "very early" support for multicast since end of October 2018
(currently in the 2.0.x-SNAPSHOT). 
But I would go that far, to say, this is RFC7390 compliant :-).    

Mit freundlichen Grüßen / Best regards

Achim Kraus

(INST/ECS4) 
Bosch Software Innovations GmbH | Stuttgarter Straße 130 | 71332 Waiblingen | GERMANY | www.bosch-si.com

Sitz: Berlin, Registergericht: Amtsgericht Charlottenburg; HRB 148411 B 
Aufsichtsratsvorsitzender: Dr.-Ing. Thorsten Lücke; Geschäftsführung: Dr. Stefan Ferber, Michael Hahn, Dr. Aleksandar Mitrovic 

-----Original Message-----
From: core <[email-masked]> On Behalf Of Göran Selander
Sent: Freitag, 14. Dezember 2018 12:00
To: [email-masked]
Subject: [core] Groupcomm for CoAP (RFC 7390) implementations

All,

Thanks
Göran

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: Göran Selander <[email-masked]>
Date: Wed, 19 Dec 2018 17:02:06 +0000

Achim, thanks!

It seems there is no list yet of implementations supporting CoAP over multicast. 

I got an indication that Mbed OS implements RFC 7390. Could someone confirm or deny that?

Other CoAP implementations with support for multicast?

Thanks
Göran

> 19 dec. 2018 kl. 16:25 skrev Kraus Achim (INST/ECS4) <[email-masked]>:
> 
> Hi,
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 19 Dec 2018 19:49:45 +0100

> It seems there is no list yet of implementations supporting CoAP over multicast. 

Just for the record: I would expect any CoAP server implementation to support CoAP over multicast; otherwise the requirements in section 7 and 8 about discovery cannot be met.

I think we are talking about support beyond that, as in RFC 7390 support?

Grüße, Carsten

---

From: Göran Selander <[email-masked]>
Date: Wed, 19 Dec 2018 20:10:19 +0000

> 19 dec. 2018 kl. 19:50 skrev Carsten Bormann <[email-masked]>:
> 

Yes, RFC 7390, but not necessarily complete; one reason for the question is to identify which communities may be interested in the updated draft and the upcoming interop test. 

BR
Göran