Subject: [core] I-D Action: draft-ietf-core-sid-06.txt

From: [email-masked]
Date: Thu, 28 Mar 2019 15:05:12 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Constrained RESTful Environments WG of the IETF.

        Title           : YANG Schema Item iDentifier (SID)
        Authors         : Michel Veillette
                          Alexander Pelov
                          Ivaylo Petrov
	Filename        : draft-ietf-core-sid-06.txt
	Pages           : 29
	Date            : 2019-03-28

Abstract:
   YANG Schema Item iDentifiers (SID) are globally unique 64-bit
   unsigned numbers used to identify YANG items.  This document defines
   the semantics, the registration, and assignment processes of SIDs.
   To enable the implementation of these processes, this document also
   defines a file format used to persist and publish assigned SIDs.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-core-sid/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-core-sid-06
https://datatracker.ietf.org/doc/html/draft-ietf-core-sid-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-core-sid-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: ivaylo petrov <[email-masked]>
Date: Thu, 28 Mar 2019 23:07:53 +0100

Dear all,

The new version of the sid draft is uploaded to the datatracker. It is the
result of a number of discussions with IANA representatives. Please review
it and don't hesitate to contact us if you have any questions or comments.

Best regards,
Ivaylo

On Thu, Mar 28, 2019 at 11:05 PM <[email-masked]> wrote:

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Fri, 29 Mar 2019 11:04:11 +0000

Hi Ivaylo,

I have made comments on the -05 version, and the same comments on previous versions, that have been discussed with Carsten twice, but these comments have not gone any further without any explanation why.  Perhaps they have just been missed?

Please can you check back on those threads and either incorporate the appropriate changes into the draft, or explain why you don’t want to make them.

Kind regards,
Rob

From: core <[email-masked]> On Behalf Of ivaylo petrov
Sent: 28 March 2019 22:08
To: [email-masked]
Cc: [email-masked]
Subject: Re: [core] I-D Action: draft-ietf-core-sid-06.txt

Dear all,

The new version of the sid draft is uploaded to the datatracker. It is the result of a number of discussions with IANA representatives. Please review it and don't hesitate to contact us if you have any questions or comments.

Best regards,
Ivaylo

On Thu, Mar 28, 2019 at 11:05 PM <[email-masked]<mailto:internet-drafts@ietf..org>> wrote:

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
core mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/core

Subject: Re: [core] draft-ietf-core-sid-05 and draft-ietf-core-yang-cbor-07
From: Carsten Bormann <[email-masked]>
To: "Rob Wilton (rwilton)" <[email-masked]>
Cc: Michael Richardson <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Date: Fri, 15 Mar 2019 15:42:22 +0000

On Mar 15, 2019, at 14:24, Rob Wilton (rwilton) <[email-masked]> wrote:
>
> In short, I think that it would be more pragmatic if SIDs are restricted to the non-negative range of the signed 64 bit integer type.  I.e. disallow values from (2^63 through 2^64 - 1).

SIDs are unsigned integers.  However, there are still languages that have a hard time with those.  And it helps if all SID deltas fit into a signed 64-bit integer.
So maybe limiting SIDs to the (non-negative) range of signed 64-bit integers is a restriction that makes sense.

https://github.com/core-wg/yang-cbor has three pull requests, but no issues.
(This apparently also happens to be the repo for the SID specification.)

Should we put up the issues there?

Grüße, Carsten