Subject: [core] move sid typedef from draft-ietf-core-comi to draft-ietf-core-sid

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 25 Mar 2019 09:09:54 +0100

Hi,

draft-ietf-core-sid-05 depends on draft-ietf-core-comi-04 because it
imports the definition of the sid type. I think this is a bit
cumbersome and I suggest that the definition of the sid type becomes
part of draft-ietf-core-sid-05. SIDs do not depend on COMI and they
may be used in other protocol contexts (e.g., RESTCONF using CBOR
encoding).

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Peter van der Stok <[email-masked]>
Date: Mon, 25 Mar 2019 01:17:33 -0700

+1

Peter

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 25 Mar 2019 09:19:22 +0100

Good point.

So:

YANG-CBOR depends on none of the other documents (but has informative references to SID and COMI); I’m not sure the SID reference can stay informative though.

SID depends on none of the other documents (with an informative reference to COMI only?).

COMI needs both, of course, and also the core-yang-library (which we still need to adopt!).

Grüße, Carsten

> On Mar 25, 2019, at 09:09, Juergen Schoenwaelder <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: ivaylo petrov <[email-masked]>
Date: Tue, 26 Mar 2019 14:12:26 +0100

Hello,

Thank you for bringing it to our attention! Yes, it is already included in
the next version that is currently being developed.

Best regards,
Ivaylo Petrov

On Mon, Mar 25, 2019 at 9:19 AM Carsten Bormann <[email-masked]> wrote:

> Good point.
>
> So:
>
> YANG-CBOR depends on none of the other documents (but has informative
> references to SID and COMI); I’m not sure the SID reference can stay
> informative though.
>
> > On Mar 25, 2019, at 09:09, Juergen Schoenwaelder <
> [email-masked]> wrote:
> >
> > Hi,
> >