Subject: [core] 🔔 WGLC of draft-ietf-core-senml-more-units

From: Jaime Jiménez <[email-masked]>
Date: Wed, 25 Sep 2019 12:26:18 +0300

Dear CoRE,

this is a WGLC for the senml-more-units draft. The document proposes additional units for
SenML. It has gone through chairs' review and it looks ready from that
point of view. The group is requested to provide more feedback at this
point.

For those familiar with v-00, the diff is available at:
https://tools.ietf.org/rfcdiff?url2=draft-ietf-core-senml-more-units-01.txt

The call will last two weeks until the 9th of October. 

Best Regards,
-- Jaime Jiménez

---

From: Thomas Fossati <[email-masked]>
Date: Wed, 25 Sep 2019 13:23:23 +0000

Hi Jaime, all,

> point of view. The group is requested to provide more feedback at this

I've read draft-ietf-core-senml-more-units-01 and it looks like
a very nicely written document.

I've left a couple of tiny editorial suggestions in a PR.

WRT the note in Section 4:

    "[So does this spec update RFC 8428?]"

I guess the answer is yes?

Cheers, thanks

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 25 Sep 2019 16:22:59 +0200

Hi Thomas,

> I’ve left a couple of tiny editorial suggestions in a PR.

Thank you!

> I guess the answer is yes?

I think so, as the Unit names defined in the secondary registry are now defined as acceptable in SenML unit fields where previously only the primary ones were.  So we can delete the note.

I added the “updates” legend to -01, but forgot to add the requisite information in abstract and intro that would explain that legend.  Now https://github.com/core-wg/senml-more-units/issues/2 —— https://github.com/core-wg/senml-more-units/commit/61cb6396935bec49c192e8debe7f4b0156a56e7f is a proposal to handle this issue.

Grüße, Carsten

---

From: Thomas Fossati <[email-masked]>
Date: Wed, 25 Sep 2019 15:52:05 +0000

On 25/09/2019, 15:23, "Carsten Bormann" <[email-masked]> wrote:
> I added the "updates" legend to -01, but forgot to add the requisite
> information in abstract and intro that would explain that legend.  Now
> https://github.com/core-wg/senml-more-units/issues/2 --
> https://github.com/core-wg/senml-more-units/commit/61cb6396935bec49c192e8debe7f4b0156a56e7f
> is a proposal to handle this issue.

FWIW, the change looks good to me.

Cheers!