Subject: Re: [core] 🔔 CoRE Working Group Adoption call for draft-bormann-senml-more-units-03

From: Jaime Jiménez <[email-masked]>
Date: Mon, 2 Sep 2019 09:33:00 +0300

Dear CoRE,

The call for WG Adoption of draft-bormann-senml-more-units-03 ended yesterday.
During the time we have received positive feedback and good additions to
the subregistry. It looks like the work is necessary and has sufficient
support within the WG, therefore let's adopt this document as a WG item. 

The authors should resubmit the latest version, if possible with Harri's
additions. 

BR,
-- Jaime Jiménez

On Mon, Aug 26, 2019 at 10:31:28AM +0300, Jaime Jiménez wrote:
> Dear all,
> 
> as there seems to be some timing issues with the deadline of the WGA, 
> I'd like to move it ahead few days to the 1st of September. 
> 
> I hope this does not create problems to potential reviewers as there is
> still this week to provide feedback.
> 
> BR,
> -- Jaime Jiménez
> 
> On Wed, Aug 21, 2019 at 11:25:55AM +0300, Jaime Jiménez wrote:
> > 
> > Forgot to add that the call will last a couple of weeks and will end the 
> > 4th of September.
> > 
> > On Wed, Aug 21, 2019 at 11:22:34AM +0300, Jaime Jiménez wrote:
> > > Dear Core WG,
> > > 
> > > We would like to start the call for adoption on
> > > draft-bormann-senml-more-units-03.
> > > >From the minutes I see there was interest in the room during IETF 105.
> > > 
> > > The draft registers some additional basic unit types for SenML (e.g.
> > > Byte, etc). It also proposes a secondary registry of derived units 
> > > (e.g. milisecond, minute, etc)  with different scales and
> > > offset that better adjust to their "common uses".
> > > 
> > > At a general level the need for this secondary registry has been
> > > discussed in other SDOs and they too found it would be useful to have.
> > > In order to encourage interoperability the main unit registry would be
> > > more restricted.
> > > 
> > > BR,
> > > -- Jaime Jiménez
> > > 
> > > _______________________________________________
> > > core mailing list
> > > [email-masked]
> > > https://www.ietf.org/mailman/listinfo/core
> > 
> > _______________________________________________
> > core mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/core
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 2 Sep 2019 10:42:53 +0200

> The authors should resubmit the latest version, if possible with Harri's

Right.  I already prepared a bormann-04 of the individual draft with those additions (and the IPSO particulates one, as well), and that is what I just submitted as ietf-00.

I believe the one thing we need to decide before going for WGLC on this short document is whether we say “Updates 8428” or not.  I now seem to think we should, as we are changing SenML to also allow (“MAY, but SHOULD NOT”) use of the secondary registry, and that sounds like an actual update to me.  (Abstract and Introduction need a sentence on this “Updates”, too.)

Grüße, Carsten

---

From: Jaime Jiménez <[email-masked]>
Date: Mon, 02 Sep 2019 12:57:11 +0300

On Mon, Sep 2, 2019, at 11:42 AM, Carsten Bormann wrote:
> Right.  I already prepared a bormann-04 of the individual draft with 
> those additions (and the IPSO particulates one, as well), and that is 
> what I just submitted as ietf-00.

Great, it is now published!
https://tools.ietf.org/html/draft-ietf-core-senml-more-units-00

> 
> I believe the one thing we need to decide before going for WGLC on this 
> short document is whether we say “Updates 8428” or not.  I now seem to 
> think we should, as we are changing SenML to also allow (“MAY, but 
> SHOULD NOT”) use of the secondary registry, and that sounds like an 
> actual update to me.  (Abstract and Introduction need a sentence on 
> this “Updates”, too.)

Before the really speedy processing of the draft, I think we should make 
sure that the subregistry works as intended. For example, on page 6 it 
says we want to have the same expert review process also when reviewing 
new unit submissions. Are we expecting a lot of those? Are the experts ready
to review those? Maybe we would need to involve some unit experts on that.