Subject: [core] Unregistered CoAP Content Formats

From: Jim Schaad <[email-masked]>
Date: Mon, 16 Sep 2019 10:56:23 -0700

I am in the process of trying to do some clean up and the implementation
that I have has several Content Formats that are not registered in IANA.  I
am trying to determine if this is an oversite and they are used or if it was
just a hiccup in my code base.  I not that at least some of these also
appear to be in Californium as well.

Text/xml = 1
Text/csv = 2
Text/html = 3
Image/Gif = 21
Image/Jpeg = 22
Image/png = 23
Image/tiff = 24
Audio/Raw = 25
Video/Raw = 26
Application/rdf+xml = 43
Application/soap+xml = 44
Application/atom+xml = 45
Application/fastinfoset = 48
Application/soap+fastinfoset = 49
Application/x-obix-binary = 51

Jim

---

From: Robert Quattlebaum <[email-masked]>
Date: Mon, 16 Sep 2019 11:51:01 -0700

These content formats are from way back when the CoAP specification itself was being written.

It seems they first showed up in draft-ietf-core-coap-01: https://tools.ietf.org/html/draft-ietf-core-coap-01#section-11.2 <https://tools.ietf.org/html/draft-ietf-core-coap-01#section-11.2>

They were apparently removed in draft-ietf-core-coap-06: https://tools.ietf.org/html/draft-ietf-core-coap-06#section-11.3 <https://tools.ietf.org/html/draft-ietf-core-coap-06#section-11.3>

Some efforts have apparently been made to avoid allocating new media types to those numbers in the registry, I guess just in case someone needed those media types in the future. It feels like they are being treated like reserved option numbers 128, 132, 136, and 140, except that they don't actually have official reserved status and could be allocated for something completely different at any time.

I would personally avoid using them and remove the definitions for them.

-- RQ

> On Sep 16, 2019, at 10:56 AM, Jim Schaad <[email-masked]> wrote:
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Mehmet Adalier <[email-masked]>
Date: Mon, 16 Sep 2019 12:42:24 -0700

Core-team,

Along the same lines, I’d like to register a content format for the CCSDS Space Packet format.

Could someone provide specific guidelines on how to get this reviewed by core and registered in IANA.

Best

mehmet

From: core <[email-masked]> on behalf of Robert Quattlebaum <[email-masked]>
Date: Monday, September 16, 2019 at 11:51 AM
To: Jim Schaad <[email-masked]>
Cc: core <[email-masked]>
Subject: Re: [core] Unregistered CoAP Content Formats

It seems they first showed up in draft-ietf-core-coap-01: https://tools.ietf.org/html/draft-ietf-core-coap-01#section-11.2

They were apparently removed in draft-ietf-core-coap-06: https://tools.ietf.org/html/draft-ietf-core-coap-06#section-11.3

-- RQ

Text/xml = 1
Text/csv = 2
Text/html = 3
Image/Gif = 21
Image/Jpeg = 22
Image/png = 23
Image/tiff = 24
Audio/Raw = 25
Video/Raw = 26
Application/rdf+xml = 43

Jim

_______________________________________________ core mailing list [email-masked] https://www.ietf.org/mailman/listinfo/core

---

From: Mehmet Adalier <[email-masked]>
Date: Mon, 16 Sep 2019 12:42:24 -0700

Core-team,

Best

mehmet

-- RQ

Text/xml = 1
Text/csv = 2
Text/html = 3
Image/Gif = 21
Image/Jpeg = 22
Image/png = 23
Image/tiff = 24
Audio/Raw = 25
Video/Raw = 26
Application/rdf+xml = 43

Jim

---

From: Jim Schaad <[email-masked]>
Date: Mon, 16 Sep 2019 13:06:27 -0700

Depending on what you are trying to do, the easiest thing is to send mail to IANA with your request and ask for a First Come-First Served value.  This should be a very rapid assignment.  Providing a reference to some type of document is highly desirable, but the reference can just be to you for a description.   If you want a smaller value, then you would need to do something along the lines of writing an RFC and ask for a value.

Jim

From: Mehmet Adalier <[email-masked]> 
Sent: Monday, September 16, 2019 12:42 PM
To: Robert Quattlebaum <[email-masked]>; Jim Schaad <[email-masked]>
Cc: core <[email-masked]>
Subject: Re: [core] Unregistered CoAP Content Formats

Core-team,

Best

mehmet

From: core <[email-masked] <mailto:[email-masked]> > on behalf of Robert Quattlebaum <[email-masked] <mailto:[email-masked]> >
Date: Monday, September 16, 2019 at 11:51 AM
To: Jim Schaad <[email-masked] <mailto:[email-masked]> >
Cc: core <[email-masked] <mailto:[email-masked]> >
Subject: Re: [core] Unregistered CoAP Content Formats

-- RQ

On Sep 16, 2019, at 10:56 AM, Jim Schaad <[email-masked] <mailto:[email-masked]> > wrote:

Text/xml = 1
Text/csv = 2
Text/html = 3
Image/Gif = 21
Image/Jpeg = 22
Image/png = 23
Image/tiff = 24
Audio/Raw = 25
Video/Raw = 26
Application/rdf+xml = 43

Jim

_______________________________________________
core mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/core

_______________________________________________ core mailing list [email-masked] <mailto:[email-masked]>  https://www.ietf.org/mailman/listinfo/core

---

From: Mehmet Adalier <[email-masked]>
Date: Mon, 16 Sep 2019 13:45:03 -0700

Thanks Jim.

I’ll probably take the easy route on this one.

From: Jim Schaad <[email-masked]>
Date: Monday, September 16, 2019 at 1:06 PM
To: 'Mehmet Adalier' <[email-masked]>, 'Robert Quattlebaum' <[email-masked]>
Cc: 'core' <[email-masked]>
Subject: RE: [core] Unregistered CoAP Content Formats

Jim

Core-team,

Best

mehmet

-- RQ

Text/xml = 1
Text/csv = 2
Text/html = 3
Image/Gif = 21
Image/Jpeg = 22
Image/png = 23
Image/tiff = 24
Audio/Raw = 25
Video/Raw = 26
Application/rdf+xml = 43

Jim