Subject: [core] draft-ietf-core-senml-more-units-00

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 12 Sep 2019 15:27:51 +0000

Hi Carsten, Hi all,

When do you expect draft-ietf-core-senml-more-units-00 to be completed?

Ciao
Hannes
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 13 Sep 2019 07:07:56 +0300

Hi Hannes,

Quick answer from my vacation:
The discussion we had during WG adoption raised a couple minor points, but nothing we couldn't handle during a WGLC. So if Jaime can do a chair's review soon, we could WGLC the document afterwards, say, until about Sep 30. 
Deg can be registered right away, but adding the second table requires iesg approval; so we should submit to iesg by, say, Oct 1 and could be approved by the end of the month, barring surprises. This is optimistic, but not unrealistic at all. 

Sent from mobile, sorry for terse

> On 12. Sep 2019, at 18:27, Hannes Tschofenig <[email-masked]> wrote:
> 
> Hi Carsten, Hi all,
>  
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Jaime Jiménez <[email-masked]>
Date: Fri, 13 Sep 2019 09:15:39 +0300

Hi,

I'll try to provide a review in the coming days. 

Ciao!

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 13 Sep 2019 07:16:31 +0000

Thanks, Carsten.

Jaime, can you do a chair review of the document?

From: Carsten Bormann <[email-masked]>
Sent: Freitag, 13. September 2019 06:08
To: Hannes Tschofenig <[email-masked]>
Cc: [email-masked] WG <[email-masked]>
Subject: Re: [core] draft-ietf-core-senml-more-units-00

Hi Hannes,

On 12. Sep 2019, at 18:27, Hannes Tschofenig <[email-masked]<mailto:[email-masked]>> wrote:
Hi Carsten, Hi all,

Ciao
Hannes
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.
_______________________________________________
core mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/core
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 13 Sep 2019 07:17:20 +0000

Thanks!

-----Original Message-----
From: Jaime Jiménez <[email-masked]>
Sent: Freitag, 13. September 2019 08:16
To: Carsten Bormann <[email-masked]>
Cc: Hannes Tschofenig <[email-masked]>; [email-masked] WG <[email-masked]>
Subject: Re: [core] draft-ietf-core-senml-more-units-00

Hi,

Ciao!

---

From: Jaime Jiménez <[email-masked]>
Date: Fri, 13 Sep 2019 12:12:31 +0300

Hi Carsten,

here is the review for the draft.

## General comments

- The Secondary Registry table is probably lacking a description column
  similar to the main SenML registry.

- It looks like "ppm" is not derived from any main SenML unit. As the
  secondary registry is explicity for derived units, shouldn't ppm
  be then in the main SenML registry?   

- There is an open comment on whether the text should update RFC 8428,
  IMO the answer is yes but maybe the authors of both documents and the
  group should decide.

## Editorial

- P4: Says "four", however including the reference there would be five
  columns. 

- P5: "Table 2" is missing the caption.

- P6,P7: Wouldn't the references to IEC and IEEE be informative rather than
  normative?

- P7: IMHO for informational purposes it would help a lot to have references
  to the right locations in BIPM and the IEC, which are referenced themselves in [RS]. 

## Other

- The document indicates that new entries will be added through "Expert
  Review". Often it is the case that little documentation is provided
  when new entries are given to IANA and, since we should avoid
  confusion, I would like to know if we will have specific experts
  versed in the topics of Units to review the entries.

Ciao!

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 13 Sep 2019 21:04:34 +0300

Answering from memory...

> On 13. Sep 2019, at 12:12, Jaime Jiménez <[email-masked]> wrote:
> 
> 
> Hi Carsten,
> 

That could be added, but the scale/offset columns are often all that is needed.  Open for input here. 
>  be then in the main SenML registry?   

The base unit listed is / (slash), the unit we use for dimensionless quantities in senml. Iirc, it even says so. 
>  IMO the answer is yes but maybe the authors of both documents and the

Yes. I now think it does update 8428, as it allows the user of units defined in the secondary table where 8428 only allowed the primary one. 
> - P6,P7: Wouldn't the references to IEC and IEEE be informative rather than

Good question. They are normative for the units defined. 
>  to the right locations in BIPM and the IEC, which are referenced themselves in [RS]. 

Ok; do you have a text proposal?
>  versed in the topics of Units to review the entries.

That is a requirement on the DE already in 8428, so I'm not sure the is a new one here. 
> Ciao!

Thanks for the review. 
Do you think any of this blocks a WGLC?

Grüße, Carsten

---

From: Jaime Jiménez <[email-masked]>
Date: Mon, 16 Sep 2019 10:40:28 +0300

Hi Carsten,

comments inline. If you could send me the link to the repo I (or some
volunteer) can do the additions and after that we can do WGLC.

I can also send you an email with the edits.

Ciao!
> That could be added, but the scale/offset columns are often all that is needed.  Open for input here. 

At least the acronym expansion would help, I can write some suggestions.

> The base unit listed is / (slash), the unit we use for dimensionless quantities in senml. Iirc, it even says so. 

Ok, I see now (P32 RFC8428) that it is used to represent ratio. Sorry for that. 

(Sidenote: I wonder now if there might be some issue in the future as
the "/" character is also used to separate multiple URI path segments.)

> Ok; do you have a text proposal?

Sure I could add a couple of references to those. 

> That is a requirement on the DE already in 8428, so I'm not sure the is a new one here. 

Ok, just wanted to make sure.

> Do you think any of this blocks a WGLC?

I think we can do WGLC after the few edits mentioned before. 

Ciao!

---

From: Jaime Jiménez <[email-masked]>
Date: Mon, 16 Sep 2019 11:53:38 +0300

Found few other nits:

The "kvar" entry is repeated twice.
The "vars" entry is not in the IANA SenML registry. Should it be on this
secondary registry as another entry before "varh"?

Shortly I will send you the .md with the table and the two references I
mentioned.

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 16 Sep 2019 17:23:39 +0300

Great, thank you!   I'll do this when I'm back in DE on Thursday. 

> On 16. Sep 2019, at 11:53, Jaime Jiménez <[email-masked]> wrote:
> 
> Found few other nits:
>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 24 Sep 2019 21:45:38 +0200

On Sep 16, 2019, at 10:53, Jaime Jiménez <[email-masked]> wrote:
> 
> Found few other nits:
> 
> The “kvar" entry is repeated twice.

Fixed in editor’s copy.

> secondary registry as another entry before “varh"?

It should be (and is being added by this draft) on the primary registry.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 24 Sep 2019 22:26:59 +0200

On Sep 16, 2019, at 09:40, Jaime Jiménez <[email-masked]> wrote:

[…]
> At least the acronym expansion would help, I can write some suggestions.

Makes sense.  Thanks for the suggestions; I have massaged them a bit.  Now in editor’s copy.

> the “/" character is also used to separate multiple URI path segments.)

I don’t think SenML as a whole needs to be URL-safe.
(Units don’t occur in SenML names, which in certain cases *are* intended to be parts of URLs.)

> I think we can do WGLC after the few edits mentioned before. 

I actually went ahead and submitted a -01 — if I didn’t miss anything, you can WGLC this.

Grüße, Carsten