Subject: Re: [core] 🔔 WGLC of draft-ietf-core-senml-more-units

From: Joaquin Prado <[email-masked]>
Date: Mon, 7 Oct 2019 09:18:29 +0000

Dear Jaime et al,

Based on the units that we still have pending to register in OMA LwM2M, we are still missing the following units:

* kvarh (kilovolt-ampere reactive per hour)
* kVAh (kilovolt-ampere per hour)
* km    (kilometers)
* kmh   (kilometer per hour)
* rpm    (revolutions per minute)

Please let me know if you have any question.

Regards
---
Joaquin Prado 
 
OMA Director of Technical Programs
Cell:     +1 858 249 8300
email:  [email-masked]
Skype/Slack: jpradocueva
 
www.omaspecworks.org <http://www.omaspecworks.org>
OMA GitHub Organization <https://github.com/OpenMobileAlliance>

On 9/25/19, 6:26 PM, "core on behalf of Jaime Jiménez" <[email-masked] on behalf of [email-masked]> wrote:

    Dear CoRE,
    
    this is a WGLC for the senml-more-units draft. The document proposes additional units for
    SenML. It has gone through chairs' review and it looks ready from that
    point of view. The group is requested to provide more feedback at this
    point.
    
    For those familiar with v-00, the diff is available at:
    https://tools.ietf.org/rfcdiff?url2=draft-ietf-core-senml-more-units-01.txt
    
    The call will last two weeks until the 9th of October. 
    
    Best Regards,
    -- Jaime Jiménez

    _______________________________________________
    core mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/core

---

From: Jaime Jiménez <[email-masked]>
Date: Mon, 7 Oct 2019 13:37:20 +0300

Hi,

Well, we are in WGLC until Wednesday. 

Maybe the authors can still submit a revision with those units if they so choose. 
That is, unless they are deemed too trivial to be included. 
A third option is that others -including OMA- could register more units 
when the sub-registry is up and running. 

Thank you Joaquin for pointing it out.

BR,
-- Jaime Jiménez

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 7 Oct 2019 18:00:33 +0200

> * rpm    (revolutions per minute)

Hi Joaquin,

these can be registered when the document is approved, but it certainly saves time to put them in now.  I have slightly cleaned up the above and put it into the editor’s draft https://core-wg.github.io/senml-more-units/draft-ietf-core-senml-more-units.html (*); diff can be seen below or (together with some previous changes) at https://tinyurl.com/senml-more-units-diff .

Grüße, Carsten

diff --git a/draft-ietf-core-senml-more-units.md b/draft-ietf-core-senml-more-units.md
index 7618e16..c50792f 100644
--- a/draft-ietf-core-senml-more-units.md
+++ b/draft-ietf-core-senml-more-units.md
@@ -123,6 +123,7 @@ subregistry of the SenML registry {{IANA.senml}} (as defined in {{RFC8428}}):
 |--------+------------------------------------------------+-------+-----------|
 | B      | Byte (information content)                     | float | RFCthis   |
 | VA     | volt-ampere (Apparent Power)                   | float | RFCthis   |
+| VAs    | volt-ampere seconds (Apparent Energy)          | float | RFCthis   |
 | var    | volt-ampere reactive (Reactive Power)          | float | RFCthis   |
 | vars   | volt-ampere reactive seconds (Reactive Energy) | float | RFCthis   |
 | J/m    | joule per meter (Energy per distance)          | float | RFCthis   |
@@ -207,6 +208,8 @@ The initial content of the secondary units registry is provided in {{secondary-u
 | Wh             | watt-hour                  | J          |      3600 |        0 | RFCthis     |
 | kWh            | kilowatt-hour              | J          |   3600000 |        0 | RFCthis     |
 | varh           | var-hour                   | vars       |      3600 |        0 | RFCthis     |
+| kvarh          | kilovar-hour               | vars       |   3600000 |        0 | RFCthis     |
+| kVAh           | kilovolt-ampere-hour       | VAs        |   3600000 |        0 | RFCthis     |
 | Wh/km          | watts-hour per kilometer   | J/m        |       3.6 |        0 | RFCthis     |
 | KiB            | kibibyte                   | B          |      1024 |        0 | RFCthis     |
 | mV             | millivolt                  | V          |    1/1000 |        0 | RFCthis     |
@@ -217,6 +220,9 @@ The initial content of the secondary units registry is provided in {{secondary-u
 | ppm            | parts per million          | /          |      1e-6 |        0 | RFCthis     |
 | hPa            | hectopascal                | Pa         |       100 |        0 | RFCthis     |
 | mm             | millimeter                 | m          |    1/1000 |        0 | RFCthis     |
+| km             | kilometer                  | km         |      1000 |        0 | RFCthis     |
+| km/h           | kilometer per hour         | m/s        |     1/3.6 |        0 | RFCthis     |
+| rpm            | (revolutions) per minute   | 1/s        |      1/60 |        0 | RFCthis     |
 {: #secondary-unit-tbl title="Secondary units registered for SenML"}
 
 Example: the value of a quantity given as 100 ms is first multiplied

---

From: Joaquin Prado <[email-masked]>
Date: Tue, 8 Oct 2019 13:42:14 +0000

Hi Carsten,
Thanks for your prompt reply and prepare the work.

We are awaiting for these units to be registered before accepting new LwM2M registrations.
Hopefully, this registration will be done soon.

Thank you and Kind Regards
---
Joaquin Prado 

On 10/8/19, 1:00 AM, "Carsten Bormann" <[email-masked]> wrote:

    Hi Joaquin,

    Grüße, Carsten

---

From: Jaime Jiménez <[email-masked]>
Date: Wed, 9 Oct 2019 16:19:51 +0300

Hi,

today ends the call for this draft. 
The feedback has been positive from all reviewers and it looks the
document is ready to move forward. 

One small nit however is the "rpm" unit, which seems to be already
registered in the main senml registry under the "1/min" name. 
In order to avoid duplication we probably should have one only. 
While OMA folks are making a decission we could simply move this draft forward
without that unit, which they could add afterwars.

Therefore, if the authors and the group are OK with that nit, the
authors can resubmit and we will finalize the WGLC here.

Best Regards,
-- Jaime Jiménez

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 12 Oct 2019 10:33:37 +0200

I have submitted -02 that should address all WGLC comments:

Htmlized:       https://tools.ietf.org/html/draft-ietf-core-senml-more-units-02
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-core-senml-more-units
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-core-senml-more-units-02

I believe this can now be shipped to the IESG.

Grüße, Carsten

> On Oct 9, 2019, at 15:19, Jaime Jiménez <[email-masked]> wrote:
> 
> 
> Hi,
>