Subject: [core] draft-tschofenig-core-senml-lbn-00: Next Steps

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 14 Oct 2019 16:56:19 +0000

Hi all,

We had a testfest organized by the OMA and hosted by TTA in Seoul last week where a number of companies tested LwM2M v1.1. The use of SenML JSON/CBOR is an (optional) feature of v1.1.

I was expecting problems with the uniqueness of the basename in SenML. As mentioned in draft-tschofenig-core-senml-lbn-00, the LwM2M specification interprets the global uniqueness requirement as global to the LwM2M ecosystem whereas the IETF SenML specification appears to interpret it as being much larger.

In any case, there were no problems noticed at the testfest. That's great news and was a surprise to me.

As such, I think it is probably best to discontinue the work on draft-tschofenig-core-senml-lbn-00. Absent any problems in LwM2M v1.1 today I fear I would cause more problems with the introduction of the new "local basename" concept.

I am wondering whether anyone has encountered problems with the global uniqueness requirement elsewhere.

Ciao
Hannes
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Michael Koster <[email-masked]>
Date: Mon, 14 Oct 2019 15:37:23 -0700

Hi Hannes,

Can we see an example of what your bn fields looked like? How does your library process them? It's not terribly suprising to me that nothing failed. After all, how does one test for global uniqueness?

Best regards,

Michael

> On Oct 14, 2019, at 9:56 AM, Hannes Tschofenig <[email-masked]> wrote:
> 
> Hi all, 
>  
> In any case, there were no problems noticed at the testfest. That’s great news and was a surprise to me.  
>  
> As such, I think it is probably best to discontinue the work on draft-tschofenig-core-senml-lbn-00. Absent any problems in LwM2M v1.1 today I fear I would cause more problems with the introduction of the new “local basename” concept. 
>  
> IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you. _______________________________________________
> core mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/core <https://www.ietf.org/mailman/listinfo/core>

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 16 Oct 2019 12:41:45 +0000

> It's not terribly suprising to me that nothing failed. After all, how does one test for global uniqueness?

That said I wonder why nobody noticed working on SenML that this global uniqueness idea was probably not relevant for interoperability and rather was to specify a specific deployment vision instead.

Anyway, here is an example of how the basename is used in a response message for a read operation to /3/0

[{"bn":"/3/0/","n":"0","vs":"Open Mobile Alliance"},
{"n":"1","vs":"Lightweight M2M Client"},
{"n":"2","vs":"345000123"},
{"n":"3","vs":"1.0"},
{"n":"6/0","v":1},
{"n":"6/1","v":5},
{"n":"7/0","v":3800},
{"n":"7/1","v":5000},
{"n":"8/0","v":125},
{"n":"8/1","v":900},
{"n":"9","v":100},
{"n":"10","v":15},
{"n":"11/0","v":0},
{"n":"13","v":1367491215},
{"n":"14","vs":"+02:00"},
{"n":"16","vs":"U"}]

Ciao
Hannes

From: Michael Koster <[email-masked]>
Sent: Dienstag, 15. Oktober 2019 00:37
To: Hannes Tschofenig <[email-masked]>
Cc: [email-masked] WG <[email-masked]>
Subject: Re: [core] draft-tschofenig-core-senml-lbn-00: Next Steps

Hi Hannes,

Best regards,

Michael

On Oct 14, 2019, at 9:56 AM, Hannes Tschofenig <mailto:[email-masked]> wrote:

Hi all,

Ciao
Hannes
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you. _______________________________________________
core mailing list
mailto:[email-masked]
https://www.ietf.org/mailman/listinfo/core