Subject: [core] Coap

From: Francesca Palombini <[email-masked]>
Date: Tue, 19 May 2020 15:31:27 +0000

Hi,

I am working on a proposal to update the http://coap.technology/ website to add work on CoAP security. I have added a Security tab, and some sub-tabs such as DTLS, OSCORE. You can see the result of my PR here: https://github.com/coap-technology/coap-technology.github.io/pull/33 

I included some text right now, but I'd love to include more implementations, for both DTLS and OSCORE!
Also feedback on the proposed text is welcome: for example, I put in DTLS 1.2 and DTLS 1.3, as well as the ACE profiles of DTLS and OSCORE, and Group OSCORE even though these are drafts. 

The easiest way to contribute to this proposal update is by pull request on my repo: https://github.com/fpalombini/coap-technology.github.io 

If you have more comments, unrelated to my proposal update, the way to go about it is to contact Carsten or open issues on the parent repository: https://github.com/coap-technology/coap-technology.github.io 

This is not CoRE work, but is CoRE-topics related, so feedback from anyone here is welcome. 

Thanks,
Francesca

---

From: Thomas Fossati <[email-masked]>
Date: Tue, 19 May 2020 17:02:20 +0100

Hi Francesca,

On Tue, May 19, 2020 at 4:31 PM Francesca Palombini
<[email-masked]> wrote:
> Hi,
>
> I am working on a proposal to update the http://coap.technology/
> website to add work on CoAP security. I have added a Security tab, and
> some sub-tabs such as DTLS, OSCORE. You can see the result of my PR
> here:
> https://github.com/coap-technology/coap-technology.github.io/pull/33
>
> I included some text right now, but I'd love to include more
> implementations, for both DTLS and OSCORE!  Also feedback on the
> proposed text is welcome: for example, I put in DTLS 1.2 and DTLS 1.3,
> as well as the ACE profiles of DTLS and OSCORE, and Group OSCORE even
> though these are drafts.
>
> The easiest way to contribute to this proposal update is by pull
> request on my repo:
> https://github.com/fpalombini/coap-technology.github.io
>
> If you have more comments, unrelated to my proposal update, the way to
> go about it is to contact Carsten or open issues on the parent
> repository:
> https://github.com/coap-technology/coap-technology.github.io
>

This is great!  I'll provide text on the TLS and DTLS profiles for IoT -
which makes me think that one further piece of (possibly) useful
information we could collect regarding implementations is their level of
compliance with said profiles.

Cheers, thanks!

---

From: Francesca Palombini <[email-masked]>
Date: Tue, 26 May 2020 13:42:20 +0000

Hi Thomas!

Thank you, that would be very helpful!! And yes, ideally we would add something about implementation features in there as well... Feel free to PR to my branch directly! (or send text and I will include it)

Oh and obviously the subject was cut short, I was trying to write coap.technology :)

Thanks,
Francesca

On 19/05/2020, 18:02, "Thomas Fossati" <[email-masked]> wrote:

    Hi Francesca,

    > Hi,
    [clipped...]

    Cheers, thanks!