Subject: [core] What is the best introduction to CoRE aims and rationale?

From: John Carter <[email-masked]>
Date: Mon, 4 May 2020 16:14:52 +1200

I'm having a hard time convincing and explaining to some colleagues what
the value of it is.

In particular one colleague is very disbelieving that one can, in practice,
gain effective decoupling of software systems by it.

Thank you!

-- 
John Carter
Phone : (64)(3) 358 6639
Tait Electronics
PO Box 1645 Christchurch
New Zealand

-- 
This Communication is Confidential. We only send and receive email on the

basis of the terms set out at www.taitradio.com/email_disclaimer 
<http://www.taitradio.com/email_disclaimer>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 4 May 2020 08:59:42 +0200

Hi John,

while there is no single document that addresses your needs here, may I point you to a T2TRG draft [1]:

  "RESTful Design for Internet of Things Systems", Ari Keranen, Matthias
  Kovatsch, Klaus Hartke, 2019-11-04, <draft-irtf-t2trg-rest-iot-05.txt>

      This document gives guidance for designing Internet of Things (IoT)
      systems that follow the principles of the Representational State
      Transfer (REST) architectural style.  This document is a product of
      the IRTF Thing-to-Thing Research Group (T2TRG).

This is less about just listing the benefits of REST-oriented design for IoT and more about telling how to actually do that, but it should contain enough material for a good start.

If you have any feedback on how to clarify the argumentation there or otherwise improve the document, I’m sure the authors [2] and/or the T2TRG mailing list [3] would appreciate that.

Grüße, Carsten

[1]: https://tools.ietf.org/html/draft-irtf-t2trg-rest-iot
[2]: mailto:[email-masked]
[3]: mailto:[email-masked]

> On 2020-05-04, at 06:14, John Carter <john.carter=[email-masked]> wrote:
> 
> I'm having a hard time convincing and explaining to some colleagues what the value of it is.
> 
> In particular one colleague is very disbelieving that one can, in practice, gain effective decoupling of software systems by it.
> 
> Thank you!
> 
> -- 
> John Carter
> Phone : (64)(3) 358 6639
> Tait Electronics                         
> PO Box 1645 Christchurch
> New Zealand
> 
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core