Subject: [core] HTTP 418 response code ("I'm a teapot")

From: Carsten Bormann <[email-masked]>
Date: Wed, 10 Jun 2020 19:02:30 +0200

(For those who were in today’s CoRE interim meeting:)

https://developer.mozilla.org/en-US/docs/Web/HTTP/Status/418

I find the universal support in both desktop and mobile browsers intriguing.
What do they do with a 418?

Grüße, Carsten

---

From: <[email-masked]>
Date: Thu, 11 Jun 2020 07:13:17 +0000

Hi Carsten, 

Thank you for the note. 

FWIW, as there is no existing code that can be mapped to what we are doing in the block draft, we just picked the first available value in https://www.iana.org/assignments/http-status-codes/http-status-codes.xhtml#http-status-codes-1 and cross check with https://www.iana.org/assignments/core-parameters/core-parameters.xhtml#response-codes, hence 4.18. 

We can change to 4.19.

Cheers,
Med

> -----Message d'origine-----
> De : core [mailto:[email-masked]] De la part de Carsten Bormann
> Envoyé : mercredi 10 juin 2020 19:03
> À : [email-masked]
> Objet : [core] HTTP 418 response code ("I'm a teapot")
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 11 Jun 2020 09:19:29 +0200

> FWIW, as there is no existing code that can be mapped to what we are doing in the block draft, we just picked the first available value in https://www.iana.org/assignments/http-status-codes/http-st…

Yes.  The more interesting question is whether 4.xx is the right group.
We already have 2.31 for “continue”, i.e. a provisional result that asks to go on.
I’m wondering whether that can be used (with the new payload), or whether a 2.xx would be right in general, as we are not trying to tell the client they have made a mistake and the processing of the request is over.

Grüße, Carsten

---

From: <[email-masked]>
Date: Thu, 11 Jun 2020 07:31:10 +0000

Re- 

Please see inline. 

Cheers,
Med

> De : Carsten Bormann [mailto:[email-masked]]
> Envoyé : jeudi 11 juin 2020 09:19
> À : BOUCADAIR Mohamed TGI/OLN
> Cc : [email-masked]; [email-masked]
> Objet : Re: [core] HTTP 418 response code ("I'm a teapot")
> 
> > FWIW, as there is no existing code that can be mapped to what we are
> doing in the block draft, we just picked the first available value in
> https://www.iana.org/assignments/http-status-codes/http-status-
> codes.xhtml#http-status-codes-1 and cross check with
> https://www.iana.org/assignments/core-parameters/core-
> parameters.xhtml#response-codes, hence 4.18.
> >
> > We can change to 4.19.
> 

[Med] We are in the "gray" area as the error can be of different nature as we report in the draft:

   Likely causes are the client has not sent all blocks, some blocks
   were dropped during transmission, or the client has sent them long
   enough ago that the server has already discarded them.

> I’m wondering whether that can be used (with the new payload), or whether a
> 2.xx would be right in general, as we are not trying to tell the client
> they have made a mistake and the processing of the request is over.

[Med] The use of 2.xx in 7959 is justified, but not in our case:

==
   This class of Response Code indicates that the clients request was
   successfully received, understood, and accepted.
== 

In our case, we need to signal a failure/error not a success. 

No?