Subject: [core] TR: New Version Notification for draft-bosh-core-new-block-03.txt

From: <[email-masked]>
Date: Wed, 17 Jun 2020 13:18:47 +0000

Hi all, 

We updated the draft to address the comments discussed during the last interim meeting. The main changes are as follows:

* Use Request-Tag and ETag instead of the BID. All the block 1-4 options have now the same structure.
* TBA3 (Missing Payloads) payload is defined as a CBOR Sequence. A CDDL for the encoded payload is also provided.
* The server is not a teapot anymore ;-)
* A new content format is defined: "application/cbor-seq+block"

Comments are more than welcome, as usual.  

Thank you. 

Cheers,
Jon & Med

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] 
Envoyé : mercredi 17 juin 2020 15:06
À : Jon Shallow; BOUCADAIR Mohamed TGI/OLN
Objet : New Version Notification for draft-bosh-core-new-block-03.txt

A new version of I-D, draft-bosh-core-new-block-03.txt
has been successfully submitted by Mohamed Boucadair and posted to the
IETF repository.

Name:		draft-bosh-core-new-block
Revision:	03
Title:		Constrained Application Protocol (CoAP) Block-Wise Transfer Options for Faster Transmission
Document date:	2020-06-17
Group:		Individual Submission
Pages:		23
URL:            https://www.ietf.org/internet-drafts/draft-bosh-core-new-block-03.txt
Status:         https://datatracker.ietf.org/doc/draft-bosh-core-new-block/
Htmlized:       https://tools.ietf.org/html/draft-bosh-core-new-block-03
Htmlized:       https://datatracker.ietf.org/doc/html/draft-bosh-core-new-block
Diff:           https://www.ietf.org/rfcdiff?url2=draft-bosh-core-new-block-03

Abstract:
   This document specifies new Constrained Application Protocol (CoAP)
   Block-Wise transfer options: Block3 and Block4 Options.

   These options are similar to the CoAP Block1 and Block2 Options, but
   enable faster transmission rates for large amounts of data with less
   packet interchanges as well as supporting faster recovery should any
   of the blocks get lost in transmission.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 17 Jun 2020 15:31:50 +0200

Quick reply to just this:

> On 2020-06-17, at 15:18, <[email-masked]> <[email-masked]> wrote:
> 
> * A new content format is defined: "application/cbor-seq+block”

RFC 8742 defines the structured syntax suffix "+cbor-seq”.  As the name implies, this comes at the end of the media-type name.  “Block” is OK as a prefix, but maybe we find something more descriptive.  Maybe:

> application/missing-blocks+cbor-seq

Grüße, Carsten

---

From: <[email-masked]>
Date: Wed, 17 Jun 2020 13:38:09 +0000

Hi Carsten,

I agree that "application/missing-blocks+cbor-seq" is more description. Deal! 

This is now fixed: https://www.ietf.org/rfcdiff?url2=draft-bosh-core-new-block-04.

Thanks.

Cheers,
Med

> De : Carsten Bormann [mailto:[email-masked]]
> Envoyé : mercredi 17 juin 2020 15:32
> À : BOUCADAIR Mohamed TGI/OLN
> Cc : [email-masked]; [email-masked]
> Objet : Re: [core] New Version Notification for draft-bosh-core-new-block-
> 03.txt
> 
> RFC 8742 defines the structured syntax suffix "+cbor-seq”.  As the name
> implies, this comes at the end of the media-type name.  “Block” is OK as a
> prefix, but maybe we find something more descriptive.  Maybe:
>