Subject: [core] I-D Action: draft-ietf-core-dev-urn-07.txt

From: [email-masked]
Date: Thu, 02 Jul 2020 01:04:33 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Constrained RESTful Environments WG of the IETF.

        Title           : Uniform Resource Names for Device Identifiers
        Authors         : Jari Arkko
                          Cullen Jennings
                          Zach Shelby
	Filename        : draft-ietf-core-dev-urn-07.txt
	Pages           : 17
	Date            : 2020-07-02

Abstract:
   This memo describes a new Uniform Resource Name (URN) namespace for
   hardware device identifiers.  A general representation of device
   identity can be useful in many applications, such as in sensor data
   streams and storage, or equipment inventories.  A URN-based
   representation can be easily passed along in any application that
   needs the information.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-core-dev-urn/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-core-dev-urn-07
https://datatracker.ietf.org/doc/html/draft-ietf-core-dev-urn-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-core-dev-urn-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Thomas Fossati <[email-masked]>
Date: Thu, 2 Jul 2020 09:21:53 +0000

LGTM, ship it!

Nits: comforming, ambiquity (twice)

On 02/07/2020, 09:06, "[email-masked]" <[email-masked]> wrote:
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.  This draft is a work item of the Constrained RESTful
> Environments WG of the IETF.
>

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Michael Richardson <[email-masked]>
Date: Thu, 02 Jul 2020 12:39:00 -0400

> LGTM, ship it!

I read it, perhaps for the first time, and I agree. It seems ready.

I guess that:
  > DEV URNs do not use r-, q-, or f-components.

refers to some URN thing of which I'm ignorant.
I also confess that I don't know what the difference between an EUI-48 and a
MAC-48, and given that I "know" fffe is what I insert to turn MAC addresses
to IPv6 IIDs, I'm confused which is which now.
This is probably on me.

I guess I have ignored this because it was all SenML-focused, and I haven't
cycles for that.

I wonder if this spec has applicability to be put into IDevID
certificates as a URI SAN.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 2 Jul 2020 18:44:36 +0200

Hi Michael,
hi authors,

> certificates as a URI SAN.

While not mission critical, I'd +1 some expositional text on how 
hardware device identifier URNs relate to secure device identifier DevIDs.

Viele Grüße,

Henk

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 2 Jul 2020 20:24:33 +0200

On 2020-07-02, at 18:44, Henk Birkholz <[email-masked]> wrote:
> 
> While not mission critical, I'd +1 some expositional text on how hardware device identifier URNs relate to secure device identifier DevIDs.

Rathole alert.  We have so far avoided dev-urn getting stuck in the stable identifier debate.  Adding more relationships to things some of us don’t think are acceptable for privacy reasons is not going to help.

(I wouldn’t mind the idevid people writing up how they could use dev-urns.  Once these are an RFC, please…)

Grüße, Carsten

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 2 Jul 2020 21:04:37 +0200

I am fine with vice versa. Having said that, I am not pulling this from 
thin air. The "relations to devid" question is pretty much always the 
first question I encounter when floating this I-D (next to application 
in production today, of course).

Viele Grüße,

Henk

---

From: Michael Richardson <[email-masked]>
Date: Thu, 02 Jul 2020 17:15:45 -0400

Henk Birkholz <[email-masked]> wrote:
    > I am fine with vice versa. Having said that, I am not pulling this from thin
    > air. The "relations to devid" question is pretty much always the first
    > question I encounter when floating this I-D (next to application in
    > production today, of course).

Is it okay if we discuss it on the CORE list?

    Carsten> (I wouldn’t mind the idevid people writing up how they could use
    Carsten> dev-urns.  Once these are an RFC, please…)

I'm not sure who the IDevID people are :-)
I know who are the IETFs who were involved in 802.1AR, but that might not be
quite the same thing.