Subject: [core] Fwd: New Version Notification for draft-ietf-core-dev-urn-06.txt

From: Jari Arkko <[email-masked]>
Date: Wed, 1 Jul 2020 14:39:00 +0300

I submitted a new version of this draft, based on feedback from Marco. The updates relate to further cleanup of the references, and some editorial updates.

Jari

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-ietf-core-dev-urn-06.txt
> Date: 1 July 2020 at 14.37.26 GMT+3
> To: "Cullen Jennings" <[email-masked]>, "Jari Arkko" <[email-masked]>, "Zach Shelby" <[email-masked]>
> 
> 
> A new version of I-D, draft-ietf-core-dev-urn-06.txt
> has been successfully submitted by Jari Arkko and posted to the
> IETF repository.
> 
> Name:		draft-ietf-core-dev-urn
> Revision:	06
> Title:		Uniform Resource Names for Device Identifiers
> Document date:	2020-07-01
> Group:		core
> Pages:		17
> URL:            https://www.ietf.org/internet-drafts/draft-ietf-core-dev-urn-06.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-core-dev-urn/
> Htmlized:       https://tools.ietf.org/html/draft-ietf-core-dev-urn-06
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-core-dev-urn
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-core-dev-urn-06
> 
> Abstract:
>   This memo describes a new Uniform Resource Name (URN) namespace for
>   hardware device identifiers.  A general representation of device
>   identity can be useful in many applications, such as in sensor data
>   streams and storage, or equipment inventories.  A URN-based
>   representation can be easily passed along in any application that
>   needs the information.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 1 Jul 2020 16:37:13 +0200

Looks very good.

Nits: equivalance, assignemnts

I don’t understand this sentence:

   […] For equivalance
   checks, it is RECOMMENDED that lower case letters are used throughout
   by implementations unless there is a reason otherwise.

Does that mean I convert everything to lower case before checking equivalence?  (That’s what this says to me.)  Maybe you mean:

   […] To facilitate equivalence
   checks, it is RECOMMENDED that implementations always use lower case letters where they have a choice in case, unless there is a reason otherwise.

(Also, we usually like to have some idea when a SHOULD [which this is] might not be applicable.)

I probably would like this sentence to be reworded:

   Note that the subtypes defined in this
   document do not require the specific case, however.

Grüße, Carsten