Subject: [core] comments on core-oscore-groupcomm-09

From: Peter van der Stok <[email-masked]>
Date: Thu, 09 Jul 2020 14:29:35 +0200

Dear authors,

After implementing the changes with respect to the former draft with
exclusion of the pairwise mode, I have a question.

Why do I need in the exteranal_aad and in the context both
counter signature parameters and counter signature key parameters. One
looks sufficient to me.

Secondly, It is not clear to me how pairwise keys solve the problem of a
blocked group communication. 
When using block in the multicast request, I assume that using unicasts
to as many destinations is more straightforward.

Greetings,

peter
-- 
Peter van der Stok
vanderstok consultancy
mailto: [email-masked], [email-masked]
www: www.vanderstok.org [1]
tel NL: +31(0)492474673     F: +33(0)966015248 

Links:
------
[1] http://www.vanderstok.org

---

From: Marco Tiloca <[email-masked]>
Date: Fri, 10 Jul 2020 09:23:40 +0200

Hello Peter,

> counter signature parameters and counter signature key parameters. One

==>MT
Regarding the Context, Jim raised the same point in his latest review
[1]. We may end up keeping only Counter Signature Parameters, in its
current format.

Regarding the external_aad , the intent was to closely reflect the way
COSE Capabilities are registered in the COSE Algorithms and COSE Key
Types registries.

[1] https://mailarchive.ietf.org/arch/msg/core/VMhrAPEt4TE8jahatVd1EoDzdMI/
<==

>
> Secondly, It is not clear to me how pairwise keys solve the problem of
> a blocked group communication. 
> When using block in the multicast request, I assume that using
> unicasts to as many destinations is more straightforward.

==>MT
Multicast usage of blockwise is limited to a first multicast request
including the Block2 Option; then the following requests for blocks have
to be sent necessarily over unicast, individually to the different
servers [2].

Those unicast requests can be protected in group mode or in pairwise
mode. Using the pairwise mode prevents the attack described in Section
10.7, which can otherwise be performed by leveraging unicast requests
protected in group mode.

Would it help if the third paragraph of Section 9 includes a pointer to
Section 10.7 ?

Best,
/Marco

[2]
https://tools.ietf.org/html/draft-ietf-core-groupcomm-bis-00#section-2.3.6
<==

>
>
> Greetings,
>
> peter
> -- 
> Peter van der Stok
> vanderstok consultancy
> mailto: [email-masked]
> <mailto:[email-masked]>, [email-masked]
> <mailto:[email-masked]>
> www: www.vanderstok.org <http://www.vanderstok.org>
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

-- 
Marco Tiloca
Ph.D., Senior Researcher

RISE Research Institutes of Sweden
Division ICT
Isafjordsgatan 22 / Kistagången 16
SE-164 40 Kista (Sweden)

Phone: +46 (0)70 60 46 501
https://www.ri.se