Subject: [core] Fwd: [OPSAWG] some comments and thoughts on mud-sbom and sbom-type

From: Carsten Bormann <[email-masked]>
Date: Mon, 24 Aug 2020 07:21:26 +0200

I fished the below out of conversation in opsawg.

The objective is to say “here, but with coaps:// scheme”.

We can say “with the current scheme, but elsewhere” as

//elsewhere.example/.well-known/sbom

But we can’t say

coaps:///.well-known/sbom

out of a resource accessed with coap://

Food for thought.

(I know, use CoRAL :-)

Grüße, Carsten

> Begin forwarded message:
> 
> From: Eliot Lear <lear=[email-masked]>
> Subject: Re: [OPSAWG] some comments and thoughts on mud-sbom and sbom-type
> Date: 2020-08-18 at 15:18:42 CEST
> To: Michael Richardson <[email-masked]>
> Cc: opsawg <[email-masked]>, Brendan Moran <[email-masked]>, Henk Birkholz <[email-masked]>
> Archived-At: <https://mailarchive.ietf.org/arch/msg/opsawg/02vUItNV-HRYdxKrVl8ye8xx3ZI>
> Message-Id: <[email-masked]>
> 
>> 1) It seems that just putting coaps:///.well-known/sbom in the URI might work as well.
>>  If necessary, then maybe: coaps://127.0.0.1/.well-known/sbom or https://[::1]/.well-known/sbom
>>  CoAP does have a Content-Type for returned content, but it is true that
>>  there isn't as much negotiation by default in the form of Accept:
> 
> I don’t think /// is a real construct.  There are two issues.  We don’t know the hostname and we don’t know the scheme.  But the MUD manager does know the hostname, and we need to be provided the scheme.  There is no convention for ME without a pre-existing context. That might be something to work on, but it would hav to happen in coordination with the COAP and HTTP working groups, and I don’t know how big a job it would be.  Thus what’s there.

---

From: Michael Richardson <[email-masked]>
Date: Thu, 27 Aug 2020 22:05:37 -0400

> The objective is to say “here, but with coaps:// scheme”.

Yup.

    > out of a resource accessed with coap://

Maybe you have a suggestion.
rfc6570 has been suggested.

    > (I know, use CoRAL :-)

Could we easily, in a YANG module?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-