Subject: [core] I-D Action: draft-ietf-core-new-block-02.txt

From: [email-masked]
Date: Thu, 29 Oct 2020 02:01:24 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Constrained RESTful Environments WG of the IETF.

        Title           : Constrained Application Protocol (CoAP) Block-Wise Transfer Options for Faster Transmission
        Authors         : Mohamed Boucadair
                          Jon Shallow
	Filename        : draft-ietf-core-new-block-02.txt
	Pages           : 25
	Date            : 2020-10-29

Abstract:
   This document specifies alternative Constrained Application Protocol
   (CoAP) Block-Wise transfer options: Q-Block1 and Q-Block2 Options.

   These options are similar to the CoAP Block1 and Block2 Options, not
   a replacement for them, but do enable faster transmission rates for
   large amounts of data with less packet interchanges as well as
   supporting faster recovery should any of the blocks get lost in
   transmission.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-core-new-block/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-core-new-block-02
https://datatracker.ietf.org/doc/html/draft-ietf-core-new-block-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-core-new-block-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Thu, 29 Oct 2020 09:19:14 +0000

Hi all, 

We published the -02 as per the plan presented in the interim. The main changes are to reflect the outcomes of the interim:
(1) Add a statement that either both or neither options can be supported.
(2) Add an implementation note about how tokens are handled. 
(3) Change the name of the options.
(4) Add a clarification about the behaviour when multiple instances of Q-Block2 are included. 
(5) Remove the "MUST NOT" restriction on 2.31 (Continue) as a provision to (9). 
(6) Clarify what is meant by "repeat request". Marco, please check if the NEW wording is better.  
(7) Overflow discussion. Michael, please check and let us know if we need to say more. 
(8) Update the CDDL and add an implementation note to suggest the use of indefinite-length arrays.
(9) Add a note about the ACK_TIMEOUT delay after MAX_PAYLOADS. 

We are waiting for the feedback from the WG whether (9) is worth to be solved at the CoAP level. This is the main pending issue that we would like to fix before asking for the WGLC (https://mailarchive.ietf.org/arch/msg/core/uoXMI8vcsGoto6fa1GpgftXS-cU/). 

Please review and share your comments.

Cheers,
Jon & Med

> -----Message d'origine-----
> De : core [mailto:[email-masked]] De la part de internet-
> [email-masked]
> Envoyé : jeudi 29 octobre 2020 10:01
> À : [email-masked]
> Cc : [email-masked]
> Objet : [core] I-D Action: draft-ietf-core-new-block-02.txt
> 
> 
>         Title           : Constrained Application Protocol (CoAP)
> Block-Wise Transfer Options for Faster Transmission
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Marco Tiloca <[email-masked]>
Date: Thu, 29 Oct 2020 15:43:52 +0100

Hi Med,

> (6) Clarify what is meant by "repeat request". Marco, please check if the NEW wording is better.  

==>MT
Yes, the new text looks good, as well as having flipped the meaning of
the M bit. Thanks for this update!

Best,
/Marco
<==

> We are waiting for the feedback from the WG whether (9) is worth to be solved at the CoAP level. This is the main pending issue that we would like to fix before asking for the WGLC (https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fcore%2FuoXMI8vcsGoto6fa1GpgftXS-cU%2F&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7Cda58ad6f454847d9eb6308d87bebc107%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637395600621436441%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=nUjooRkYtNoo1QpHPEK0D4kc7%2FLg0fexRtTKkjI55Oc%3D&amp;reserved=0). 
>
>> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-core-new-block%2F&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7Cda58ad6f454847d9eb6308d87bebc107%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637395600621436441%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=Yf5B9lJU%2BBWrBgdJSFhW5%2F9l0V8Odn0iKhW2rU4jMkU%3D&amp;reserved=0
>>
>> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-core-new-block-02&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7Cda58ad6f454847d9eb6308d87bebc107%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637395600621436441%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=g85ezNcVn2V6V0xITw8St63XNgpjnWukJjjAeztWVIw%3D&amp;reserved=0
>> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-core-new-block-02&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7Cda58ad6f454847d9eb6308d87bebc107%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637395600621436441%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=yrDMk6%2FDGoB5nEO8b2DVLXNtZwhRkWcSUinZiK7eJaQ%3D&amp;reserved=0
>>
>> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-core-new-block-02&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7Cda58ad6f454847d9eb6308d87bebc107%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637395600621436441%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=RN5bhbD%2F0pQAOd%2BEhFv5DKocLx4Bsl2t1WypWecSHnc%3D&amp;reserved=0
>>
>>
>> https://eur02.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%2Finternet-drafts%2F&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7Cda58ad6f454847d9eb6308d87bebc107%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637395600621436441%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=2cL6qRL19CseFZzpgCxEDDnlBKRnYQ2pagIplFw7kkU%3D&amp;reserved=0
>>
>>
>> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fcore&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7Cda58ad6f454847d9eb6308d87bebc107%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637395600621436441%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=e4YPV08wXZ7GBH%2BhcSv7PccpxzIuri%2Fe0s34H2qd6g4%3D&amp;reserved=0
> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fcore&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7Cda58ad6f454847d9eb6308d87bebc107%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637395600621436441%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=e4YPV08wXZ7GBH%2BhcSv7PccpxzIuri%2Fe0s34H2qd6g4%3D&amp;reserved=0

-- 
Marco Tiloca
Ph.D., Senior Researcher

RISE Research Institutes of Sweden
Division ICT
Isafjordsgatan 22 / Kistagången 16
SE-164 40 Kista (Sweden)

Phone: +46 (0)70 60 46 501
https://www.ri.se