Subject: Re: [Crypto-panel] Request for review: draft-irtf-cfrg-hpke-04

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Wed, 5 Aug 2020 18:54:56 +0300

Dear Jean-Philippe,

Could you please confirm that you are happy with the changes made in
draft-irtf-cfrg-hpke-05,
addressing your concerns?..

Regards,
Stanislav, Alexey, Nick

On Wed, 17 Jun 2020 at 09:16, Jean-Philippe Aumasson <
[email-masked]> wrote:

> Hi,
>
> I wrote this review a few days ago after Chris and Fred contacted me:
>
> https://gist.github.com/veorq/76196fde31390a8696eac7e062c7b2ea
>
> Cheers,,
>
> JP
>
>
> On Wed, Jun 17, 2020 at 12:57 AM Nick Sullivan <nick=
> [email-masked]> wrote:
>
>> Hi Stephen,
>>
>> This works for us. We look forward to your review.
>>
>> Nick (on behalf of the chairs)
>>
>> On Mon, Jun 8, 2020 at 2:57 PM Stephen Farrell <[email-masked]>
>> wrote:
>>
>>>
>>> I've implemented an earlier version [1] and will be
>>> coding up the final one. Happy to do it, or for that
>>> to be considered disqualifying:-)
>>>
>>> Cheers,
>>> S.
>>>
>>> [1] https://github.com/sftcd/happykey
>>>
>>> On 08/06/2020 22:53, Nick Sullivan wrote:
>>> > Dear Crypto Panel members,
>>> >
>>> > Alexey, Stanislav and I would like to ask Crypto Review Panel members
>>> for a
>>> > review of https://www.ietf.org/id/draft-irtf-cfrg-hpke-04.html. The
>>> > document specifies a set of mechanisms to do hybrid public key
>>> encryption.
>>> > It can be thought of as a generalization of ECIES for any KEM.
>>> >
>>> > This document went through last call and didn't receive many comments,
>>> so a
>>> > thorough review from a crypto panel member would be helpful to move
>>> this
>>> > document forward.
>>> >
>>> > Who would like to volunteer?
>>> >
>>> > Best regards,
>>> > Nick (on behalf of chairs)
>>> >
>>> >
>>> > _______________________________________________
>>> > Crypto-panel mailing list
>>> > [email-masked]
>>> > https://www.irtf.org/mailman/listinfo/crypto-panel
>>> >
>>> _______________________________________________
>>> Crypto-panel mailing list
>>> [email-masked]
>>> https://www.irtf.org/mailman/listinfo/crypto-panel
>>>
>> _______________________________________________
>> Crypto-panel mailing list
>> [email-masked]
>> https://www.irtf.org/mailman/listinfo/crypto-panel
>>
>

---

From: Jean-Philippe Aumasson <[email-masked]>
Date: Wed, 12 Aug 2020 15:42:30 +0200

Hi all,

Apologies for the late reply, been travelling and still on vacation on an
island, didn’t pay much attention to non-urgent looking email and somewhat
overlooked this. Thanks Chris for reminding me by message :)

So I’m fine with the changes, looks like a clear and correct draft. As
commented there are specification choices that I would have done
differently, but nothing worrisome security wise.

Cheers,

JP

On Wed 5 Aug 2020 at 17:54, Stanislav V. Smyshlyaev <[email-masked]>
wrote:

> Dear Jean-Philippe,
>
> Could you please confirm that you are happy with the changes made in draft-irtf-cfrg-hpke-05,
>>> On Mon, Jun 8, 2020 at 2:57 PM Stephen Farrell <
>>> [email-masked]> wrote:
>>>
>>>>
>>>> > This document went through last call and didn't receive many
>>>> comments, so a

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Thu, 13 Aug 2020 09:23:05 +0300

Thanks a lot, Jean-Philippe!

Regards,
Stanislav

On Wed, 12 Aug 2020 at 16:42, Jean-Philippe Aumasson <
[email-masked]> wrote:

>>>>> > Alexey, Stanislav and I would like to ask Crypto Review Panel
>>>>> members for a