Subject: [Crypto-panel] Request for review: "The OPAQUE Asymmetric PAKE Protocol"

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Wed, 11 Aug 2021 17:03:15 +0300

Dear Crypto Panel Experts,

We've obtained a request for review of version -06 of the "The OPAQUE
Asymmetric PAKE Protocol" draft, draft-irtf-cfrg-opaque-06 (
https://datatracker.ietf.org/doc/html/draft-irtf-cfrg-opaque-06).

The chairs would like to ask the Crypto Panel to provide a review of this
document. The Crypto Panel experts reviewed OPAQUE a number of times during
the PAKE Selection Process: during both Round 1, see
https://github.com/cfrg/pake-selection#overall-reviews-by-crypto-review-panel,
and  Round 2, see
https://github.com/cfrg/pake-selection#reviews-by-crypto-review-panel-round-2.
The draft was later adopted by the CFRG based on the results of the
Selection Process.

The authors have provided a document with replies to the questions asked in
previous reviews:
https://docs.google.com/document/d/18B_nXbyjukTB9rR7qEj8-LiNAZDRssDxyhxT0-JzwPc/edit#heading=h.owtmbbgjiae1

Any volunteers?

Stanislav (on behalf of the CFRG Chairs)

---

From: "Scott Fluhrer (sfluhrer)" <[email-masked]>
Date: Wed, 11 Aug 2021 14:35:54 +0000

I’ll take a look at it…

From: Crypto-panel <[email-masked]> On Behalf Of Stanislav V. Smyshlyaev
Sent: Wednesday, August 11, 2021 10:03 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Crypto-panel] Request for review: "The OPAQUE Asymmetric PAKE Protocol"

We've obtained a request for review of version -06 of the "The OPAQUE Asymmetric PAKE Protocol" draft, draft-irtf-cfrg-opaque-06 (https://datatracker.ietf.org/doc/html/draft-irtf-cfrg-opaque-06).

The chairs would like to ask the Crypto Panel to provide a review of this document. The Crypto Panel experts reviewed OPAQUE a number of times during the PAKE Selection Process: during both Round 1, see https://github.com/cfrg/pake-selection#overall-reviews-by-crypto-review-panel, and  Round 2, see https://github.com/cfrg/pake-selection#reviews-by-crypto-review-panel-round-2. The draft was later adopted by the CFRG based on the results of the Selection Process.

The authors have provided a document with replies to the questions asked in previous reviews: https://docs.google.com/document/d/18B_nXbyjukTB9rR7qEj8-LiNAZDRssDxyhxT0-JzwPc/edit#heading=h.owtmbbgjiae1

Any volunteers?

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Thu, 12 Aug 2021 07:21:21 +0300

Thanks a lot, Scott!

Julia Hesse has also agreed to do a review.

Two reviews will be enough.

Regards,
Stanislav

On Wed, 11 Aug 2021 at 17:36, Scott Fluhrer (sfluhrer) <[email-masked]>
wrote:

> I’ll take a look at it…
>
>
>
> *From:* Crypto-panel <[email-masked]> *On Behalf Of *Stanislav
> V. Smyshlyaev
> *Sent:* Wednesday, August 11, 2021 10:03 AM
> *To:* [email-masked]
> *Cc:* [email-masked]; [email-masked]
> *Subject:* [Crypto-panel] Request for review: "The OPAQUE Asymmetric PAKE
> Protocol"
>
>
>
> The authors have provided a document with replies to the questions asked
> in previous reviews: