Subject: Re: [Crypto-panel] EXTERNAL: Fwd: review needed: draft-brown-ec-2y2-x3-x-mod-8-to-91-plus-5-09

From: Thomas Pornin <[email-masked]>
Date: Tue, 12 Apr 2022 22:59:51 +0000

I don't exactly know where this should be sent, but in any case, I read through the draft. I attach my review to this email (as a plain ASCII text file).
Rough summary: I am unimpressed by the curve. The draft should not be published in its current state; it's way too much full of typos, errors, unsafe suggestions, and unstructured ramblings (and voluntarily obfuscated pseudocode!). I don't exactly see the point of this draft becoming an RFC either.

Thomas

From: Independent Submissions Editor (Eliot Lear) <[email-masked]>
Date: Wednesday, March 23, 2022 at 16:03
To: Thomas Pornin <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: EXTERNAL: [Crypto-panel] Fwd: review needed: draft-brown-ec-2y2-x3-x-mod-8-to-91-plus-5-09
You don't often get email from [email-masked]. Learn why this is important<http://aka.ms/LearnAboutSenderIdentification>

Thanks very much Thomas.  Any other takers?  Should this go to the CFRG directly?

Eliot
On 23.03.22 20:42, Thomas Pornin wrote:
I can have a look at this draft over the next couple of weeks.

Thomas

From: Crypto-panel <[email-masked]><mailto:[email-masked]> on behalf of Independent Submissions Editor <[email-masked]><mailto:[email-masked]>
Date: Tuesday, March 22, 2022 at 06:17
To: [email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Subject: EXTERNAL: [Crypto-panel] Fwd: review needed: draft-brown-ec-2y2-x3-x-mod-8-to-91-plus-5-09
You don't often get email from [email-masked]<mailto:[email-masked]>. Learn why this is important<http://aka.ms/LearnAboutSenderIdentification>

-------- Forwarded Message --------
Subject:
review needed: draft-brown-ec-2y2-x3-x-mod-8-to-91-plus-5-09
Date:
Tue, 22 Mar 2022 08:04:00 +0100
From:
Independent Submissions Editor <[email-masked]><mailto:[email-masked]>
To:
[email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

Dear crypto experts,

The ISE requests the review of draft-brown-ec-2y2-x3-x-mod-8-to-91-plus-5-09.  Given its nature it would be good to have more than one crypto expert take a look. Has this been seen by the CFRG?  Would it be reasonable to pass this request there as well?

Best regards,

Eliot (ISE)

---

From: "Independent Submissions Editor (Eliot Lear)" <[email-masked]>
Date: Wed, 13 Apr 2022 07:48:02 +0200

Thomas,

Thank you for taking the time to review the document in so much 
detail.   Also, thanks to Stephen as well for his views.  Thomas, may I 
share your comments (attributed or not, your choice) back to the author?

Regards,

Eliot (ISE)

On 13.04.22 00:59, Thomas Pornin wrote:
>
> I don't exactly know where this should be sent, but in any case, I 
> read through the draft. I attach my review to this email (as a plain 
> ASCII text file).
>
> Rough summary: I am unimpressed by the curve. The draft should not be 
> published in its current state; it's way too much full of typos, 
> errors, unsafe suggestions, and unstructured ramblings (and 
> voluntarily obfuscated pseudocode!). I don't exactly see the point of 
> this draft becoming an RFC either.
>
> Thomas
>
> *From: *Independent Submissions Editor (Eliot Lear) 
> <[email-masked]>
> *Date: *Wednesday, March 23, 2022 at 16:03
> *To: *Thomas Pornin <[email-masked]>, 
> [email-masked] <[email-masked]>
> *Subject: *Re: EXTERNAL: [Crypto-panel] Fwd: review needed: 
> draft-brown-ec-2y2-x3-x-mod-8-to-91-plus-5-09
>
>
> 	
>
> You don't often get email from [email-masked]. Learn why this 
> is important <http://aka.ms/LearnAboutSenderIdentification>
>
> 	
>
>     *From: *Crypto-panel <[email-masked]>
>     <mailto:[email-masked]> on behalf of Independent
>     Submissions Editor <[email-masked]>
>     <mailto:[email-masked]>
>     *Date: *Tuesday, March 22, 2022 at 06:17
>     *To: [email-masked] <[email-masked]>
>     <mailto:[email-masked]>
>     *Subject: *EXTERNAL: [Crypto-panel] Fwd: review needed:
>     draft-brown-ec-2y2-x3-x-mod-8-to-91-plus-5-09
>
>
>     	
>
>     You don't often get email from [email-masked]. Learn why
>     this is important <http://aka.ms/LearnAboutSenderIdentification>
>
>     	
>
>
>
>     *Subject: *
>     *Date: *
>     *From: *
>     *To: *
>     [email-masked], [email-masked]
>
>
>
>     Dear crypto experts,
>
>     The ISE requests the review of
>     draft-brown-ec-2y2-x3-x-mod-8-to-91-plus-5-09.  Given its nature
>     it would be good to have more than one crypto expert take a look.
>     Has this been seen by the CFRG?  Would it be reasonable to pass
>     this request there as well?
>
>     Best regards,
>
>     Eliot (ISE)
>
>

---

From: Thomas Pornin <[email-masked]>
Date: Wed, 13 Apr 2022 07:05:32 +0000

Yes, no problem, everything here was written under the assumption that it was public (or close enough).

Thomas

From: Independent Submissions Editor (Eliot Lear) <[email-masked]>
Date: Wednesday, April 13, 2022 at 01:48
To: Thomas Pornin <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: EXTERNAL: [Crypto-panel] Fwd: review needed: draft-brown-ec-2y2-x3-x-mod-8-to-91-plus-5-09

Thomas,

Thank you for taking the time to review the document in so much detail.   Also, thanks to Stephen as well for his views.  Thomas, may I share your comments (attributed or not, your choice) back to the author?

Regards,

Eliot (ISE)

Thomas

From: Independent Submissions Editor (Eliot Lear) <[email-masked]><mailto:[email-masked]>
Date: Wednesday, March 23, 2022 at 16:03
To: Thomas Pornin <[email-masked]><mailto:[email-masked]>, [email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Subject: Re: EXTERNAL: [Crypto-panel] Fwd: review needed: draft-brown-ec-2y2-x3-x-mod-8-to-91-plus-5-09
You don't often get email from [email-masked]<mailto:[email-masked]>. Learn why this is important<http://aka.ms/LearnAboutSenderIdentification>

Eliot

Thomas

-------- Forwarded Message --------
Subject:
review needed: draft-brown-ec-2y2-x3-x-mod-8-to-91-plus-5-09
Date:

Dear crypto experts,

Best regards,

Eliot (ISE)