Subject: [Dbound] commands to get TLD list (was: multiple PSL-equivalents exist..

From: =JeffH <[email-masked]>
Date: Mon, 17 Nov 2014 11:02:14 -0800

Casey supplied..

 > awk '$4 == "NS" { print $1 }' root.zone | sed 's/\.$//' | sort -u > tlds.txt

cool, thx. tho one needs to do this first to get the root.zone file..

wget http://www.internic.net/domain/root.zone
awk '$4 == "NS" { print $1 }' root.zone | sed 's/\.$//' | sort -u > tlds.txt

[see also: https://www.iana.org/domains/root/files ]

results:

 > head -20 tlds.txt

abogado
ac
academy
accountants
active
actor
ad
ae
aero
af
ag
agency
ai
airforce
al
allfinanz
alsace
am
an
...

---

From: Tim Wicinski <[email-masked]>
Date: Mon, 17 Nov 2014 11:47:36 -0800

Or for us very lazy one-liner types:

curl -s http://www.internic.net/domain/root.zone  | awk '$4 == "NS" { 
print $1 }' | sed 's/\.$//' | sort -u

On 11/17/14 11:02 AM, =JeffH wrote:
> _______________________________________________
> Dbound mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dbound

---

From: Gavin Brown <[email-masked]>
Date: Tue, 18 Nov 2014 09:04:11 +0000

IANA publishes a flat list of TLDs:

https://data.iana.org/TLD/tlds-alpha-by-domain.txt

-- 
Gavin Brown
Chief Technology Officer
CentralNic Group plc (LSE:CNIC)
Innovative, Reliable and Flexible Registry Services
for ccTLD, gTLD and private domain name registries
https://www.centralnic.com/

CentralNic Group plc is a company registered in England and Wales with
company number 8576358. Registered Offices: 35-39 Moorgate, London,
EC2R 6AR.

---

From: Warren Kumari <[email-masked]>
Date: Tue, 18 Nov 2014 06:33:32 -1000

> https://data.iana.org/TLD/tlds-alpha-by-domain.txt

My God -- it's full of sta^wnames...

W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf