Subject: Re: [Dcrouting] DC Routing requirements draft

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Tue, 23 Jan 2018 23:58:11 +0000

Comments on draft-dt-rtgwg-dcrouting-requirements

I'd like to expand on the ZTP requirement.
It is ok to pre-configure devices with items such as a unique identifier, capabilities, port types and so on.
It is not ok to require any of the configured items to depend upon the location of the device in the topology.
In other words, it should be possible to remove a device from any part of the network and put it into another part of the network without any manual configuration. The auto-configuration protocol should recognize the move and reconfigure a moved device.

It should be possible to have multiple networks that are individually auto-configured to be connected to each other in such a way that the auto-configuration of one network does not interfere with the auto-configuration of an adjoining network.

The DC routing protocol should be able to auto-configure and route multiple CLOS networks that are interconnected with a loose data-center-interconnect (DCI) network. The auto-configuration protocol should be able to discover and configure all the datacenters in a DCI as a single network.

The auto-configuration protocol should not require a dedicated (out-of-band) network.

Each device should not be required to know the topology outside of its immediate neighbors. It should be sufficient for a device to know about distant devices in the aggregate. Specific knowledge of certain distant devices should be for special cases only. For example, a network controller is expected to know precise topology information about its domain of control. In particular, each device must not store a complete link state database of the whole network or IP addresses of every leaf in the datacenter.

Thanks,
Jakob

---

From: Tony Przygienda <[email-masked]>
Date: Tue, 23 Jan 2018 16:11:51 -0800

Largely agreed. One observation only.

Trying to extend a single ZTP over a very large area like DCI IMO is a
perilous idea due to the lack of separation of the fabrics (i.e. if that
implies that one device flap could shake another DC fabric that way) ...
DCI ZTP is probably a different problem than DC fabric ZTP due to the fact
that fabrics internally are ideally run on private addressing or even no
addressing at all (or only local addressing if must be). DCI is more of a
public address problem IMO but one could argue against that as well if the
DCIs extend over LSPs or some kind of overlay ...

thanks

--- tony

On Tue, Jan 23, 2018 at 3:58 PM, Jakob Heitz (jheitz) <[email-masked]>
wrote:

> In other words, it should be possible to remove a device from any part of
> the network and put it into another part of the network without any manual
> configuration. The auto-configuration protocol should recognize the move
> and reconfigure a moved device.
>
>
>
> It should be possible to have multiple networks that are individually
> auto-configured to be connected to each other in such a way that the
> auto-configuration of one network does not interfere with the
> auto-configuration of an adjoining network.
>
>
>
> The DC routing protocol should be able to auto-configure and route
> multiple CLOS networks that are interconnected with a loose
> data-center-interconnect (DCI) network. The auto-configuration protocol
> should be able to discover and configure all the datacenters in a DCI as a
> single network.
>
>
>
> Each device should not be required to know the topology outside of its
> immediate neighbors. It should be sufficient for a device to know about
> distant devices in the aggregate. Specific knowledge of certain distant
> devices should be for special cases only. For example, a network controller
> is expected to know precise topology information about its domain of
> control. In particular, each device must not store a complete link state
> database of the whole network or IP addresses of every leaf in the
> datacenter.
>
>
>
> Thanks,
>
> Jakob
>
>
>
> _______________________________________________
> Dcrouting mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dcrouting
>
>

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Wed, 24 Jan 2018 00:19:24 +0000

The likelihood of a perturbation in one part of the network shaking something distant is one reason I added that a device should only know about distant devices in the aggregate. You could make it more explicit: The blast radius of a failure should be small. It's a bit difficult to specify exactly how small.

Thanks,
Jakob

From: Tony Przygienda [mailto:[email-masked]]
Sent: Tuesday, January 23, 2018 4:12 PM
To: Jakob Heitz (jheitz) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Dcrouting] DC Routing requirements draft

Trying to extend a single ZTP over a very large area like DCI IMO is a perilous idea due to the lack of separation of the fabrics (i.e. if that implies that one device flap could shake another DC fabric that way) ... DCI ZTP is probably a different problem than DC fabric ZTP due to the fact that fabrics internally are ideally run on private addressing or even no addressing at all (or only local addressing if must be). DCI is more of a public address problem IMO but one could argue against that as well if the DCIs extend over LSPs or some kind of overlay ...
thanks
--- tony

On Tue, Jan 23, 2018 at 3:58 PM, Jakob Heitz (jheitz) <[email-masked]<mailto:[email-masked]>> wrote:
Comments on draft-dt-rtgwg-dcrouting-requirements

Thanks,
Jakob

_______________________________________________
Dcrouting mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dcrouting