Subject: Re: [Dcrouting] New Version Notification for draft-li-dynamic-flooding-01.txt

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Tue, 23 Jan 2018 21:54:02 +0000

This looks to me like a good idea.
It does not require a separate management network.
A small flooding topology would be a spanning tree.
This would assume that upon a link failure, both ends of a p2p link detect the failure and send an LSA within an acceptable time.
If not, then I would add a second link to any nodes that have only one link in the spanning tree.

Thanks,
Jakob

> Name:           draft-li-dynamic-flooding
> Revision: 01
> Title:          An Architecture for Dynamic Flooding on Dense Graphs
> Document date:  2018-01-14
> Group:          Individual Submission
> Pages:          8
> URL:            https://www.ietf.org/internet-drafts/draft-li-dynamic-flooding-01.txt
> Status:         https://datatracker.ietf.org/doc/draft-li-dynamic-flooding/
> Htmlized:       https://tools.ietf.org/html/draft-li-dynamic-flooding-01
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-li-dynamic-flooding-01
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-li-dynamic-flooding-01
>
> Abstract:
>   Routing with link state protocols in dense network topologies can
>   result in sub-optimal convergence times due to the overhead
>   associated with flooding.  This can be addressed by decreasing the
>   flooding topology so that it is less dense.
>
>   This document discusses the problem in some depth and an
>   architectural solution.  Specific protocol changes are not described
>   in this document.

---

From: Tony Li <[email-masked]>
Date: Tue, 23 Jan 2018 14:09:12 -0800

Hi Jakob,

Thank you for the kind words!

> This would assume that upon a link failure, both ends of a p2p link detect the failure and send an LSA within an acceptable time.

Which is possible, but it also implies that systems on the other side of the failure would only see one side of the failure immediately and the other side might take some time to propagate. While SPF might still calculate good results, I would definitely prefer to see a fully consistent database sooner rather than later. Also, if there is a second failure on the far side of the first failure, that might be invisible for some time.

> If not, then I would add a second link to any nodes that have only one link in the spanning tree.

And this is why I suggested a cyclic topology with minimal diameter and minimal node degree.

Tony