Subject: [Dime] Invalid AVP within a Grouped AVP

From: Anders Kristensen <[email-masked]>
Date: Fri, 24 Feb 2006 16:20:49 -0500

Suppose an AVP nested within a Grouped AVP is illegal. Should the server 
return the "most specific" illegal child AVP or the "top level" Grouped 
AVP containing the offending AVP?

Same question for a Grouped AVP with a missing mandatory child AVP.

Thanks,
Anders

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: David Connelly <[email-masked]>
Date: Fri, 24 Feb 2006 22:15:36 -0800

I think the top level AVP is better since it is really the AVP whose  
value is incorrect. It is also less ambiguous in some situations. For  
example, if a CER message contained a Vendor-Specific-Application-Id  
with a bad Vendor-Id AVP, and we were to return that Vendor-Id AVP as  
invalid, then how would a peer know if the Failed-AVP refers to the  
embedded Vendor-Id or the top-level Vendor-Id AVP for the CER itself?

- David

On Feb 24, 2006, at 1:20 PM, Anders Kristensen wrote:

> Suppose an AVP nested within a Grouped AVP is illegal. Should the  
> server return the "most specific" illegal child AVP or the "top  
> level" Grouped AVP containing the offending AVP?
>

---

From: David Connelly <[email-masked]>
Date: Fri, 24 Feb 2006 22:17:53 -0800

---

From: <[email-masked]>
Date: Sat, 25 Feb 2006 09:45:21 +0200

I agree with David on this.  The top-level AVP would be the best to
return the
with the error.

John 

>-----Original Message-----
>From: ext David Connelly [mailto:[email-masked]] 
>Sent: 25 February, 2006 08:16
>To: Anders Kristensen
>Cc: [email-masked]
>Subject: Re: [Dime] Invalid AVP within a Grouped AVP
>
>I think the top level AVP is better since it is really the AVP 
>whose value is incorrect. It is also less ambiguous in some 
>situations. For example, if a CER message contained a 
>Vendor-Specific-Application-Id with a bad Vendor-Id AVP, and 
>we were to return that Vendor-Id AVP as invalid, then how 
>would a peer know if the Failed-AVP refers to the embedded 
>Vendor-Id or the top-level Vendor-Id AVP for the CER itself?
>
>- David
>
>> server return the "most specific" illegal child AVP or the 
>"top level" 
>> Grouped AVP containing the offending AVP?
>>

---

From: Anders Kristensen <[email-masked]>
Date: Sat, 25 Feb 2006 09:44:31 -0500

OK, makes sense. Probably should be made explicit in the next version of 
the spec.

Thanks,
Anders