Subject: [Dime] feature tag AVP

From: "German Blanco \(E2/EEM\)" <[email-masked]>
Date: Fri, 3 Mar 2006 11:45:50 +0100

Hello,

as far as I know, there is no AVP defined to transport
the feature tags specified in RFC 2533, or?

Wouldn't it make sense to have an AVP code reserved 
for that?

Regards,

German.

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Fri, 3 Mar 2006 08:04:08 -0800

German Blanco (E2/EEM) <mailto:[email-masked]> supposedly scribbled:

> Hello,
> 
> as far as I know, there is no AVP defined to transport the feature
> tags specified in RFC 2533, or? 
> 
> Wouldn't it make sense to have an AVP code reserved for that?

Why?

~gwz

Why is it that most of the world's problems can't be solved by simply
  listening to John Coltrane? -- Henry Gabriel

---

From: "German Blanco \(E2/EEM\)" <[email-masked]>
Date: Wed, 8 Mar 2006 14:35:11 +0100

Hi Victor,

No, that was not my idea.
But I think the AVP could be useful for many cases.
Since there is no Diameter application that needs this in the
list of mandatory AVPs, how about a short document describing
how it could be used and with the allocation of the code?

If that makes sense, I could start writing a draft.  It may
take some time for me, but I don't think there is a hurry.

/German.

> -----Original Message-----
> From: Victor Fajardo [mailto:[email-masked]] 
> Sent: miércoles, 08 de marzo de 2006 14:23
> To: German Blanco (E2/EEM)
> Cc: Glen Zorn (gwz); [email-masked]
> Subject: Re: [Dime] feature tag AVP
> 
> Hi German,
> 
> >If I understand it correctly, these feature tags are used to 
> identify 
> >the content and format of the communication.  They are 
> intended for the 
> >negotiation of the characteristics of the communication.  If it were 
> >possible to have restrictions on the kind of communication that a 
> >certain user is authorized to establish, then it would make 
> sense to me 
> >to perform the authorization to establish this communication with 
> >Diameter and to transport these feature tags in a Diameter AVP.
> >
> >Should I continue?  Or is there already a wrong assumption in that?
> >  
> >
> Are you proposing that a feature tag avp definition should be 
> present the base proto ? I think it has no use in there.
> 
> victor
> 
> >/German.
> >
> >  
> >
> >>-----Original Message-----
> >>From: Glen Zorn (gwz) [mailto:[email-masked]]
> >>Sent: viernes, 03 de marzo de 2006 17:04
> >>To: German Blanco (E2/EEM)
> >>Cc: [email-masked]
> >>Subject: RE: [Dime] feature tag AVP
> >>