Subject: RE: [Dime] RE: RADIUS to Diameter gateways & extended attributes

From: <[email-masked]>
Date: Fri, 24 Mar 2006 15:00:09 +0100

Hi,

The 3GPP I-WLAN spec 29.234 is the only place in 3GPP scope
that I remember that has D->R and R->D cases (on Wa and Wd
interfaces). Currently the spec only says that the D->R and
R->D cases are done according to the NASREQ and the Diam-EAP.

In 3GPP I-WLAN point of view there are couple open issues
under this topic:
 o how to provide Diameter's NAS-Filter-Rule also on RADIUS
   (current reference is to now splitted radext-ieee802 draft)
 o how to provide Diameter's request redirecting on RADIUS side
   (redirect-host etc + the functionality)

Cheers,
	Jouni

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: 24. maaliskuuta 2006 3:09
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: [Dime] RE: RADIUS to Diameter gateways & extended attributes 
> 
> Hi all,
> 
> >David Mitton <[email-masked]> wrote:
> >> I'd like to hear from people that actually have such things, as we 
> >> didn't get very many responses in the Dime meeting room.  
> I'll chase 
> >> that in a different thread.
> >
> >  Knowing current D->R gateway practices would help, thanks.
> 
> Could some people on the DiME mailing list point out anything?  I know
> that 3GPP has some plans for such things.  Maybe someone could explain
> what is happening in 3GPP or other SD0s?
> 
> John
> 
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dime
> 

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Bernard Aboba" <[email-masked]>
Date: Fri, 24 Mar 2006 06:19:57 -0800

>    (current reference is to now splitted radext-ieee802 draft)

As we discussed in the RADEXT WG meeting, it seems to make sense to define a 
NAS-Filter-Rule attribute in RADIUS, in addition to the Filter-ID and 
NAS-Traffic-Rule attributes.  However, only one of these attributes can be 
included in a single packet.

>    (redirect-host etc + the functionality)

I was unaware of this request.  I think that satisfying it will be difficult 
since RADIUS (unlike Diameter) requires pre-set credentials and does not 
support DNS-based location of servers.   Therefore redirection support alone 
will not make this work; it is necessary to enhance the RADIUS protocol 
substantially.