Subject: [Dime] CEA and the error bit

From: Andreas Fredriksson <[email-masked]>
Date: Tue, 21 Mar 2006 16:29:26 +0100

Hi list,

I think the status of CER/CEA and the use of the error bit is unclear in 
the Base RFC.

What rules apply when a CER message cannot be decoded on the receiving 
end? Is sending a CEA with the error bit set a valid option, or should a 
proper CEA be produced with the ResultCode AVP set to some specific value?

I've had this happen when interacting with various systems and currently 
we're unclear on how to handle the situation.

Best regards,
Andreas

-- 
Andreas Fredriksson
Software Engineer, Digital Route

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 21 Mar 2006 10:37:33 -0500

Wouldn't following the generic error generating rules be sufficient, i.e.
E-bit set for protocol errors, and adding Result-Code AVP and Failed-AVP AVP
as applicable ?

> -----Original Message-----
> From: Andreas Fredriksson [mailto:[email-masked]]
> Sent: Tuesday, March 21, 2006 10:29 AM
> To: [email-masked]
> Subject: [Dime] CEA and the error bit
>
>
>
> Hi list,
>

---

From: Andreas Fredriksson <[email-masked]>
Date: Wed, 22 Mar 2006 09:20:24 +0100

> E-bit set for protocol errors, and adding Result-Code AVP and Failed-AVP AVP

Tolga,
this makes perfect sense, and I believe this is what we do. I can 
imagine that some state machine implementations could be confused to see 
  a CEA with the error bit set (I've seen strange behavior a few times), 
but in general it makes sense.

Thanks,
Andreas