Subject: RE: [Dime] WGLC on ACTION:draft-ietf-dime-diameter-api-00.txt

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Fri, 10 Mar 2006 08:31:52 -0800

[email-masked] <mailto:[email-masked]> supposedly scribbled:

> I don't think that meta-discussions are useful.  

Actually, I think that they are extremely useful in establishing the direction of the WG.

> Review the document,
> raise conserns - if there are things that are in the document are not
> good, then state that. If there isn't enough WG consensus to approve
> the document, then the document doesn't get approved.  

No offense, but you seem to have missed a rather crucial step here: if there isn't WG consensus to go to last call (which there doesn't appear to be), there is no last call.
 
> 
> The IETF has worked on APIs before, see:
> http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-sctpsocket-12.txt
> IPv6 Advanced IPv6 API http://www.ietf.org/rfc/rfc3542.txt
> 
> and a good search will find:
> https://datatracker.ietf.org/public/idindex.cgi?command=do_search_id&fil
> ename=api&id_tracker_state_id=-1&wg_id=0&other_group=&status_id=0&last_n
> ame=&first_name=

Be that as it may, it doesn't mean that _this_ WG must (or even should) work on APIs.  I agree that this LC is premature, given the rather checkered past of the document in question & the fact that the WG is not even properly constituted as yet.

> 
> John
> 
>> -----Original Message-----
>> From: ext Tolga Asveren [mailto:[email-masked]]
>> Sent: 09 March, 2006 17:53
>> To: [email-masked]
>> Subject: RE: [Dime] WGLC on
>> ACTION:draft-ietf-dime-diameter-api-00.txt 
>> 
>> Hi John,
>> 
>> What is the goal of this document?
>> 
>> The draft says:
>> "The intent of the API is to foster source code portability across
>> multiple programming platforms."
>> 
>> Is this really something done often by IETF?
>> 
>> Protocols being procedures between two peers need to be standardized,
>> but APIs are a local contract between a protocol layer and an
>> application of that protocol. For that reason they won't cause
>> interoperability problems and people won't be forced to comply with
>> them. Although initially this seems like good news because there is
>> no need to comply with them, this also is the reason, why they are
>> not very useful -there are of course exceptions like the socket
>> API-. BTW, any API also implies certain implementation decisions,
>> aren't we intervening too much to implementation dependent details
>> by defining an API as a WG-document? 
>> 
>> I think, any API document for Diameter is better to be a non-WG
>> document. In this way, people which are interested can submit the
>> "best" API according to them and we won't have one "officially
>> endorsed by IETF" version of API. 
>> 
>>   Thnaks,
>>   Tolga
>> 
>> 
>> 
>>> -----Original Message-----
>>> From: [email-masked] [mailto:[email-masked]]
>>> Sent: Thursday, March 09, 2006 10:50 AM
>>> To: [email-masked]; [email-masked]
>>> Cc: [email-masked]
>>> Subject: RE: [Dime] WGLC on
>> ACTION:draft-ietf-dime-diameter-api-00.txt
>>> 
>>> 
>>> Just as a note - if the document isn't ready, then make comments,
>>> the document will be revised and we can then see if the document
>>> needs another WGLC, etc. 
>>> 
>>> The focus should be getting the document finalized, if it takes more
>>> than one round, or additional revisions, then that's fine.
>>> 
>>> John
>>> 
>>>> -----Original Message-----
>>>> From: ext Julien Bournelle [mailto:[email-masked]]
>>>> Sent: 09 March, 2006 17:44 To: David Lehmann
>>>> Cc: [email-masked]
>>>> Subject: Re: [Dime] WGLC on
>>>> ACTION:draft-ietf-dime-diameter-api-00.txt
>>>> 
>>>> Hi David,
>>>> 
>>>> On Thu, Mar 09, 2006 at 09:27:18AM -0500, David Lehmann wrote:
>>>>> David Frascone wrote:
>>>>>> 
>>>>>> The API was used in sun's reference implementation. Opendiameter
>>>>>> moved away from it, since they're in c++.
>>>>> I question whether this is Sun's API.  If someone from Sun can
>>>>> confirm or deny, please do. 
>>>>> 
>>>>>> 
>>>>>> I think there is one other implementation.  The author has
>>>>>> promised to review and post ocmments to this list. Please name
>>>>>> it. 
>>>> 
>>>> I guess that's me but I'm not the author of the implementatiion.
>>>> I'm using a Diameter Base Protocol which is based on this API on
>>>> top of which I implement an application. I already posted some
>>>> comments on it (Diameter API) both on AAA and DIME ML. I
>>>> "promised" to compile all these comments. 
>>>> 
>>>>> As it stands right now, there is no known implementation which
>>>>> uses this API. As Anders stated, this is a bit dubious.
>>>>> 
>>>>> Back in October 2005, I tried to raise a discussion on the AAA
>>>>> group about the API, but the authors were unresponsive. That being
>>>>> the case, we could not follow it because of its shortcomings and
>>>>> a general lack of maturity. In addition, there seemed to be no
>>>>> effort to make it mature. So now, a new draft suddenly appears
>>>>> and we immediately go to last call? IMHO, there should be much
>>>>> more discussion and there should be a couple of independent
>>>>> implementations.  Without real implementations, there will be no
>>>>> meaningful discussions and the API will have serious
>>>>> shortcomings.  A simple review of the draft will not cut it.
>>>>> IMHO, we are a least a year away from a last call. 
>>>> 
>>>> I agree that maybe this WG LC is a little bit premature.
>>>> 
>>>> Julien Bournelle
>>>> 
>>>> 
>>>>> 
>>>>> --
>>>>> 
>>>>> David Lehmann
>>>>> Ulticom, Inc.
>>>>> http://www.ulticom.com
>>>>> 
>>>>> 
>>>>> _______________________________________________
>>>>> DiME mailing list
>>>>> [email-masked]
>>>>> https://www1.ietf.org/mailman/listinfo/dime
>>>> 
>>>> --
>>>> julien.bournelle at int-evry.fr
>>>> 
>>>> _______________________________________________
>>>> DiME mailing list
>>>> [email-masked]
>>>> https://www1.ietf.org/mailman/listinfo/dime
>>>> 
>>> 
>>> _______________________________________________
>>> DiME mailing list
>>> [email-masked]
>>> https://www1.ietf.org/mailman/listinfo/dime
>>> 
>> 
>> 
>> 
>> _______________________________________________
>> DiME mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/dime
>> 
> 
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dime

Hope this helps,

~gwz

Why is it that most of the world's problems can't be solved by simply
  listening to John Coltrane? -- Henry Gabriel

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: <[email-masked]>
Date: Sat, 11 Mar 2006 08:18:22 +0200

Glenn,

I think you are confused about this list - the Internet Debating Society
is down the 
hall.  

No, seriously, the status is the following:

The Diameter API draft was a WG draft from the AAA working group,
and it was suggested as a charter item of DiME.  There was plenty of
time to
comment on the charter, if people thought the charter was good or bad,
if items
should be added or removed.

I asked the authors of the document if they had resolved the open issues
on
the draft, which they said yes.  In order to ensure the WG is happy with
the
document, I have started a WGLC.  Based upon technical feedback from the
WG,
we can see what the next steps are.

We could endlessly cycle on debating non-technical issues, and get no
closer
to completing this work.  I would like for people to read the draft and
comment
on if it is finished, if it needs fixes or a rethink.

thanks,
John
>From: ext Glen Zorn (gwz) [mailto:[email-masked]] 
>Sent: 10 March, 2006 18:32
>To: Loughney John (Nokia-NRC/Helsinki)
>Cc: [email-masked]; [email-masked]
>Subject: RE: [Dime] WGLC on ACTION:draft-ietf-dime-diameter-api-00.txt
>
>No offense, but you seem to have missed a rather crucial step 
>here: if there isn't WG consensus to go to last call (which 
>there doesn't appear to be), there is no last call.
> 
>> 
>Be that as it may, it doesn't mean that _this_ WG must (or 
>even should) work on APIs.  I agree that this LC is premature, 
>given the rather checkered past of the document in question & 
>the fact that the WG is not even properly constituted as yet.
>
>> 
>> John
>> 
>>> not very useful -there are of course exceptions like the 
>socket API-. 
>>> BTW, any API also implies certain implementation decisions, 
>aren't we 
>>> intervening too much to implementation dependent details by 
>defining 
>>> an API as a WG-document?
>>> 
>>>>>> the case, we could not follow it because of its 
>shortcomings and a 
>>>>>> general lack of maturity. In addition, there seemed to be no 
>>>>>> effort to make it mature. So now, a new draft suddenly 
>appears and 
>>>>>> we immediately go to last call? IMHO, there should be much more 
>>>>>> discussion and there should be a couple of independent 
>shortcomings.  
>>>>>> A simple review of the draft will not cut it.