Subject: RE: [Dime] Policy based Applications and QoS Application

From: "Alan McNamee" <[email-masked]>
Date: Sat, 13 May 2006 21:54:54 +0100

Hi Marco,
 
Thanks for the slide I found it an excellent representation.
 
In regards to Avi's questions:
 
Question 1. I believe there is a need to create QoS application in
Diameter. The 3GPP R7 spec for the PCRF although stating that it will
define a unified Policy and Charging Rules node using Diameter
interfaces it has yet to define any significant level detail on the QoS
portion of the Gx or Rx interfaces. The Gx interface is an adaptation of
the CCA, the Rx interface is an adaptation of a NASreq subset. Using CCA
in this manner is questionable to me i.e. using CCA for a rules
distribution application as opposed to a true credit control application
like the OCS (accessed via Ro, Gy, Wy etc.).
 
Question 2. I would suggest that this work is done within IETF and seek
for 3GPP et al to adopt it. This worked well for the CCA.
 
Question 3. I think that this would be a good starting point.
 
Regards,
Alan.

________________________________

From: Marchisio Marco Enzo [mailto:[email-masked]] 
Sent: 12 May 2006 10:30
To: [email-masked]
Cc: [email-masked]; Tschofenig, Hannes
Subject: R: [Dime] Policy based Applications and QoS Application

Hi All

I send you a slide that summarizes and schematizes the 3GPP QoS
evolution.

Regarding the question 2: 

2) Should we work on a Diameter Flow-based Policy Application that is
able to deliver QoS/Charging and in the future other flow based
application?

-Should this work be done in the IETF? Do we get folks in 3GPP/3GPP2 and
WiMAX to agree to work on this within the IETF.  Or perhaps we can agree
to work on this together outside the IETF?

3GPP Release 6 Introduces Flow Based Charging (FBC) and in Release 7 FBC
and QoS are merged together with Diameter interface

In Release 5, the QoS was COPS protocol based on

Marco

________________________________

Da: Avi Lior [mailto:[email-masked]] 
Inviato: Thursday, May 11, 2006 6:25 PM
A: [email-masked]
Cc: [email-masked]; Tschofenig, Hannes
Oggetto: [Dime] Policy based Applications and QoS Application

Hi All,

This email prompts me to start a discussion on Policy and QoS
Application.

As some of you are aware IMS Rel 7.0 has an entity called PCRF.  This
PCRF is supposed to broker per flow based policy actions between the IMS
infrastructure and the Network.  Initially this policy was QoS and in
release 7.0 it also brokers Charging Policy.  In the future it will
probably broker other per flow policy.  For example, it may instruct the
network to apply security policies to a flow or group of flows.

The QoS Application that is being developed by the IETF (IMO) was
targeting the Policy entity in its IMS Rel 6.0 form when it was called
the PDF instead of PCRF and when it was only serving QoS policies.  Now
in rel 7.0 the Diameter application being developed is serving both QoS
and Charging information and is based on the Diameter Credit Control
function.  

Also QoS policies are also delivered as part of Authentication.  So EAP
Application may be used to deliver initial QoS policies to the User
session being authenticated and authorized.

So I am raising the following questions:

1) Is there any reason to create a QoS Application in Diameter?

2) Should we work on a Diameter Flow-based Policy Application that is
able to deliver QoS/Charging and in the future other flow based
application?

-Should this work be done in the IETF? Do we get folks in 3GPP/3GPP2 and
WiMAX to agree to work on this within the IETF.  Or perhaps we can agree
to work on this together outside the IETF?

3) Perhaps we should just define QoS based attributes that can be pulled
into various future Diameter Applications.

Comments are welcome!!!

	
________________________________

	From: Tschofenig, Hannes [mailto:[email-masked]] 
	Sent: Monday, May 08, 2006 4:23 AM
	To: [email-masked]; [email-masked]
	Cc: [email-masked]
	Subject: AW: [Dime] FW: [AAA-WG]: Policy representation for AAA
server

	Hi Salekul, 

	could you formulate your question in more detail? 

	What type of policies are you talking about? E.g., policies that
represent the business logic at a AAA server or policies that are
conveyed from the AAA server to the AAA client? Are you looking for a
language to express these policies or rather for the content of these
policies? Do you have a specific application in mind (e.g., policies
regarding charging, QoS, location information)

	Ciao

	Hannes

________________________________

		Von: [email-masked]
[mailto:[email-masked]] 
		Gesendet: Montag, 8. Mai 2006 10:10
		An: [email-masked]
		Cc: [email-masked]
		Betreff: [Dime] FW: [AAA-WG]: Policy representation for
AAA server

		Forward to the DiME WG, in case any one has opinions for
Diameter.

		John

________________________________

			From: [email-masked]
[mailto:[email-masked]] On Behalf Of ext Salekul Islam
			Sent: 30 April, 2006 08:55
			To: [email-masked]
			Cc: Salekul Islam
			Subject: [AAA-WG]: Policy representation for AAA
server

			Hi,

			I am interested in policy representation or
policy server in Diameter architecture. Is there any Internet Draft or
paper addressing the issues related to policy representation for AAA
server? Is there any specific direction or goal of the WG regarding this
issue?

			Any sort of information will be very helpful for
me.

			regards,

			Salekul Islam

			PhD candidate, Concordia University

			Montreal, Canada

--------------------------------------------------------------------
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please contact us by
replying to [email-masked]
<mailto:[email-masked]> .
        Thank you
                                        www.telecomitalia.it
<http://www.telecomitalia.it> 
--------------------------------------------------------------------
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Alan McNamee" <[email-masked]>
Date: Sun, 14 May 2006 01:10:40 +0100

Resend. Didn't get through first time.

From: Alan McNamee 
Sent: 13 May 2006 21:55
To: 'Marchisio Marco Enzo'; [email-masked]
Cc: [email-masked]; Tschofenig, Hannes
Subject: RE: [Dime] Policy based Applications and QoS Application

Hi Marco,

 

 
Regards,
Alan.

Hi All

Marco

Hi All,

 

Comments are welcome!!!

	

	Hi Salekul, 

	Ciao

	Hannes

		John

			Hi,

			regards,

			Salekul Islam

			Montreal, Canada

---

From: "Avi Lior" <[email-masked]>
Date: Tue, 30 May 2006 09:54:51 -0400

Hi Hannes,

The discussion on MIPv6 bootstrapping is different.  We know that it is
an Application we were just debating whether or not we need to create a
new Application ID.

QoS may be an application and it may also be an attribute that is used
by various applications.

While it may be difficult for the IETF to come up with a QoS application
that would work across many SDOs, it may be good enough for DIME to
define a standerdized QoS blob and have SDOs pick it up as they work on
SDO specific applications.

For vendors like us, providing products across SDOs, having a
standerdized QoS blob is adventageous.  QoS Blob is relatively complex,
and requires a complex GUI for provisioning it and also complex API.

Avi

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]] 
> Sent: Monday, May 29, 2006 4:52 PM
> To: Avi Lior
> Cc: [email-masked]; [email-masked]; Tschofenig, Hannes
> Subject: Re: [Dime] Policy based Applications and QoS Application
> 
> Hi Avi,
> 
> thanks for raising this topic. Please find my response below;
> 
> Avi Lior wrote:
> > Hi All,
> >  
> > This email prompts me to start a discussion on Policy and 
> QoS Application.
> >  
> > PCRF is supposed to broker per flow based policy actions 
> between the 
> > IMS infrastructure and the Network.  Initially this policy 
> was QoS and 
> > in release 7.0 it also brokers Charging Policy.  In the 
> future it will 
> > probably broker other per flow policy.  For example, it may 
> instruct 
> > the network to apply security policies to a flow or group of flows.
> >  
> > the PDF instead of PCRF and when it was only serving QoS policies.  
> > Now in rel 7.0 the Diameter application being developed is serving 
> > both QoS and Charging information and is based on the 
> Diameter Credit 
> > Control function.
> >  
> > Also QoS policies are also delivered as part of Authentication.  So 
> > EAP Application may be used to deliver initial QoS policies to the 
> > User session being authenticated and authorized.
> 
> I agree with you.
> 
> >  
> I guess your question is 'Does it need to be an application' 
> and thereby referring to question 3. In some sense we also 
> discussed this question in context of MIPv6 Bootstrapping as well.
> 
> Are you concerned about the additional messaging or more 
> about the degree of flexbility.
> 
> >  
> > able to deliver QoS/Charging and in the future other flow 
> based application?
> > -Should this work be done in the IETF? Do we get folks in 
> 3GPP/3GPP2 
> > and WiMAX to agree to work on this within the IETF.  Or 
> perhaps we can 
> > agree to work on this together outside the IETF?
>  >
> > 3) Perhaps we should just define QoS based attributes that can be 
> > pulled into various future Diameter Applications.
> 
> The last two approaches sound like interesting approaches we 
> should investigate.
> 
> 
> Ciao
> Hannes
> 
> >  
> >  
> > Comments are welcome!!!
> >  
> >  
> > 
> >     
> --------------------------------------------------------------
> ----------
> >     *From:* Tschofenig, Hannes 
> [mailto:[email-masked]]
> >     *Sent:* Monday, May 08, 2006 4:23 AM
> >     *To:* [email-masked]; [email-masked]
> >     *Cc:* [email-masked]
> >     *Subject:* AW: [Dime] FW: [AAA-WG]: Policy 
> representation for AAA server
> > 
> >     Hi Salekul,
> >      
> >     conveyed from the AAA server to the AAA client? Are you 
> looking for
> >     a language to express these policies or rather for the 
> content of
> >     these policies? Do you have a specific application in 
> mind (e.g.,
> >     policies regarding charging, QoS, location information)
> >      
> >     Ciao
> >     Hannes
> >      
> > 
> >         
> --------------------------------------------------------------
> ----------
> >         *Von:* [email-masked] 
> >         *Gesendet:* Montag, 8. Mai 2006 10:10
> >         *An:* [email-masked]
> >         *Cc:* [email-masked]
> >         *Betreff:* [Dime] FW: [AAA-WG]: Policy 
> representation for AAA server
> > 
> >         Forward to the DiME WG, in case any one has 
> opinions for Diameter.
> >          
> >         John
> > 
> >             
> --------------------------------------------------------------
> ----------
> >             *From:* [email-masked]
> >             [mailto:[email-masked]] *On Behalf Of 
> *ext Salekul Islam
> >             *Sent:* 30 April, 2006 08:55
> >             *To:* [email-masked]
> >             *Cc:* Salekul Islam
> >             *Subject:* [AAA-WG]: Policy representation for 
> AAA server
> > 
> >             Hi,
> >              
> policy server in
> >             Diameter architecture. Is there any Internet 
> Draft or paper
> >             addressing the issues related to policy 
> representation for
> >             AAA server? Is there any specific direction or 
> goal of the
> >             WG regarding this issue?
> >              
> >             Any sort of information will be very helpful for me.
> >              
> >             regards,
> >              
> >             Salekul Islam
> --------------------------------------------------------------
> ----------
> >