Subject: RE: [Dime] Defining a new Application for mip6-split ?

From: "Avi Lior" <[email-masked]>
Date: Fri, 19 May 2006 17:34:56 -0400

Hi Jari,

I may have to perform Network Access Authentication and MIP access
authentication.  The Network Access Authentication server is provided by
Foobar.Inc and the MIP access authentication server is provided by
Zot.Inc.

But nevertheless, it seems there could be lots of different scenarios as
well.

We need to make sure the Diameter is used such that it does not prevent
deployement problems.  

The parameters presented in by the MIP scenarios need to be resolved
correctly and provide guidelines in the future.

To me the behavior of the two applications are different and therefore
that calls for different applications ID.  That is the intent of the
Application ID as I understand it.   

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]] 
> Sent: Friday, May 19, 2006 2:59 PM
> To: Avi Lior
> Cc: [email-masked]
> Subject: Re: [Dime] Defining a new Application for mip6-split ?
> 
> Avi Lior wrote:
> 
> >>However, it is far from clear to me why you would really 
> need to route 
> >>the authentication differently *for the same user*.
> >>    
> >>
> >
> >We want to use common user credentials.  That is a big plus.
> > 
> >  
> >
> >>Many authentication mechanisms can also have state, which 
> would imply 
> >>that at the end they need to end up in the same device 
> anyhow. Can you 
> >>expand on why you need to handle the same users in different 
> >>authentication servers?
> >>    
> >>
> >
> >See above.
> >
> >Can you please explain why we are not using Diamter 
> Application Id the 
> >way they ought to be used?
> >  
> >
> The application ID is indeed designed for routing. Not 
> questioning that. And I also agree with you about the 
> undesirability of the other options. And yes, we want common 
> user credentials. However, what I was asking about is why 
> this leads to the need to use different authentication servers.
> 
> --Jari
> 
> 

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Jari Arkko <[email-masked]>
Date: Sun, 21 May 2006 13:37:32 +0300

Avi Lior wrote:

>Zot.Inc
OK. What are the identities of provided by the client in this example?
[email-masked] and [email-masked]? Or [email-masked] for both?
If its the latter, can you explain how the credentials are managed
and what routing effect you want to provide?

>Application ID as I understand it.   
Sure. All I am saying is that there's a fine line between
a mandatory attribute in an application designed for
<condition> and the use of an optional AVP when
<condition> in a more generic application.

--Jari