Subject: [Dime] Policy based Applications and QoS Application

From: "Avi Lior" <[email-masked]>
Date: Thu, 11 May 2006 12:25:04 -0400

Hi All,
 
This email prompts me to start a discussion on Policy and QoS
Application.
 
As some of you are aware IMS Rel 7.0 has an entity called PCRF.  This
PCRF is supposed to broker per flow based policy actions between the IMS
infrastructure and the Network.  Initially this policy was QoS and in
release 7.0 it also brokers Charging Policy.  In the future it will
probably broker other per flow policy.  For example, it may instruct the
network to apply security policies to a flow or group of flows.
 
The QoS Application that is being developed by the IETF (IMO) was
targeting the Policy entity in its IMS Rel 6.0 form when it was called
the PDF instead of PCRF and when it was only serving QoS policies.  Now
in rel 7.0 the Diameter application being developed is serving both QoS
and Charging information and is based on the Diameter Credit Control
function.  
 
Also QoS policies are also delivered as part of Authentication.  So EAP
Application may be used to deliver initial QoS policies to the User
session being authenticated and authorized.
 
So I am raising the following questions:
 
1) Is there any reason to create a QoS Application in Diameter?
 
2) Should we work on a Diameter Flow-based Policy Application that is
able to deliver QoS/Charging and in the future other flow based
application?
-Should this work be done in the IETF? Do we get folks in 3GPP/3GPP2 and
WiMAX to agree to work on this within the IETF.  Or perhaps we can agree
to work on this together outside the IETF?
 
3) Perhaps we should just define QoS based attributes that can be pulled
into various future Diameter Applications.

Comments are welcome!!!

________________________________

	From: Tschofenig, Hannes [mailto:[email-masked]] 
	Sent: Monday, May 08, 2006 4:23 AM
	To: [email-masked]; [email-masked]
	Cc: [email-masked]
	Subject: AW: [Dime] FW: [AAA-WG]: Policy representation for AAA
server

	Hi Salekul, 
	 
	could you formulate your question in more detail? 
	What type of policies are you talking about? E.g., policies that
represent the business logic at a AAA server or policies that are
conveyed from the AAA server to the AAA client? Are you looking for a
language to express these policies or rather for the content of these
policies? Do you have a specific application in mind (e.g., policies
regarding charging, QoS, location information)
	 
	Ciao
	Hannes

________________________________

		Von: [email-masked]
[mailto:[email-masked]] 
		Gesendet: Montag, 8. Mai 2006 10:10
		An: [email-masked]
		Cc: [email-masked]
		Betreff: [Dime] FW: [AAA-WG]: Policy representation for
AAA server

		Forward to the DiME WG, in case any one has opinions for
Diameter.
		 
		John

________________________________

			From: [email-masked]
[mailto:[email-masked]] On Behalf Of ext Salekul Islam
			Sent: 30 April, 2006 08:55
			To: [email-masked]
			Cc: Salekul Islam
			Subject: [AAA-WG]: Policy representation for AAA
server

			Hi,
			 
			I am interested in policy representation or
policy server in Diameter architecture. Is there any Internet Draft or
paper addressing the issues related to policy representation for AAA
server? Is there any specific direction or goal of the WG regarding this
issue?
			 
			Any sort of information will be very helpful for
me.
			 
			regards,
			 
			Salekul Islam
			PhD candidate, Concordia University
			Montreal, Canada

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 29 May 2006 22:51:37 +0200

Hi Avi,

thanks for raising this topic. Please find my response below;

Avi Lior wrote:
> Hi All,
>  
> This email prompts me to start a discussion on Policy and QoS Application.
>  

I agree with you.

> 1) Is there any reason to create a QoS Application in Diameter?

I guess your question is 'Does it need to be an application' and thereby 
referring to question 3. In some sense we also discussed this question 
in context of MIPv6 Bootstrapping as well.

Are you concerned about the additional messaging or more about the 
degree of flexbility.

> able to deliver QoS/Charging and in the future other flow based application?

The last two approaches sound like interesting approaches we should 
investigate.

Ciao
Hannes

>  
>  
> Comments are welcome!!!
>  
>  
> 
>     ------------------------------------------------------------------------
>     *From:* Tschofenig, Hannes [mailto:[email-masked]]
>     *Sent:* Monday, May 08, 2006 4:23 AM
>     *To:* [email-masked]; [email-masked]
>     *Cc:* [email-masked]
>     *Subject:* AW: [Dime] FW: [AAA-WG]: Policy representation for AAA server
> 
>     Hi Salekul,
>      
>     conveyed from the AAA server to the AAA client? Are you looking for
>     a language to express these policies or rather for the content of
>     these policies? Do you have a specific application in mind (e.g.,
>     policies regarding charging, QoS, location information)
>      
>     Ciao
>     Hannes
>      
> 
>         ------------------------------------------------------------------------
>         *Von:* [email-masked] [mailto:[email-masked]]
>         *Gesendet:* Montag, 8. Mai 2006 10:10
>         *An:* [email-masked]
>         *Cc:* [email-masked]
>         *Betreff:* [Dime] FW: [AAA-WG]: Policy representation for AAA server
> 
>         Forward to the DiME WG, in case any one has opinions for Diameter.
>          
>         John
> 
>             ------------------------------------------------------------------------
>             *From:* [email-masked]
>             [mailto:[email-masked]] *On Behalf Of *ext Salekul Islam
>             *Sent:* 30 April, 2006 08:55
>             *To:* [email-masked]
>             *Cc:* Salekul Islam
>             *Subject:* [AAA-WG]: Policy representation for AAA server
> 
>             Hi,
>              
>             I am interested in policy representation or policy server in
>             Diameter architecture. Is there any Internet Draft or paper
>             addressing the issues related to policy representation for
>             AAA server? Is there any specific direction or goal of the
>             WG regarding this issue?
>              
>             Any sort of information will be very helpful for me.
>              
>             regards,
>              
>             Salekul Islam
> ------------------------------------------------------------------------
>