Subject: RE: [Dime] Defining a new Application for mip6-split ?

From: "MORAND Lionel RD-CORE-ISS" <[email-masked]>
Date: Thu, 18 May 2006 12:51:04 +0200

Hi Julien,

>From my point of view, if there is no backward incompatible change in the Diameter application itself, there is no reason to assign a new application ID.

Lionel
-----Message d'origine-----
De : Julien Bournelle [mailto:[email-masked]] 
Envoyé : jeudi 18 mai 2006 10:42
À : [email-masked]
Cc : [email-masked]
Objet : [Dime] Defining a new Application for mip6-split ?

Hi all,

 we're in the process of updating/writing the document describing use of  Diameter for the Mobile IPv6 split scenario.

 In the split scenario, the Mobile Node (MN) uses IKEv2 with the HA to  setup IPsec SAs. This exchange is also used by the HA to authenticate  the MN using EAP. The HA may rely on a AAA/EAP server for this. So we  have the following scheme:

 MN <-- IKEv2-EAP --> HA <--------> AAA

 A priori Diameter EAP (RFC 4072) can be used between HA and AAA. 

 The problem is that Diameter EAP is normally used for Network Access  authentication. 

 In our case, the AAA server must perform AAA functionality for the  Mobile IPv6 service. The AAA server must know that it has to authorize  the mip6 service and the accounting (ASR/ASA) is also for mip6 and not  for network access.

 For the above reason, it seems that we should define a new Diameter  Application. However, in the same time, the messages defined in  Diameter EAP could be reused.

 So I'd like to hear opinions concerning this issue.

 Thanks,

 - Julien B.

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Julien Bournelle <[email-masked]>
Date: Thu, 18 May 2006 11:57:40 +0200

Hi lionel,

> From my point of view, if there is no backward incompatible change in the Diameter application itself, there is no reason to assign a new application ID.

 but the problem is: how do the AAA server know that it is performing
 AAA functionalities for mip6 service and not for network access ?

 This AAA server may be used both for network access and mip6 service.

 Julien

-- 
julien.bournelle at int-evry.fr