Subject: RE: Re: [Mip6] RE: [Dime] Impact of RFC 4285 for Diameter MIP6Bootstrapping Work

From: 지정훈 <[email-masked]>
Date: Sat, 21 Oct 2006 23:24:53 +0900

Hi Julien,

Does your thought imply that the piggybacking the MIPv6 BU to the AAA messages?

-Junghoon

-----원본 메시지-----
보낸 사람: "Julien Bournelle" <[email-masked]>
보낸 날짜: 2006-10-20 오후 6:30:12
받는 사람: "Gerardo Giaretta" <[email-masked]>
참조: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
제목: Re: [Mip6] RE: [Dime] Impact of RFC 4285 for Diameter MIP6Bootstrapping Work

Hi all,

concerning support for rfc4285, I think we'll need messages to carry the BU
from the HA to the AAAH for the authentifcation. As such, a new application
may be necessary. As a consequence, the authorization and accounting part
may be handled by the same application.

This application would be similar to the RFC4004 (without FA...).

Just my 2 cents,

Julien

On 10/20/06, Gerardo Giaretta <[email-masked]> wrote:
> Hi Yoshi and Madjid,
>
> the AAA goals draft does not include any specific goal for rfc4285.
> This issue was raised in Montreal and during MIP6 re-chartering
> discussion. The outcome of the discussion was that there is no a clear
> interest now in the IETF to standardize a bootstrapping solution for
> rfc4285 and a Diameter Application that supports rfc4285. MIP6 chairs
> and Jari mentioned that they may ask for rfc4285 support if
> significant interest will be raised. Remember also that rfc4285 is
> informational and the Diameter Application will be PS: not sure how to
> this difference would be handled.
>
> Having said that, I think that the approach taken so far in the design
> of the Diameter Application is flexible enough to include rfc4285
> later without any big change: the authorization application does not
> need to be changed for rfc4285 support and we may define another
> application for authentication purposes. Therefore the
> authentication/authorization split seems a correct approach in order
> to introduce rfc4285 support later.
>
> --Gerardo
>
> On 10/19/06, Madjid Nakhjiri <[email-masked]> wrote:
> > Hi Yoshi,
> >
> > I agree, no point on insisting that solutions would support 4285, if 4285
> > requirements are not included. I can think of aspects of 4285 that can be
> > problematic, but won't mention them now, since I don't want to be accused of
> > opening the pandora's box while aaa-ha-goals is going through last call or
> > the dime docs are underway :)
> >
> > We should not make claims we cannot back up later as that might derail the
> > standardization process two years from now. As Persians say (after a lousy
> > marketing translation) "A small quarrel in the beginning better than a
> > bloody peace at the end"
> >
> >
> >
> > R,
> >
> > Madjid
> >
> >
> > -----Original Message-----
> > From: Yoshihiro Ohba [mailto:[email-masked]]
> > Sent: Thursday, October 19, 2006 1:33 PM
> > To: Madjid Nakhjiri
> > Cc: 'Gerardo Giaretta'; 'Vijay Devarapalli'; [email-masked]; [email-masked]
> > Subject: Re: [Mip6] RE: [Dime] Impact of RFC 4285 for Diameter MIP6
> > Bootstrapping Work
> >
> > Madjid,
> >
> > On Thu, Oct 19, 2006 at 01:04:04PM -0700, Madjid Nakhjiri wrote:
> > > Ok, so I see I spend a long email without reading the rest of the thread.
> > > Do we feel the AAA goal draft efficiently captures the 4285 requirements?
> > > If yes, sorry for clogging your mailboxes..
> >
> > That is my feeling and is why I had the following comment on aaa-ha-goals
> > draft:
> >
> > "
> >   YO: This document seems to assume the use of IPsec between MN and HA
> >   for securing Mobile IPv6 signaling.  But the AAA interface could
> >   also be used for RFC 4285.  So I think it might be good to mention
> >   in this section that the document may not preclude the use of
> >   alternative methods for securing Mobile IPv6 signaling between MN
> >   and HA while this document focuses on the use of IPsec between MN
> >   and HA.
> > "
> >
> > Yoshihiro Ohba
> >
> >
> > >
> > > R,
> > >
> > > Madjid
> > >
> > > -----Original Message-----
> > > From: Gerardo Giaretta [mailto:[email-masked]]
> > > Sent: Friday, October 13, 2006 12:37 AM
> > > To: Vijay Devarapalli
> > > Cc: [email-masked]; [email-masked]
> > > Subject: Re: [Dime] Impact of RFC 4285 for Diameter MIP6 Bootstrapping
> > Work
> > >
> > > > > in the DIME working group we are currently producing documents that
> > > > > relate to the backend solution of the
> > > > >
> > > > > * Integrated Scenario
> > > > >   draft-ietf-mip6-bootstrapping-integrated-dhc-01
> > > > >
> > > > > * Split Scenario
> > > > >   draft-ietf-mip6-bootstrapping-split-02
> > > > >
> > > > > Now, the question came up whether we have to consider RFC 4285
> > > > > ('Authentication Protocol for Mobile IPv6') for our work as well.
> > > >
> > > > currently it is not clear if we are going to do any
> > > > further work on RFC 4285 in the MIP6 WG. so my
> > > > suggestion is to assume only the use of IKEv2 (with
> > > > and without EAP).
> > > >
> > >
> > > Agree with Vijay, this is also the assumption for the AAA goals draft.
> > >
> > > --Gerardo
> > >
> > > > but it would be good to keep the solution flexible
> > > > so that it can be extended later for 4285 if required.
> > > >
> > > > Vijay
> > > >
> > > > _______________________________________________
> > > > DiME mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/dime
> > > >
> > >
> > > _______________________________________________
> > > DiME mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/dime
> > >
> > >
> > >
> > > _______________________________________________
> > > Mip6 mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/mip6
> > >
> >
> >
> >
>
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dime
>

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Julien Bournelle" <[email-masked]>
Date: Mon, 23 Oct 2006 13:05:39 +0200

Hi junghoon, all,

> Does your thought imply that the piggybacking the MIPv6 BU to the AAA messages?

 If the MN uses the MN-AAA Authentication option, I guess the BU may
be piggybacked.

 Julien