Subject: RE: [Dime] Address format confusion

From: "Glen Zorn \(gwz\)" <[email-masked]>
Date: Wed, 1 Nov 2006 13:21:10 -0800

Ulf Bodin <mailto:[email-masked]> supposedly scribbled on Monday,
October 30, 2006 5:37 AM:

> Hi,
> 
> We're somewhat confused about what format to use for the
> Framed-IP-Address AVP. It seems that NASREQ uses the pre-draft-v16
> (Diameter base protocol) format of the IPv4 address (i.e. four
> octets) instead of the Address format defined in RFC3588, section
> 4.3:    
> 
> Address
> The Address format is derived from the OctetString AVP Base Format.
> It is a discriminated union, representing, for example a 32-bit
> (IPv4) [IPV4] or 128-bit (IPv6) [IPV6] address, most significant
> octet first.   
> The first two octets of the Address AVP represents the AddressType,
> which contains an Address Family defined in [IANAADFAM]. The
> AddressType is used to discriminate the content and format of the
> remaining octets.   
> 
> Our question is if the pre-draft-v16 format should be still used, 

Yes.

> or if the new format in RFC3588 should be adopted 

No.

> (which should result
> in a change in RFC4005 as we understand the procedure).  

The format specified for the Framed-IP-Address AVP is the same as that
of the Framed-IP-Address RADIUS attribute, on purpose.  If you need to
send an IPv6 address, I believe that you can use the Framed-IPv6-Prefix
AVP.

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Ulf Bodin" <[email-masked]>
Date: Mon, 6 Nov 2006 08:50:52 +0100

Thanks Glen, 

I'm happy to have this sorted out as it has caused confusion in an
interoperability matter of ours. 

Best regards, 
Ulf  

-----Original Message-----
From: Glen Zorn (gwz) [mailto:[email-masked]] 
Sent: den 1 november 2006 22:21
To: Ulf Bodin; [email-masked]
Cc: Erik Lundgren
Subject: RE: [Dime] Address format confusion 

Yes.

No.