Subject: [Dime] Issue regarding diameter node behavior for same host Identity on both sides.

From: Himanshu Bahl <[email-masked]>
Date: Wed, 6 Dec 2006 17:10:15 +0530

Hi all,

Can you please clarify me on the following issue. 
Suppose we get the same host id on both sides . i.e on local node and peer 
we have host1.x.com (example). Then what kind of processing are we 
supposed to do at the nodes ?

1. Will there be election lost hence an error code of 4003 ( Election 
lost) be returned on both sides.?

2. Will there be an error returned with code 5012 (UNABLE_TO_COMPLY ) ?

3. Will the message be silently discarded with no answer messages and 
connection will be torn down ?

A fast reply will be help full.

Sincerely,
Himanshu Bahl.
Know Me 

***********************  Aricent-Private   ***********************
"DISCLAIMER: This message is proprietary to Aricent  and is intended solely for the use of 
the individual to whom it is addressed. It may contain privileged or confidential information and should not be 
circulated or used for any purpose other than for what it is intended. If you have received this message in error, 
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for 
loss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Liyaqatali <[email-masked]>
Date: Wed, 06 Dec 2006 17:30:57 +0530

Hi,

Since this is not clearly stated in the RFC, there are couple of
solutions to this problem.

-If, you have a static configuration of peers and you expect to have
connections only with the configured peers then, CEA should carry
DIAMETER_UNKNOWN_PEER as the result code.

-If, you consider this as an permanent failure and don't expect this to
happen again then, DIAMETER_UNABLE_TO_COMPLY is the most appropriate
option.

-But if you discard the CER and tear down the connection then, the
other peer may initiate the connection again later.

-Election is an option, only when both the peers have initiated a
connection towards each other.

Looking at the all the options, I would go with
DIAMETER_UNABLE_TO_COMPLY since its a permanent failure.

Regards,
Liyaqatali G Nadaf

Himanshu Bahl wrote:

Hi all,

Suppose we get the same host id on both sides .
i.e
on local node and peer we have host1.x.com (example). Then what kind of
processing are we supposed to do at the nodes ?

1. Will there be election lost hence an error code of 4003 ( Election
lost)
be returned on both sides.?

connection
will be torn down ?

Sincerely,

Himanshu Bahl.

Know
Me