Subject: [Dime] Re: Input for Diameter Test Cases

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 05 Dec 2006 10:58:46 -0500

The MultiService Forum (MSF) is working through their liaison process. 
We should have the material to you in two to three weeks.

Hannes Tschofenig wrote:
> Hi Tom,
> 
> during the DIME meeting you mentioned that you could provide us with 
> some test cases (collected from another interop event).
> 
> Ciao
> Hannes
> 

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Tschofenig, Hannes" <[email-masked]>
Date: Tue, 5 Dec 2006 17:03:23 +0100

Thanks Tom. 

We are looking forward to inspect the input. 

In the meanwhile we need to work on the test cases. Would you like to give us some feedback? Here is the current draft version: 
http://www.opendiameter.org/public/draft-fajardo-dime-interop-test-suite-02.txt 

I have created a Wiki page to collect information. 

Ciao
Hannes

---

From: Tony Zhang <[email-masked]>
Date: Wed, 06 Dec 2006 10:51:50 +0800

Hi All
       I suggest add test cases:
      (1)Use DWR/DWA detect connection status.
      (2)Routing based on longest-match-from-the-right on the realm       rather than requiring an exact match.      
      (3)For Redirect,the loop maybe happen, should test it?
      (4)Routing should test default route entry?
      (5)For connection ,should test more Negative test?like no response.no CER etc?
Thanks!
Tony

-----Original Message-----
From: Tschofenig, Hannes [mailto:[email-masked]] 
Sent: Wednesday, December 06, 2006 12:03 AM
To: Tom-PT Taylor; Hannes Tschofenig
Cc: [email-masked]
Subject: AW: [Dime] Re: Input for Diameter Test Cases

Thanks Tom. 

Ciao
Hannes

---

From: Tony Zhang <[email-masked]>
Date: Wed, 06 Dec 2006 11:10:12 +0800

Hi All

---

From: himanshu bahl <[email-masked]>
Date: Tue, 5 Dec 2006 21:18:26 -0800 (PST)

hi all,
I have asked this before also.
please clarify me on this one. suppose we get the same
host id on both sides . i.e on both peers we have
host1.x.com for example.
then what kind of processing are we supposed to do ?

1. will there be election lost hence an error code of
4003 ( Election lost) be returned on both sides.?

2. Will there be an error returned with code 5012 
(unable to comply ) ?

3. will the message be silently be discarded with no
answer messages and connection will be torn down ?

a fast reply will be help full.

Sincerely,
Himanshu.
http://thebahls.blogspot.com

--- Tony Zhang <[email-masked]> wrote:

>       (2)Routing based on
> longest-match-from-the-right on the realm      
> rather than requiring an exact match.      
> In the meanwhile we need to work on the test cases.
> Would you like to give us some feedback? Here is the
> current draft version: 
>
> 
> 
>From [email-masked] Wed Dec 06 00:18:37 2006
Date: Tue, 5 Dec 2006 21:18:26 -0800 (PST)
From: himanshu bahl <[email-masked]>
To: Tony Zhang <[email-masked]>,
	"'Tschofenig, Hannes'" <[email-masked]>,
	'Tom-PT Taylor' <[email-masked]>,
	'Hannes Tschofenig' <[email-masked]>
Cc: [email-masked]
Subject: [Dime] regarding test case in interop doc for same host on both
	sides

hi all,
I have asked this before also.
please clarify me on this one. suppose we get the same
host id on both sides . i.e on both peers we have
host1.x.com for example.
then what kind of processing are we supposed to do ?

1. will there be election lost hence an error code of
4003 ( Election lost) be returned on both sides.?

2. Will there be an error returned with code 5012 
(unable to comply ) ?

3. will the message be silently be discarded with no
answer messages and connection will be torn down ?

a fast reply will be help full.

Sincerely,
Himanshu.
http://thebahls.blogspot.com

--- Tony Zhang <[email-masked]> wrote:

>       (2)Routing based on
> longest-match-from-the-right on the realm      
> rather than requiring an exact match.      
> In the meanwhile we need to work on the test cases.
> Would you like to give us some feedback? Here is the
> current draft version: 
>
> > some test cases (collected from another interop

____________________________________________________________________________________
Any questions? Get answers on any topic at www.Answers.yahoo.com.  Try it now.

---

From: himanshu bahl <[email-masked]>
Date: Tue, 5 Dec 2006 21:18:25 -0800 (PST)

hi all,

1. will there be election l I have created a Wiki page to collect information.

---

From: himanshu bahl <[email-masked]>
Date: Tue, 5 Dec 2006 21:18:25 -0800 (PST)

hi all,

Sincerely,
Himanshu.

 

ost hence an error code of
4003 ( Election lost) be returned on both sides.?

Sincerely,
Himanshu.

---

From: Victor Fajardo <[email-masked]>
Date: Wed, 06 Dec 2006 17:45:06 -0500

Hi Tony,
>       (1)Use DWR/DWA detect connection status.

I think this is already covered in Sec 3.1.1.5

>       (4)Routing should test default route entry?

For (2) and (4) I'm not sure but I think this is an implementation 
specific functionality. If we add this as a test case and others does 
not support this then we are raising an issue that may not be an issue 
at all.

>       (5)For connection ,should test more Negative test?like no response.no CER etc?

It maybe a general statement but Sec 3.1.1 says test participants must 
conform to the peer statemachine. This includes Timeout during 
Wait-Conn-Ack. I know there is a tendency to add minute test cases into 
this document but we have to think more carefully on what we want to add 
since the document may get extremely large and therefore maybe less useful.

best regards,
victor

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 08 Dec 2006 15:08:53 +0200

Hi all,

Based on the comments received in the last IETF Dime meeting I have 
updated the draft. The latest unofficial snapshot is available at:
http://www.tschofenig.priv.at/svn/draft-ietf-dime-mip6-integrated/draft-ietf-dime-mip6-integrated-02.txt

I would appreciate feedback on the latest (unofficial) draft revision.

Cheers,
	Jouni

---

From: "Julien Bournelle" <[email-masked]>
Date: Fri, 8 Dec 2006 14:46:03 +0100

HI Jouni,

 Just a quick comment, I saw on
http://www.ietf.org/internet-drafts/draft-ietf-mip6-radius-01.txt
 that the AAA server can send the HoA info to the NAS.

 Maybe we also should add this AVP.

 what do you think ?

 Julien

---

From: Jouni Korhonen <[email-masked]>
Date: Sat, 09 Dec 2006 12:59:33 +0200

Hi Julien,

HoA was considered at some point of time. Comments back then were that 
"HoA is given by the HA and not by the AAA in the integrated
scenario" and "integrated solution I-D inherits the HoA and IKEv2 SA 
bootstrapping parts from the split solution I-D" etc. However, I assume 
there are now emerging deployment cases where it would make sense to 
return HoA also as a part of the general integrated scenario 
bootstrapping. I would add an AVP for HoA.

Cheers,
	Jouni

---

From: Victor Fajardo <[email-masked]>
Date: Tue, 12 Dec 2006 12:03:49 -0500

Hi,

Sorry for the late reply.
> answer messages and connection will be torn down ?
Obviously this scenario is a mis-configuration. Are you proposing to add 
this to the test document ?

In general, I would prefer option (3) just to maintain interoperability. 
Also, election is independent of this scenario and your implementation 
can always check for this case and revert to (3) instead of going ahead 
with the election.

regards,
victor

>>> during the DIME meeting you mentioned that you
>>>       
>> could provide us with 
>>     
>>> some test cases (collected from another interop
>>>       
>> event).
>>     
>>> Ciao
>>> Hannes
>>>
>>>

---

From: Himanshu Bahl <[email-masked]>
Date: Wed, 13 Dec 2006 01:47:02 +0530

Hi victor,

I don`t think option 3 will be such a good one. As the peer might resend 
the request in case of silent discard. 
I think the most viable solution would be either returning UNKNOW_HOST. 
UNABLE TO COMPLY also seems a good solution since the receiving node is in 
fact in really unable to process the request because the peer`s Identity 
has turned out to be same.

Regarding the test case document I think this case is already present in 
the document. draft-fajardo-dime-interop-test-suite-01 in section 3.1.1.2 
, point 3.

Sincerely,
Himanshu.
Know Me 
http://www.aricent.com

Victor Fajardo <[email-masked]> 
12/12/2006 10:33 PM

To
himanshu bahl <[email-masked]>
cc
[email-masked], "'Tschofenig, Hannes'" <[email-masked]>
Subject
Re: [Dime] regarding test case in interop doc for same host on  bothsides

Hi,

regards,
victor

***********************  Aricent-Private   ***********************
"DISCLAIMER: This message is proprietary to Aricent  and is intended solely for the use of 
the individual to whom it is addressed. It may contain privileged or confidential information and should not be 
circulated or used for any purpose other than for what it is intended. If you have received this message in error, 
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for 
loss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime