Subject: Re: [Dime] RFC3588bis Issue12

From: himanshu bahl <[email-masked]>
Date: Fri, 1 Dec 2006 08:39:46 -0800 (PST)

Hi Tolga, 
can you please specify how has the following issue
been resolved. I`m unable to locate the thread for
that.

and one more thing. 
If a redirect agent replies with the redirectHost avp
value in the DiameterIdentity format instead of
diameterURI format is the message incorrect ?

sincerely,
Himanshu.
http://thebahls.blogspot.com

--- Tolga Asveren <[email-masked]> wrote:

> >From issue tracker, Issue12:
> 
> "
> There seems to be two concepts of node identity in
> the base spec.
> 
> 1. FQDN for indexing the peer table
> 2. FQDN+port (+more) in redirect URI.
> "
> 
> AFACS, there is no problem here.The Host Identity in
> peer table is of type
> DiameterIdentity, whereas Redirect-Host AVP is of
> type DiameterURI. This
> makes sense to me, because one needs to know
> transport/port in addition to
> FQDN, to be able to establish a connection after an
> asnwer with
> DIAMETER_REDIRECT_INDICATION result code. If one
> wants first to perform a
> check in peer table based on Redirect-Host AVP
> value, this is also possible
> by extracting FQDN portion of it.
> 
> Should this issue be closed with no action or am I
> missing something?
> 
>     Thanks,
>     Tolga
> 
> 
> _______________________________________________
> DiME mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dime
> 

____________________________________________________________________________________
Do you Yahoo!?
Everyone is raving about the all-new Yahoo! Mail beta.
http://new.mail.yahoo.com

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 1 Dec 2006 11:49:26 -0500

Hi Himanshu,

> -----Original Message-----
> From: himanshu bahl [mailto:[email-masked]]
> Sent: Friday, December 01, 2006 11:40 AM
> To: Tolga Asveren; [email-masked]
> Subject: Re: [Dime] RFC3588bis Issue12
>
>
> Hi Tolga,
[TOLGA]I guess the agreement was that there is no real issue here. The
Redirect-Host AVP is of type DiameterURI, not of type DiameterIdentity. So,
there is no conflict in the definition of types.
> diameterURI format is the message incorrect ?
[TOLGA]I guess DiameterURI includes DiemterIdentity because it has a FQDN
portion. So, I would think a Redirect-Host AVP with only a FQDN is valid.

---

From: Timothy Smith <[email-masked]>
Date: Fri, 1 Dec 2006 13:11:19 -0500

Hi Tolga,

My feeling is that if it is to be a URI format, then it must have the URI 
prefix as defined in the RFC:

      The DiameterURI MUST follow the Uniform Resource Identifiers (URI)
      syntax [URI] rules specified below:

      "aaa://" FQDN [ port ] [ transport ] [ protocol ]

                      ; No transport security

      "aaas://" FQDN [ port ] [ transport ] [ protocol ]

                      ; Transport security used

      FQDN               = Fully Qualified Host Name

      port               = ":" 1*DIGIT

                      ; One of the ports used to listen for
                      ; incoming connections.
                      ; If absent,
                      ; the default Diameter port (3868) is
                      ; assumed.

      transport          = ";transport=" transport-protocol

                      ; One of the transports used to listen
                      ; for incoming connections.  If absent,
                      ; the default SCTP [SCTP] protocol is
                      ; assumed.  UDP MUST NOT be used when
                      ; the aaa-protocol field is set to
                      ; diameter.

      transport-protocol = ( "tcp" / "sctp" / "udp" )

      protocol           = ";protocol=" aaa-protocol

                      ; If absent, the default AAA protocol
                      ; is diameter.

      aaa-protocol       = ( "diameter" / "radius" / "tacacs+" )

      The following are examples of valid Diameter host identities:

      aaa://host.example.com;transport=tcp
      aaa://host.example.com:6666;transport=tcp
      aaa://host.example.com;protocol=diameter
      aaa://host.example.com:6666;protocol=diameter
      aaa://host.example.com:6666;transport=tcp;protocol=diameter
      aaa://host.example.com:1813;transport=udp;protocol=radius

A Redirect-Host AVPI with a value of simply "host.example.com" does not 
seem to be valid...

Best Regards,
Timothy Smith

[email-masked]
(919) 254-4723

"Tolga Asveren" <[email-masked]> 
12/01/2006 11:49 AM

To
<[email-masked]>
cc

Subject
RE: [Dime] RFC3588bis Issue12

Hi Himanshu,

[TOLGA]I guess the agreement was that there is no real issue here. The
Redirect-Host AVP is of type DiameterURI, not of type DiameterIdentity. 
So,
there is no conflict in the definition of types.

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 1 Dec 2006 13:20:27 -0500

Hi Tim,

Yes you are right. aaa(s):// must be there.

   Thanks,
   Tolga
-----Original Message-----
From: Timothy Smith [mailto:[email-masked]]
Sent: Friday, December 01, 2006 1:11 PM
To: Tolga Asveren
Cc: [email-masked]
Subject: RE: [Dime] RFC3588bis Issue12

Hi Tolga,

                      ; No transport security

      port               = ":" 1*DIGIT

A Redirect-Host AVPI with a value of simply "host.example.com" does not seem
to be valid...

Best Regards,
Timothy Smith

[email-masked]
(919) 254-4723

"Tolga Asveren" <[email-masked]>
12/01/2006 11:49 AM To<[email-masked]>
cc
SubjectRE: [Dime] RFC3588bis Issue12

Hi Himanshu,

---

From: himanshu bahl <[email-masked]>
Date: Tue, 5 Dec 2006 01:22:29 -0800 (PST)

hi all,

please clerify me on this one. suppose we get the same
host id on both sides . i.e on both peers we have
host1.x.com for example.
then what kind of processing are we supposed to do ?

1. will there be election lost hence an error code of
4003 ( Election lost) be returned on both sides.?

2. Will there be an error returned with code 5012 (
unable to comply ) ?

3. will the message be silently be discarded with no
answer messages and connection will be torn down ?

a fast reply will be helpfull.

Sincerely,
Himanshu.

____________________________________________________________________________________
Have a burning question?  
Go to www.Answers.yahoo.com and get answers from real people who know.