Subject: [Dime] Diameter Auditing & ETSI TISPAN

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 06 Dec 2006 11:43:47 +0100

Hi Ulf,
Hi Avri,

what is the status of the liaison between ETSI TISPAN and the IETF DIME 
working group regarding the Diameter Auditing work?

Ciao
Hannes & John

PS: We encourage you to continue your work on the Diameter Auditing 
requirements draft and also to start your work on the solution document.

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Ulf Bodin" <[email-masked]>
Date: Wed, 6 Dec 2006 12:02:32 +0100

Hi Hannes, 

I've submitted a draft LS for the meeting next week jointly signed by
myself, Bruno Chatras (FT) and Steve Norries (BT). Hence the decition
will be taken next week on sending the LS to IETF. 

Best regards, 
Ulf 

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]] 
Sent: den 6 december 2006 11:44
To: Ulf Bodin; [email-masked]
Cc: [email-masked]
Subject: Diameter Auditing & ETSI TISPAN

Hi Ulf,
Hi Avri,

Ciao
Hannes & John

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 06 Dec 2006 12:33:08 +0100

Hi Ulf,

thanks for the quick response. Please keep us up-to-date with regard to 
the outcome of the discussion next week.

Ciao
Hannes

---

From: "Ulf Bodin" <[email-masked]>
Date: Wed, 6 Dec 2006 16:17:32 +0100

Absolutely. 
Rgs Ulf  

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]] 
Sent: den 6 december 2006 12:33
To: Ulf Bodin
Cc: [email-masked]; [email-masked]
Subject: Re: Diameter Auditing & ETSI TISPAN

Hi Ulf,

Ciao
Hannes

Ulf Bodin wrote:
> what is the status of the liaison between ETSI TISPAN and the IETF 
> DIME working group regarding the Diameter Auditing work?
>
> Ciao
> Hannes & John
>

---

From: "Ulf Bodin" <[email-masked]>
Date: Wed, 13 Dec 2006 15:04:27 +0100

Hi Hannes, 

Just a quick update on the LS from ETSI to the IETF. WG3 of ETSI TISPAN
has now agreed to send an LS and the draft LS will hence be forwarded to
the TC of TISPAN for the final decition (at least this is how I
understand the procedure :-). 

Best regards, 
Ulf 

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]] 
Sent: den 6 december 2006 12:33
To: Ulf Bodin
Cc: [email-masked]; [email-masked]
Subject: Re: Diameter Auditing & ETSI TISPAN

Hi Ulf,

Ciao
Hannes

---

From: Tina TSOU <[email-masked]>
Date: Wed, 13 Dec 2006 19:48:21 +0100

And ETSI TISPAN also pointed out that there are no requirements about audit 
written in the active standard documents or drafts.
People proposed, but they were removed, this is why there are no 
requirements about audit written in the active standard documents or drafts.

B. R.
Tina

----- Original Message ----- 
From: "Ulf Bodin" <[email-masked]>
To: "Hannes Tschofenig" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Wednesday, December 13, 2006 3:04 PM
Subject: [Dime] RE: Diameter Auditing & ETSI TISPAN

Hi Hannes,

Best regards,
Ulf

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]]
Sent: den 6 december 2006 12:33
To: Ulf Bodin
Cc: [email-masked]; [email-masked]
Subject: Re: Diameter Auditing & ETSI TISPAN

Hi Ulf,

Ciao
Hannes

---

From: "Ulf Bodin" <[email-masked]>
Date: Wed, 13 Dec 2006 22:44:35 +0100

Yes, that's absolutely right. The reason for removing the requirements
was that the protocol selected for the reference points in questions
(i.e. DIAMETER) doesn't (yet) support auditing. Hence, the requirements
on auditing were removed since they were not possible to meet. We hope
that by having a mechnism for auditing defined by the IETF the deletion
of the auditing requirements can be reconsidered by ETSI TISPAN for
coming releases. 

Best regards, 
Ulf 

-----Original Message-----
From: Tina TSOU [mailto:[email-masked]] 
Sent: den 13 december 2006 19:48
To: Hannes Tschofenig; Ulf Bodin
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Dime] RE: Diameter Auditing & ETSI TISPAN

And ETSI TISPAN also pointed out that there are no requirements about
audit written in the active standard documents or drafts.
People proposed, but they were removed, this is why there are no
requirements about audit written in the active standard documents or
drafts.

B. R.
Tina

----- Original Message -----
From: "Ulf Bodin" <[email-masked]>
To: "Hannes Tschofenig" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Wednesday, December 13, 2006 3:04 PM
Subject: [Dime] RE: Diameter Auditing & ETSI TISPAN

Hi Hannes,

Best regards,
Ulf

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]]
Sent: den 6 december 2006 12:33
To: Ulf Bodin
Cc: [email-masked]; [email-masked]
Subject: Re: Diameter Auditing & ETSI TISPAN

Hi Ulf,

Ciao
Hannes

---

From: <[email-masked]>
Date: Wed, 13 Dec 2006 23:49:39 +0200

Hi Ulf,

That is good if we can have a short requirements document
for auditing.  We can review that on the mailing list.  Is
it possible for you to discuss this with TISPAN?

John 

>From: ext Ulf Bodin [mailto:[email-masked]] 
>Sent: 13 December, 2006 13:45
>To: Tina TSOU; Hannes Tschofenig
>Cc: [email-masked]; [email-masked]; [email-masked]
>Subject: RE: [Dime] RE: Diameter Auditing & ETSI TISPAN
>
>Yes, that's absolutely right. The reason for removing the 
>requirements was that the protocol selected for the reference 
>points in questions (i.e. DIAMETER) doesn't (yet) support 
>auditing. Hence, the requirements on auditing were removed 
>since they were not possible to meet. We hope that by having a 
>mechnism for auditing defined by the IETF the deletion of the 
>auditing requirements can be reconsidered by ETSI TISPAN for 
>coming releases. 
>
>Best regards,
>Ulf 
>
>And ETSI TISPAN also pointed out that there are no 
>People proposed, but they were removed, this is why there are 
>no requirements about audit written in the active standard 
>documents or drafts.
>
>B. R.
>Tina
>
>Just a quick update on the LS from ETSI to the IETF. WG3 of 
>ETSI TISPAN has now agreed to send an LS and the draft LS will 
>hence be forwarded to the TC of TISPAN for the final decition 
>(at least this is how I understand the procedure :-).
>
>Best regards,
>Ulf
>
>thanks for the quick response. Please keep us up-to-date with 
>regard to the outcome of the discussion next week.
>
>Ciao
>Hannes
>
>Ulf Bodin wrote:
>> Hi Hannes,
>>

---

From: "Ulf Bodin" <[email-masked]>
Date: Wed, 13 Dec 2006 23:03:33 +0100

Hi John, 

Actually draft-bodin-dime-auditing-reqs-01.txt is exacly this document.
It is written by the authors with the intent of reflecting needs related
to coming releases of the ETSI TISPAN architecture (and hopefully
similar architectures as those defined by 3GPP and ITU-T). This IETF
draft was referred to when discussing the LS today and the requirements
listed therein ware considered useful from an ETSI TISPAN perspective. 

The intention is further to submitt contributions to ETSI TISPAN aiming
at again include sufficient requirements on auditing into the release 2
of the ETSI TISPAN NGN architecture (and releases beyond release 2).
Thereby auditing will be discussed at coming ETSI TISPAN meetings. 

Best regards, 
Ulf 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: den 13 december 2006 22:50
To: Ulf Bodin; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Dime] RE: Diameter Auditing & ETSI TISPAN

Hi Ulf,

That is good if we can have a short requirements document for auditing.
We can review that on the mailing list.  Is it possible for you to
discuss this with TISPAN?

John 

>has now agreed to send an LS and the draft LS will hence be forwarded 
>to the TC of TISPAN for the final decition (at least this is how I

---

From: Tina TSOU <[email-masked]>
Date: Thu, 14 Dec 2006 11:52:47 +0100

ITU-T has audit mechanism in Q.3301 Diameter-based Rs interface protocol 
(Tom is the editor), not extending Diameter base protocol.
The audit requirements in ITU-T Y.2111 (the architecture for Q.3301 and 
other Q.rcp series Recommendations (ITU-T standards)) are:
Synchronization and audit: The Rs reference point shall provide the 
capability to support synchronization and audit of the resource control 
session status in support of recovery and operational information statistics 
and auditing.

B. R.
Tina

----- Original Message ----- 
From: "Ulf Bodin" <[email-masked]>
To: <[email-masked]>; <[email-masked]>; 
<[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Wednesday, December 13, 2006 11:03 PM
Subject: RE: [Dime] RE: Diameter Auditing & ETSI TISPAN

Hi John,

Best regards,
Ulf

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: den 13 december 2006 22:50
To: Ulf Bodin; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Dime] RE: Diameter Auditing & ETSI TISPAN

Hi Ulf,

John

---

From: "Ulf Bodin" <[email-masked]>
Date: Thu, 14 Dec 2006 12:23:30 +0100

To my undertanding the audit mechanism in Q.3301 of ITU-T defined
although a quite general requirement a limited mechanism not fully
meeting the requirements of draft-bodin-dime-auditing-reqs-01.txt. In my
view there is an oppurtunity of the IETF DIME WG to accept developing a
specification on DIAMETER auditing that meet all requirements deemed
desired, or to advice ETSI TISPAN to develop their own extensions to the
DIAMETER base protocol. Peronally I beleve the latter alternative to be
unfortunate since we then face the risk of ending up with a number of
different extensions whereof each one solves a limited auditing problem
related to a specific usage of the DIAMETER protocol. 

Best regards, 
Ulf 

-----Original Message-----
From: Tina TSOU [mailto:[email-masked]] 
Sent: den 14 december 2006 11:53
To: [email-masked]; [email-masked]; Ulf Bodin
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Dime] RE: Diameter Auditing & ETSI TISPAN

session status in support of recovery and operational information
statistics and auditing.

B. R.
Tina

----- Original Message -----
From: "Ulf Bodin" <[email-masked]>
To: <[email-masked]>; <[email-masked]>;

Hi John,

Best regards,
Ulf

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: den 13 december 2006 22:50
To: Ulf Bodin; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Dime] RE: Diameter Auditing & ETSI TISPAN

Hi Ulf,

John

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 14 Dec 2006 13:40:00 +0100

Good to see that ITU-T is also interested in this work.

I am sure Ulf, Avri and the other draft authors are going to consider 
additional requirements.

Ciao
Hannes

Tina TSOU wrote:
> ITU-T has audit mechanism in Q.3301 Diameter-based Rs interface 
> protocol (Tom is the editor), not extending Diameter base protocol.
> The audit requirements in ITU-T Y.2111 (the architecture for Q.3301 
> and other Q.rcp series Recommendations (ITU-T standards)) are:
> capability to support synchronization and audit of the resource 
> control session status in support of recovery and operational 
> information statistics and auditing.
>
>
> B. R.
> Tina
>
> ----- Original Message ----- From: "Ulf Bodin" <[email-masked]>