Subject: [Dime] Missing AVP Code and definition

From: "Nanaparthi" <[email-masked]>
Date: Fri, 29 Dec 2006 14:54:16 +0530

Hi All,

In RFC 4005 (NASREQ) there are some AVPs which have reference in the specification but are not declared formally with AVP code. 

Following are the AVP's which given in Message format of RAR( Re-Auth-Answer) & ASA (Abort-Session-Answer). But no where description included.

1. Redirected-Host 
2. Redirected-Host-Usage 
3. Redirected-Host-Cache-Time 
4. Redirected-Max-Cache-Time

Are they defined in some other RFC or do we have to use internally defined values for them?

Thanks in Advance.

Regards, 
Naresh Babu A. 
Software Engineer 
IntelliNet Technologies India Pvt. Ltd.
413/4 Oxford Towers, 139 Airport Road,
Bangalore - 560 017
Off-Phone.....: + 91 80 51256018 Ext: 2304
Off - Fax.......: + 91 80 25202947
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 29 Dec 2006 04:25:16 -0500

They come from RFC 3588, along with the commands themselves. I tried to 
verify on this list that these AVPs are mutually exclusive to those that 
would be returned in an actual answer a few weeks back, but got no response.

Nanaparthi wrote:
> ------------------------------------------------------------------------
>

---

From: "Nanaparthi" <[email-masked]>
Date: Fri, 29 Dec 2006 15:19:06 +0530

Hi,

I verified RFC 3588. But I was unable to find the those required AVPs .

Thanks,
Naresh Babu A.

----- Original Message ----- 
From: "Tom-PT Taylor" <[email-masked]>
To: "Nanaparthi" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Friday, December 29, 2006 2:55 PM
Subject: Re: [Dime] Missing AVP Code and definition

>> In RFC 4005 (NASREQ) there are some AVPs which have reference in the 
>> specification but are not declared formally with AVP code. Following are 
>> the AVP's which given in Message format of RAR( Re-Auth-Answer) & ASA 
>> (Abort-Session-Answer). But no where description included.
>>
>> 1. Redirected-Host 2. Redirected-Host-Usage 3. Redirected-Host-Cache-Time 
>> Regards, Naresh Babu A. Software Engineer IntelliNet Technologies India 
>> Pvt. Ltd.

---

From: Alexis Hildebrandt <[email-masked]>
Date: Fri, 29 Dec 2006 12:20:47 +0100

Hello,
I assume that this might just be a typographical error where
'Redirected' was written instead of 'Redirect' and that therefore:

1. Redirected-Host AVP is likely to actually be a reference to
   Redirect-Host AVP, which is defined in sect. 6.12 of RFC 3588

2. Redirected-Host-Usage AVP rather refers to the Redirect-Host-Usage
   AVP, which is specified in sect 6.13 of RFC 3588

3. Redirected-Host-Cache-Time again should probably read
   Redirect-Host-Cache-Time, which was also an error in RFC 3588 and
   in fact is Redirect-Max-Cache-Time.
   For details please search for the errata of RFC 3588 at:
   http://www.rfc-editor.org/errata.html

4. And Redirected-Max-Cache-Time AVP was presumably meant to be
   Redirect-Max-Cache-Time AVP, that is described in sect. 6.14
   of RFC 3588

Maybe one of the authors of RFC 4005 can confirm this.

Regards,
A. Hildebrandt
-- 
Alexis Hildebrandt, Software Development
Netzwert AG, An den Treptowers 1, 12435 Berlin, Germany
Voice: +49.30.590080-1172, Fax: +49.30.5900800-700
http://www.netzwert.ag