Subject: [Dime] Query regarding Diameter agents

From: "Balamurugan T - TLS, Chennai." <[email-masked]>
Date: Fri, 22 Dec 2006 10:03:26 +0530

Hi Guys,

     I need a claification regarding diameter agent. IMS architecture has
comonents like AS,HSS,S-CSCF ,I-CSCF and P-CSCF.
     In IMS components the S-CSCF or P-CSCF can use the diameter clients for
their communication. What is the purpose of diamter 
     agents  in IMS architecture and Which are components that act as
diameter agents?

     Thanks in Advance.

Thanks,
Bala

DISCLAIMER 
The contents of this e-mail and any attachment(s) are confidential and intended for the 

named recipient(s) only. It shall not attach any liability on the originator or HCL or its 

affiliates. Any views or opinions presented in this email are solely those of the author and 

may not necessarily reflect the opinions of HCL or its affiliates. Any form of reproduction, 

dissemination, copying, disclosure, modification, distribution and / or publication of this 

message without the prior written consent of the author of this e-mail is strictly 

prohibited. If you have received this email in error please delete it and notify the sender 

immediately. Before opening any mail and attachments please check them for viruses and 

defect.

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Marco Carusio" <[email-masked]>
Date: Fri, 22 Dec 2006 09:40:48 +0100

Hi Bala,

the diameter inside the IMS architecture will have many purposes.

As far as I know the Diameter is used inside I-CSCF and S-CSCF for
accounting aims and it is, thus, interfaced to the Charging system.

Concerning the P-CSCF the diameter is used to establish communication with
the PDF element in the IMS architecture. The Diameter is a protocol
basically designed for authorization, so it is used in this scope to
"authorize" the P-CSCF to use the resources, and in this authorization
process it is the PDF to work as the "authentication Server": it checks
whether the P-CSCF is authorized to use the available resources.

Obviously Diameter has also many other purposes in the IMS architecture
since its many reliable features.

Regards,
Marco.

> -----Messaggio originale-----
> Da: Balamurugan T - TLS, Chennai. [mailto:[email-masked]]
> Inviato: venerdì 22 dicembre 2006 5.33
> A: [email-masked]
> Oggetto: [Dime] Query regarding Diameter agents
> 
> Hi Guys,
>