Subject: [Dime] Clarification needs on transaction state

From: "Balamurugan T - TLS, Chennai." <[email-masked]>
Date: Fri, 22 Dec 2006 13:47:34 +0530

Hi folks ,

   1.Section 3.(End-to-End Identifier ) in RFC says "Duplicate requests
SHOULD cause the same answer to be transmitted (modulo the hop-by-hop
Identifier field and any routing AVPs that may be present), and MUST NOT
affect any state that was set when the original request was processed.  The
identifier MUST remain locally unique for a period of at least 4 minutes,
even across reboots."
   a. For what purpose, we have to keep the same value after reboots also.?

   2. According to RFC,only  the outgoing requests should be stored in the
pending queue . The request has to be removed from the queue on arrival of
corresponding answer message. 
    a. Is it necessary to maintain the list of incoming requests in the
transaction level?.
    b. If so, How long we need to maintain them?. 
    "If the incoming requests are not available in transaction state, How to
identify duplicate requests?" .It could be helpful if any of you explain
the transaction state  maintenance.
Thanks  in advance,
Bala

DISCLAIMER 
The contents of this e-mail and any attachment(s) are confidential and intended for the 

named recipient(s) only. It shall not attach any liability on the originator or HCL or its 

affiliates. Any views or opinions presented in this email are solely those of the author and 

may not necessarily reflect the opinions of HCL or its affiliates. Any form of reproduction, 

dissemination, copying, disclosure, modification, distribution and / or publication of this 

message without the prior written consent of the author of this e-mail is strictly 

prohibited. If you have received this email in error please delete it and notify the sender 

immediately. Before opening any mail and attachments please check them for viruses and 

defect.

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 22 Dec 2006 10:23:16 -0500

Hi Bala,

> -----Original Message-----
> From: Balamurugan T - TLS, Chennai. [mailto:[email-masked]]
> Sent: Friday, December 22, 2006 3:18 AM
> To: [email-masked]
> Subject: [Dime] Clarification needs on transaction state
>
>
>
> Hi folks ,
>
[TOLGA]I guess you are asking why the value MUST be locally unique even
after a reboot for a period of 4 minutes (?). This is to prevent false
duplicate detections. Otherwise a message sent after the reboot could have
the same E2E-Id with a request sent before reboot, even if they are actaully
different messages.
>     a. Is it necessary to maintain the list of incoming requests in the
[TOLGA]Probably it depends on implementation where to keep them, but
information  should be stored somewhere on the receiving node to perform
duplicate detection.
>     b. If so, How long we need to maintain them?.
[TOLGA]This is currently not specified. 4 minutes mentioned for the
uniqueness of E2E-Id could be used as a guideline. It is important to
synchronize the uniqueness period honored when assigning E2E-Ids and how
long the requests are kept for duplicate detection. Otherwise false
duplicate detections may occur or some actual duplicate requests may not
have been identified as duplicates.