Subject: [Dime] RE: Reg. Failed Avp in ACA Msg.

From: "Arun Santhanam, TLS-Chennai" <[email-masked]>
Date: Mon, 3 Sep 2007 20:22:04 +0530

Hi Victor,
        I was just going through ACA section in 3588-bis-06 in
http://www.ietf.org/internet-drafts/draft-ietf-dime-rfc3588bis-06.txt
<http://www.ietf.org/internet-drafts/draft-ietf-dime-rfc3588bis-06..txt>

          The following are some of my suggestions:
        Suggestion 1) 
                     I think we can include Failed-Avp for ACA section,
just as we have for rest of the command code. This will help to report
errors of type 
                     DAMETER_INVALID_AVP_VALUE, DIAMETER_MISSING_AVP
....& so on
 
          Suggestion 2)
                    Section 6.9. Acct-Application-Id AVP definition says
that the Avp must be present in all the Accounting Messages 
          Then we can change the present grammar from
[Acct-Application-Id] to {Acct-Application-Id} for ACR and ACA command
code.

Thanks & Regards

Arun Santhanam

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have 
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Victor Fajardo <[email-masked]>
Date: Thu, 06 Sep 2007 21:18:13 -0400

Hi Arun,

Sorry for the late reply.

>                      I think we can include Failed-Avp for ACA section, just as we have for rest of the command code. This will help to report errors of type 
>                      DAMETER_INVALID_AVP_VALUE, DIAMETER_MISSING_AVP …& so on

We should add optional Error-Message and Failed-AVP to ACA.

>  
>           Suggestion 2)
>                     Section 6.9. Acct-Application-Id AVP definition says that the Avp must be present in all the Accounting Messages 
>           Then we can change the present grammar from [Acct-Application-Id] to {Acct-Application-Id} for ACR and ACA command code.

I'm guessing that this AVP is optional because it is present either as 
part of the Vendor-Specific-Application-Id or a 'standalone' AVP. And 
only one of them can be present at a time. (See 9.7.1).

regards,
victor

---

From: "Arun Santhanam, TLS-Chennai" <[email-masked]>
Date: Fri, 7 Sep 2007 10:08:16 +0530

Hi Victor,
     Thanks for the response.
Regards
-Arun

-----Original Message-----
From: Victor Fajardo [mailto:[email-masked]] 
Sent: Friday, September 07, 2007 6:48 AM
To: Arun Santhanam, TLS-Chennai
Cc: [email-masked]
Subject: Re: Reg. Failed Avp in ACA Msg.

Hi Arun,

>                      I think we can include Failed-Avp for ACA
section, just as we have for rest of the command code. This will help to
report errors of type 
....& so on

>  
>           Suggestion 2)
>                     Section 6.9. Acct-Application-Id AVP definition
says that the Avp must be present in all the Accounting Messages 

regards,
victor

DISCLAIMER:

---

From: "Arun Santhanam, TLS-Chennai" <[email-masked]>
Date: Fri, 7 Sep 2007 18:46:15 +0530

Hi victor,
         The following are some of my suggestion w.r.t to the draft
http://www.ietf.org/internet-drafts/draft-ietf-dime-rfc3588bis-06.txt

 Suggestion 3)     Redirect-Host can be added to the ACA message
inclusion of this will really help the accounting messages to flow
through redirect agents. Since the relay and redirect are Protocol
Transparent they will be supporting Accounting and all other Diameter
Applications. 
(Let me know your suggestion)

 Suggestion 4)    Section "10.2.  Accounting AVP Table" I find that
Error-Reporting-Host is having "0+" for ACA message .I think It should
be "0-1" (Correct me if I'm wrong).

Thx
-Arun

-----Original Message-----
From: Victor Fajardo [mailto:[email-masked]] 
Sent: Friday, September 07, 2007 6:48 AM
To: Arun Santhanam, TLS-Chennai
Cc: [email-masked]
Subject: Re: Reg. Failed Avp in ACA Msg.

Hi Arun,

....& so on

regards,
victor

DISCLAIMER: