Subject: [Dime] Re: Reg. Diameter Path Authorization

From: Victor Fajardo <[email-masked]>
Date: Sat, 01 Sep 2007 10:42:34 -0400

Sorry for the late response. Comments line:

> …
>    Similarly, the local Diameter agent, on receiving a Diameter response
>    authorizing a session, MUST check the Route-Record AVPs to make sure
>    that the route traversed by the response is acceptable.  At each
>    step, forwarding of an authorization response is considered evidence
>    of a willingness to take on financial risk relative to the session.
>    A local realm may wish to limit this exposure, for example, by
>  
>  
> The RFC says Route-Record AVP can be “0” for all response message except ACA in section 
> “10.1.  Base Protocol Command AVP Table” 

I think your right. There's something not clear with the diameter path 
authorization. As I understand it, that section is trying to co-relate 
accounting request with authorization responses. And somehow, its 
implying the use of route record to do the co-relation without 
specifying any semantics. My preference would be to remove the 1st 
sentence of this paragraph and update the talbe in 10.1 so that ACA will 
have "0" in the route record. I don't think this will break any 
implementation since even the ABNF of ACA does not enumerate 
route-record. A diameter node wishing to co-relation of authorization 
responses with forwarding can still do so based on session ids and other 
diameter application layer information.

regards,
victor

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "Arun Santhanam, TLS-Chennai" <[email-masked]>
Date: Sat, 1 Sep 2007 20:26:39 +0530

Hi Victor,
     Thanks for the response.
Regards
-Arun

-----Original Message-----
From: Victor Fajardo [mailto:[email-masked]] 
Sent: Saturday, September 01, 2007 8:13 PM
To: Arun Santhanam, TLS-Chennai
Cc: [email-masked]
Subject: Re: Reg. Diameter Path Authorization

Sorry for the late response. Comments line:

> ...
> The RFC says Route-Record AVP can be "0" for all response message
except ACA in section 
> "10.1.  Base Protocol Command AVP Table" 

regards,
victor

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have 
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------