Subject: [Dime] Clarification on Credit Control Server FSM

From: "Balamurugan T, TLS-Chennai" <[email-masked]>
Date: Tue, 27 Nov 2007 13:14:45 +0530

Hi All,

    I need some clarification regarding the Credit control server FSM.
In RFC 4006, the session based CC client receives RAR received event in
"CLIENT, SESSION BASED for intermediate and final interrogations FSM".

    But in CC Server FSM , there is no state record to send RAR request
.. Can anyone explain the complete flow   For Re-Auth.

Thanks in Advance,
Bala

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: Preeti Shandilya <[email-masked]>
Date: Thu, 29 Nov 2007 15:26:26 +0530

Hi !

Server can send the RAR message to client when the session is in open 
state. A credit control client that receives an RAR message with 
Session-Id equal to a currently active credit-control session MUST 
acknowledge the request by sending the Re-Auth-Answer (RAA) message and 
MUST initiate the credit re-authorization toward the server by sending a 
Credit-Control-Request message with the CC-Request-Type AVP set to the 
value UPDATE_REQUEST. The Result-Code 2002 (DIAMETER_LIMITED_SUCCESS) 
SHOULD be used in the RAA message to indicate that an additional message 
(i.e., CCR message  with the value UPDATE_REQUEST) is required to complete 
the procedure.

This is captured in the RFC but same is not present in the server FSM. 

Regards
Preeti

"Balamurugan T, TLS-Chennai" <[email-masked]> 
11/27/2007 01:14 PM

To
<[email-masked]>
cc

Subject
[Dime] Clarification on Credit Control Server FSM

Hi All,
    I need some clarification regarding the Credit control server FSM. In 
RFC 4006, the session based CC client receives RAR received event in 
?CLIENT, SESSION BASED for intermediate and final interrogations FSM?.
    But in CC Server FSM , there is no state record to send RAR request .. 
Can anyone explain the complete flow   For Re-Auth.
Thanks in Advance,
Bala

DISCLAIMER:

The contents of this e-mail and any attachment(s) are confidential and 
intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its 
affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect 
the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, 
modification, distribution and / or publication of 
this message without the prior written consent of the author of this 
e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender 
immediately. Before opening any mail and 
attachments please check them for viruses and defect.

***********************  Aricent-Restricted   ***********************

***********************  Aricent-Restricted   ***********************
"DISCLAIMER: This message is proprietary to Aricent  and is intended solely for the use of 
the individual to whom it is addressed. It may contain privileged or confidential information and should not be 
circulated or used for any purpose other than for what it is intended. If you have received this message in error, 
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for 
loss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime