Subject: [Dime] Regarding float type AVPs

From: "Harsha" <[email-masked]>
Date: Thu, 15 Nov 2007 22:30:33 +0530

Hello All

     As per RFC 3588 float AVP type (float32 and float64)should be
represented in IEEE Single-Precision 32 bit or IEEE Double-precision 64 bit
formats,

     but it is not clear whether it should be normalized or not, is it not
required?

     Also the RFC tells that float should be sent out in network byte order,
but as far as I know little-endian and big-endian rules will not strictly
apply to

     floats, will it not cause any problems?(Please refer to "Floating-point
and endianness" in http://en.wikipedia.org/wiki/Endianness) 

      I referred to opendiameter to see a reference implementation but float
AVP type is not implemented there.

Regards,

Harsha 

_______________________________________________
DiME mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dime

---

From: "David Frascone" <[email-masked]>
Date: Thu, 15 Nov 2007 18:50:54 -0500

I agree that the text needs to be cleaned up.  Can you provide some less
ambiguous text?

-Dave

On Nov 15, 2007 12:00 PM, Harsha <[email-masked]> wrote:

>      Also the RFC tells that float should be sent out in network byte
> order, but as far as I know little-endian and big-endian rules will not
> strictly apply to
>
>      floats, will it not cause any problems?(Please refer to
> "Floating-point and endianness" in http://en.wikipedia.org/wiki/Endianness)
>
>
>
>
>       I referred to opendiameter to see a reference implementation but
> float AVP type is not implemented there.
>
>
>
> Regards,
>
> Harsha
>
>
>

-- 
David Frascone

Oxymoron: Safe Sex.

---

From: "Harsha" <[email-masked]>
Date: Fri, 16 Nov 2007 20:12:09 +0530

Hi

   Sorry for the confusion, I think it is not needed.  IEEE 754 is clear.

Regards,

Harsha

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of David
Frascone
Sent: Friday, November 16, 2007 5:21 AM
To: Harsha
Cc: [email-masked]
Subject: Re: [Dime] Regarding float type AVPs

-Dave

On Nov 15, 2007 12:00 PM, Harsha <[email-masked]
<mailto:[email-masked]> > wrote:

Hello All

Regards,

Harsha 

-- 
David Frascone

Oxymoron: Safe Sex.